Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

I'm stumped. '95 EJ22 won't start


  • Please log in to reply
9 replies to this topic

#1 Numbchux

Numbchux

    EJ conversion addict

  • Members
  • 5,991 posts
  • Duluth, MN

Posted 12 October 2009 - 08:39 PM

a local guy here in Duluth. '95 Legacy LS. EJ22, OBD II.

his description of the initial incident: "I just pulled out of my parking spot when I hit the gas and the car chugged a bit (almost died). Immediately I put it in reverse and backed up were it continued to run really rough. I hit the gas one last time to rev it up and it died. "


we spent a couple hours tinkering with it tonight. I'm stuck....so I present our findings to the committee.......hopefully someone else here can get us pointed in the right direction.


It cranks over very unevenly...like it doesn't have compression on all cylinders. sounds like an EA82 subaru with a broken driver's side t-belt while cranking.

we pulled the end tbelt covers off. the belt looks to be in good shape, and timing is on.

Fuel pump is coming on as it should.

it sort of fired once, but not enough to start.

we borrowed an OBD II reader from Advance auto. 3 codes came up. MAP circuit, misfire cyl 1, and catalyst below efficiency.

obviously the catalyst thing isn't anything to worry about. He says the CEL has never flashed while driving, so I'm assuming the misfire code has been a result of the cranking and stuff....since it was running last.

so, we un-plugged the MAP (the '86 wagon I swapped last year with a '96 2.2 ran fine for about 1k miles with the MAP un-plugged...just crappy mileage). cranked for a minute. no change.

un-plugged the MAF. after cranking for a minute. it started, and idled very smoothly. tried revving it, and it quit immediately. plugged the MAF back in, and it started again, idled very smoothly for awhile longer. but again, quit as soon as the throttle was touched.

We tried a number of combinations of the MAF plugged in and not. and were able to get it to run. but as soon as you touch the throttle, it stumbles and quits.

Suspecting a bad MAF. we threw both of his (he had a spare) in my car. ran just as it always has.




So. it isn't the MAF itself. but when it's unplugged, and the ECU is in limp mode, the problem is lessened. So, what exactly changes when in limp mode? is it just fuel maps that go to default, or does it effect ignition too.

my current thoughts are:
TPS
CAS (either one)
fuel pressure regulator

#2 Fairtax4me

Fairtax4me

    Su bah roo'n

  • Gold Subscribers
  • 8,619 posts
  • Charlottesburg, VA

Posted 12 October 2009 - 09:11 PM

The "uneven" cranking could be because it is trying to fire on some cylinders but not on others. Since it does run I doubt that it is timing related.

The FPR is a pretty simple check, pull the vacuum hose off and see if gas drips out.

Stalling on throttle input could be due to a bad TPS. It could be a stuck or sticking idle control valve, could be a large vacuum leak. If you have a vacuum gauge hook it up and see what it reads at idle.

#3 subaru360

subaru360

    has no catchy title

  • Members
  • 1,282 posts
  • Fleetwood, PA

Posted 12 October 2009 - 11:52 PM

I had one act like that. The cat was plugged solid. Take out the front O2 sensor and see if it revs up.

#4 Fairtax4me

Fairtax4me

    Su bah roo'n

  • Gold Subscribers
  • 8,619 posts
  • Charlottesburg, VA

Posted 13 October 2009 - 11:25 AM

Reading through some threads about timing belts it seems that some people are able to get their cars to run at idle but will stall when given throttle if the belt is of by one tooth. So forget what I said earlier, jumped timing shouldn't be ruled out just yet.

#5 tcspeer

tcspeer

    1000+ Super USER!

  • Members
  • 1,444 posts
  • Walnut Springs

Posted 13 October 2009 - 05:00 PM

Check your coil pact. You can get a Haynes manual and meter for instrictions or just switch it out is you have a spare that is the same as the one that is on it.

#6 Danbob99

Danbob99

    Subaru Fanatic!

  • Members
  • 374 posts
  • Brier, Washington

Posted 13 October 2009 - 05:38 PM

I've had fuel pumps do that to me. They can still run and prime okay, but may not be building pressure. Worth a pressure check at least. Should see 30-32 psi at idle and 70 psi or so with the return blocked.

I'd check for sticking valves as well. its not uncommon to have those motors build up carbon on the exhaust valves and stick the valves open when cold. Just stick a vacuum gauge on the manifold while its running (if you can keep it running) and see if the needle flutters and bounces around.

Also see what your ECT is reading. If it's failed suddenly it may not have set a code yet.

A fully plugged cat could cause some serious issues, but it should still start up okay.

Thats where is would start.

Dan

#7 OB99W

OB99W

    Elite Master of the Subaru

  • Members
  • 3,315 posts
  • Ithaca

Posted 13 October 2009 - 05:43 PM

Even if the two cams seem to be in time with each other, that doesn't ensure that the crank is as well. As to the cylinder #1 misfire, see the last section on page 30 of http://endwrench.com...InsiderInfo.pdf for a possible cause.

#8 torxxx

torxxx

    I void warranties

  • Members
  • 2,914 posts
  • Fairbanks

Posted 13 October 2009 - 08:24 PM

I'm leaning towards low fuel pressure. I've had several EJ22 cars do that. keep in mind visually checking fuel pressure is very hard to gauge. 20 psi comes out about the same as 50 psi if u pull the hose off and turn the key on.

lift up the carpet in the back and tap on the fuel pump assembly (while its still in the tank) if it seems to run fine after u hammer on it a few times, pump is dying (brushes are losing contact) There is a way to do an amp draw test on a fuel pump to check that but I cant remember how it goes ( I just know what pins to test on a vortec chevy)

Fail Safe mode: Fuel maps are cut down, ignition timing retarded are two of things I know it does when it goes into limp home mode.

#9 NoahDL88

NoahDL88

    Elite Master of Cookies

  • Members
  • 4,264 posts
  • Everett, WA, USA

Posted 13 October 2009 - 08:45 PM

check the plugs yet?

#10 Numbchux

Numbchux

    EJ conversion addict

  • Members
  • 5,991 posts
  • Duluth, MN

Posted 13 October 2009 - 10:49 PM

obvious airflow out of the tail pipe. so the cat isn't totally plugged. and it bogs before it really even gets any rpms.


coil pack and ignitor were swapped out with other used ones. symptoms didn't change. might go over and see if they work on my car tomorrow to see if they're any good.

plugs were replaced.



I'll see if we can get ahold of a vacuum gauge and fuel pressure gauge to test those ideas.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users