Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

really high idle, ECT?


  • Please log in to reply
4 replies to this topic

#1 mjcee

mjcee

    New User

  • Members
  • PipPip
  • 17 posts
  • Chicago

Posted 12 October 2009 - 10:46 PM

hey everybody,

car: '86 GL-10 Wagon/5 speed/fuel injected.

problem:
The car is idling really high when cold. it has been up to 2300rpm. i know a high idle when cold isn't really uncommon but this seems crazy. Also, a few times, when sitting at a light in neutral, the car will rev up and down as high as 2500rpm down to around 1000rpm. And it won't stop until I put it into first and drive.

I've done some searching on the forum and mostly found vac leaks or the coolant temperature sensor is going. I'm going to have some time to work on this on wednesday so I was wondering if anybody has any other thoughts?

The only thing I've done to the car recently is an oil change and I put in a new fuel filter.

Any input is greatly appreciated. Thanks.

Edited by mjcee, 12 October 2009 - 11:05 PM.


#2 torxxx

torxxx

    I void warranties

  • Members
  • 2,914 posts
  • Fairbanks

Posted 12 October 2009 - 11:17 PM

GL-10... turbo or non turbo? IIRC in 86 they only made a turbo GL-10 (from what I've seen up here in Alaska. havent seen a non turbo GL-10 MY85, MY86.)

you could have an Idle Air controller on the fritz also. They act and a choke/high idler for a fuel injection system.

#3 GeneralDisorder

GeneralDisorder

    Elite Master of the Subaru

  • Members
  • 20,280 posts
  • Portland

Posted 13 October 2009 - 12:42 AM

It's probably a GL-10 2WD 5 speed - that would be the first model/year for SPFI.

Clean the idle air controller, and check the resistance of the CTS for starters.

GD

#4 mjcee

mjcee

    New User

  • Members
  • PipPip
  • 17 posts
  • Chicago

Posted 13 October 2009 - 08:27 AM

Sorry guys. It's a 4WD turbo.

#5 mjcee

mjcee

    New User

  • Members
  • PipPip
  • 17 posts
  • Chicago

Posted 14 October 2009 - 12:18 AM

Is there a gasket under the idle air controller that I should replace in the process?


It's probably a GL-10 2WD 5 speed - that would be the first model/year for SPFI.

Clean the idle air controller, and check the resistance of the CTS for starters.

GD






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users