Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Delta Cam roll call


  • Please log in to reply
57 replies to this topic

#26 Qman

Qman

    Happiness is... no lag!!

  • Moderator
  • 11,119 posts
  • Sumner

Posted 11 August 2011 - 10:15 AM

DOHC is $125.00 per cam. They have to be weld/grind. There simply isn't enough shim available to make up for the lost basecircle. You can install 2.2 heads for the "franken" motor and those run $82.50 each.

Ken

#27 1-3-2-4

1-3-2-4

    Subaru Mike!

  • Members
  • 3,659 posts
  • Greenwich

Posted 11 August 2011 - 04:28 PM

What profiles do you have for the ej25 cams? Any suggestions?

#28 Qman

Qman

    Happiness is... no lag!!

  • Moderator
  • 11,119 posts
  • Sumner

Posted 11 August 2011 - 04:41 PM

What profiles do you have for the ej25 cams? Any suggestions?


264 or 272 profiles. Basically, a torque grind and a hot street grind.

#29 mellow65

mellow65

    Subaru, my drug of choice

  • Members
  • 1,081 posts
  • Portland

Posted 11 August 2011 - 07:20 PM

i swore i read somewhere that you did certain grinds for the ej22 based on the rockers you had.

like only a torque grind for the earlier hydo/non roller and only a "hot rod" grind for the later solid/rollers.

is that true?

i'm piecing together a 2.2/2.5 franky motor and was thinking of running the torque grind because the heads probably wont flow enough to take advantage of the upper gains of the "hot rod" grind. but i like me some roller rockers and solid lifters.

#30 Delta Cam

Delta Cam

    New User

  • Members
  • Pip
  • 4 posts
  • Tacoma

Posted 16 August 2011 - 01:43 PM

Actually, there are two grinds for the non-roller rocker type and one for the roller rocker.

non-roller
220 torque cam
230 HP cam
roller
200 torque cam

Ken

#31 bratclay

bratclay

    USMB is life!

  • Members
  • 207 posts
  • Portland,OR

Posted 26 August 2011 - 12:41 PM

It won't give it much of a lope. This is a torque style cam. We have a bigger HP cam but you will lose some of the low end torque.

Ken


Ok first I need a set for my girls loyale that Im installing a EJ22 from a 95 Legy. Im also using a 4eat 4.444 so I want the torque cams on hers. I can send them to you next week after the show. Hows the turn around time? I will also be doing a set for the 95 Imp ej22 we have that Im going to frankenmotor it. So not sure if Im going tq or HP cams on that one but itll be a few weeks before those ones.

Thanks Clay

#32 Verybad

Verybad

    New User

  • Members
  • Pip
  • 0 posts
  • Bothell

Posted 03 September 2011 - 01:07 PM

I'm having problems with Delta... Installed the cams a couple months ago in my fresh 95 2.2. Installed the shims under the adjusters and it has very loud valvetrain noise. Only 500 miles on the engine and it was dead quiet with the stock cams.

Been trying to work with Ken at Delta to resolve the problem. I took some lift measurements and it appears that I was sent the wrong grind per Ken.

To make a long story short... two months have past and I amstill waiting for Delta to send the proper replacement cams. All I have been getting is promises from them, but no results. Plus they haven't credited me for my cores as of yet.

I will look elsewere for my next camshaft purchase.

Gordon

#33 95legwagon

95legwagon

    USMB is life!

  • Members
  • 221 posts
  • west hartford

Posted 03 September 2011 - 05:24 PM

Ive heard nothing but good things about delta cams to be honest..... every board i read says great things and thats ALL they recommend. everyone makes mistakes........

btw i have a 95 legacy wagon ej22e and i put a big exhaust and cold air intake on it..... i lost lots of bottom end with the exhaust..... should i get the torque grind? and how long does it take to get them back once theyre shipped out to you guys?

thanks!
-jarrid

#34 Verybad

Verybad

    New User

  • Members
  • Pip
  • 0 posts
  • Bothell

Posted 04 September 2011 - 12:45 AM

I did a bit of checking before and read good things about them.
Just so you know, I am no a constant complainer like so folks that post on the web, In fact... This is the first time I have posted about a company that I have had an issue with.
I own a sucessful fuel injector cleaning & flow testing business (WitchHunter Performance), and at times things happen, but it's all how the problems are taken care off is what really matters.
I'll elaborate a bit:
I ordered the cams and was told that the would ship in 2-3 days, after 10 days I called and they arrived 4 days later.
Installed them a week later and it ran well, but the valve train was clicking very loud. It is embarrassing to drive.
Called Ken the next day and he sugested that I may have a lash ajuster problem so I bought a set of new ones from them. I pretty much knew that it wasn't the problem but since everything else in the enigine was new, I did it anyway. It made no difference.
I talked to Ken again and he asked me to measure the lift, so I did and gave him the information. The indicated that I may have been shipped a non-roller cam by mistake. He then said that I could install another shim to take up the slack. I wasn't thrilled about doing that, but it sounded like an easy way out at the time.
Weeks past and I didn't get the shims, I called him again and he then said that it would be best for them to grind me another set of cams. I said that it would be best also.
A couple weeks past and I did not receive them, I called again and the said thet they would ship in a couple days. Ten days later I called and he said that they would ship that day. Four days later I called and said that I did not get them and was told that they did not ship them and now they want me to pull the out and verify the numbers on them... That was yesterday. I had been nice until that moment and told him that if I don't get a new set within a week I will contact my credit card company and the Better Business Bureau.

That's the story.

It just seems that anything that Ken said all along, didn't happen.

I feel that I have given them every chance to make things right before posting. I can't even put the old cams in since they were sent back (five weeks ago) for cores and my card has not credited as of today.

Sorry for the long post.

#35 Delta Cam

Delta Cam

    New User

  • Members
  • Pip
  • 4 posts
  • Tacoma

Posted 06 September 2011 - 12:40 PM

Gordon, as we discussed Friday I take this responsibility on myself. Your order has indeed been a problem. I am not entirely sure what the problem is either. I did not realize that this has been going on for this long. I will try to get them out tonight so you'll have them tomorrow. A lot of it depends on when they get done and when UPS arrives for packages. But, I will try.

#36 Delta Cam

Delta Cam

    New User

  • Members
  • Pip
  • 4 posts
  • Tacoma

Posted 06 September 2011 - 12:43 PM

Ive heard nothing but good things about delta cams to be honest..... every board i read says great things and thats ALL they recommend. everyone makes mistakes........

btw i have a 95 legacy wagon ej22e and i put a big exhaust and cold air intake on it..... i lost lots of bottom end with the exhaust..... should i get the torque grind? and how long does it take to get them back once theyre shipped out to you guys?

thanks!
-jarrid


You will usually lose bottom end when you install big exhaust and intake. The torque grind will help some but it will not restore the bottom end as it was stock. You may want to try a smaller exhaust and a set of torque cams.

Usually, these cams are shipped out within a couple of days.

Ken

#37 Verybad

Verybad

    New User

  • Members
  • Pip
  • 0 posts
  • Bothell

Posted 14 September 2011 - 12:18 AM

Hello all...

Received my replacement cams from Delta a couple days after posting my issues I was having with them.
Had to wait until the weekend to install them. Replacing them went well, took about 3 hours and I am very happy with the outcome.
Now the valvetrain noise is pretty much quiet as stock and the engine is running very well. It will pull easily to 7K and no noticable loss of any bottom end.

Although I had an issue with Delta and had to post the problem here. I was pleased that Ken stepped up and took responsibility here on the forum, then rectified the problem. As long as I get my core funds returned, life will be good.

Gordon
WitchHunter

#38 UraBUS09

UraBUS09

    USMB Regular

  • Members
  • PipPipPip
  • 69 posts
  • AK

Posted 26 September 2011 - 07:02 PM

i have the torque grind in my ea81. runs awesome! get 30+ on the hwy with 5th gear. have had no issues at all.

#39 Crazyeights

Crazyeights

    Subaru Nut

  • Members
  • 880 posts
  • PNW

Posted 26 September 2011 - 09:24 PM

i have the torque grind in my ea81. runs awesome! get 30+ on the hwy with 5th gear. have had no issues at all.


What is your valve lash set at? Mine is a bit noisy, how is yours?

#40 UraBUS09

UraBUS09

    USMB Regular

  • Members
  • PipPipPip
  • 69 posts
  • AK

Posted 27 September 2011 - 10:29 AM

i have mine set to stock specs if i remember correctly. and its supposed to sound like that... its a solid lifter style cam. they make a little noise. if its overly noisy, go back through and check all the lash. run thru it a few times, not just once, roll it over again and make sure theyre as close as you can get them! i love it only takes me 30-45 minutes. i do have my timing advanced a bit. more than just a cam in my motor... working on more/different things with this motor. :grin:

#41 91leglift

91leglift

    USMB Regular

  • Members
  • PipPipPip
  • 59 posts
  • portland

Posted 23 December 2011 - 11:31 AM

About to put my Frankenstein engine together tonight with the 220 torque grind cams. if all goes to plan it will be in the car running tonight or in the morning.

Im sending my cores back today if i can get by UPS

#42 Qman

Qman

    Happiness is... no lag!!

  • Moderator
  • 11,119 posts
  • Sumner

Posted 23 December 2011 - 11:47 AM

Cool, I'll keep an eye out for them.

#43 monstaru

monstaru

    wow, relevance....

  • Members
  • 4,379 posts
  • OlyWa

Posted 23 December 2011 - 06:58 PM

200 grind cams where put in EJ22 heads this morning.Those heads were put on anEJ251 block..075 MLS SUbaru head gaskets.
It won't run until next week.AS the car is in pieces right now.Literally.
Can't wait!
Thanks Ken.Cheers

#44 tundrabrat

tundrabrat

    Eat, Live, Breath Subaru

  • Members
  • 374 posts
  • Anchorage

Posted 23 January 2012 - 10:52 PM

Just got my cam back from Delta Cam... Ken provided great communication and amazing turn around time! (barely a week round trip):headbang:

#45 Battlewagon

Battlewagon

    USMB Regular

  • Members
  • PipPipPip
  • 38 posts
  • Knoxville/Miami

Posted 11 February 2012 - 04:47 PM

So, how "hot" are the 272 profile cams for the Phase I EJ25D? Would I need to run some sort of piggy back engine management or would my stock ECU be able to deal with it?

#46 Qman

Qman

    Happiness is... no lag!!

  • Moderator
  • 11,119 posts
  • Sumner

Posted 13 February 2012 - 02:48 PM

So, how "hot" are the 272 profile cams for the Phase I EJ25D? Would I need to run some sort of piggy back engine management or would my stock ECU be able to deal with it?


To get what the cam has to offer, yes, EM would be a good plan.

#47 Crazyeights

Crazyeights

    Subaru Nut

  • Members
  • 880 posts
  • PNW

Posted 13 February 2012 - 08:38 PM

Finally finished my performance solid lifter EA81 about a year ago. EA71 NOS pistons, Delta "torque" cam, and had Ken grind the lifters as well along with all new bearings, seals, water pump, ect. All the typical head work was done too, DeMoss port, polish and grind large valve heads, ect.

This engine has been one torquey SOB since I first put it together, but I could never get the valves to quiet down no matter what I tried. Finally after about 5000 miles the front intake lobe has gone flat:(

Rather than pull it and spilt the case again just to fix it and still have it clatter, I think I'm going with a bone stock Hydro Dual Port EJ22E

Just some thoughts. Sure was fun while it lasted!

#48 Qman

Qman

    Happiness is... no lag!!

  • Moderator
  • 11,119 posts
  • Sumner

Posted 14 February 2012 - 11:31 AM

Hmm, those don't usually go flat. May have gone away @ break-in. Which would explain the fact that it would never quiet down. I will repair/replace the cam for you though if you decide to redo it.

Ken
Delta Camshaft

#49 Battlewagon

Battlewagon

    USMB Regular

  • Members
  • PipPipPip
  • 38 posts
  • Knoxville/Miami

Posted 26 February 2012 - 09:19 AM

To get what the cam has to offer, yes, EM would be a good plan.


That's what I figured. Do you suggest a specific type? I was thinking that a Perfect Power SMT6 or SMT8 piggy back could work; am I going in the wrong direction?

#50 89ChevondaSI

89ChevondaSI

    USMB Regular

  • Members
  • PipPipPip
  • 89 posts
  • Stoughton, WI

Posted 26 February 2012 - 08:03 PM

Is a set of cams for a '97 Legacy GT EJ25 offered?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users