Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Quick and dirty fix for a sloppy shift linkage


  • Please log in to reply
9 replies to this topic

#1 moped

moped

    New User

  • Members
  • PipPip
  • 27 posts
  • Cleveland

Posted 15 October 2009 - 10:33 PM

In related news, I finally have my 4 speed dual-range back together enough to worry about the shifter linkage. What a pain in the butt that was.

Anyway, I decided to try to tighten up the shift linkage as long as I had the transmission out of the car. Instead of any of the stuff involving splitting the shift sleeve listed here: http://www.ultimates...ead.php?t=49954 I tried something a little quicker and dirtier.

I had some aluminum flashing material sitting in my basement and I cut myself a shim to fit between the sleeve and the rod that runs into the transmission. Remove the sleeve, cut a strip of flashing about 8mm wide, wrap it around the shifter rod, and cut it to length. Wrap it around a small socket to get a nice smooth curve in it, fit it over the rod, and then carefully slide the sleeve onto the rod and over the shim. Replace the spring pins.

The difference is pretty noticeable, even with the transmission out of the car. The best part about the aluminum flashing material is that you can pound it to your required thickness between two hammer heads. It probably won't last as long as a fix with splitting the sleeve and tightening it with a bolt, but it's a heck of a lot easier if winter is fast approaching and you're getting tired of riding your bike to the office.

This weekend's project: put the transmission back in the car and take it for a test drive. Woohoo!

#2 GeneralDisorder

GeneralDisorder

    Elite Master of the Subaru

  • Members
  • 20,280 posts
  • Portland

Posted 15 October 2009 - 10:49 PM

Splitting the sleeve is no longer the gold standard for fixing the 4 speed slop. This is the new method.... as far as I know I'm the only one who's done it but I've done several now. There's even a better version still where I drilled and tapped for a second 5mm socket-head cap screw that bisects the sleeve and rod at about a 15* or 20* angle to the primary locking bolt. It's amazing. My daily driver has had this done as well as a fellow board member's Brat. Both were done with the tranny in the car - removing only the exhaust bracket and tapping the hole with a good quality tap and a crescent wrench for a tap handle.

http://www.ultimates...ead.php?t=86901

And here's another post where I detailed the second bolt I added to the linkage on my lifted wagon:

http://www.ultimates...007&postcount=3

GD

Edited by GeneralDisorder, 15 October 2009 - 11:00 PM.


#3 renob123

renob123

    Subaru Nut

  • Members
  • 719 posts
  • Hillsburrito, OR

Posted 16 October 2009 - 09:21 AM

Splitting the sleeve is no longer the gold standard for fixing the 4 speed slop. This is the new method.... as far as I know I'm the only one who's done it but I've done several now. There's even a better version still where I drilled and tapped for a second 5mm socket-head cap screw that bisects the sleeve and rod at about a 15* or 20* angle to the primary locking bolt. It's amazing. My daily driver has had this done as well as a fellow board member's Brat. Both were done with the tranny in the car - removing only the exhaust bracket and tapping the hole with a good quality tap and a crescent wrench for a tap handle.

http://www.ultimates...ead.php?t=86901

And here's another post where I detailed the second bolt I added to the linkage on my lifted wagon:

http://www.ultimates...007&postcount=3

GD


^^^What he said. I've put aluminum flashing on my Brat for different things. It always seems to wear out or move around. GD's fix, along with new motor and tranny mounts, are in my category of "should have done this a long time ago".

Jacob

#4 The Beast I Drive

The Beast I Drive

    CALL ME, (509) 391-5903

  • Members
  • 2,120 posts
  • Toppenish, WA

Posted 16 October 2009 - 02:37 PM

I tried GD's method, and for some reason it did not work in my 85 Brat, the slop was still there, just not as bad. So, since I had already tapped the shifter rod, I removed the sleeved shifter mechanism thingy and drill the holes out to 3/8", then cut a slot on each side of it. When I installed it, I use a 3/8x1 1/4" bolt. I put the bolt in from the bottom, and tightend the piss outa it, then I put a 3/8" lock nut on the top, and tightened the piss outa it too. Basically, I combined the old method with the new method, and it completely fixed my shifter slop on the rod. My shifter still felt a little sloppy though, so I took the metal sleeve out of both of the shifter bushings, and filed a few thousandths off the end of each one, and reinstalled. Voila! No more shifter slop, my 4 speed DR shifts tighter than a new Ferrari!

-Bill

Edited by The Beast I Drive, 16 October 2009 - 02:41 PM.


#5 GeneralDisorder

GeneralDisorder

    Elite Master of the Subaru

  • Members
  • 20,280 posts
  • Portland

Posted 16 October 2009 - 06:50 PM

I tried GD's method, and for some reason it did not work in my 85 Brat, the slop was still there, just not as bad.


Perhaps there was so much wear to the sleeve, rod, and roll-pin holes that it just didn't have enough material to work with. I've seen the sleeve's and rods with grooves in them from pivoting on the roll-pins.

I really don't like splitting the sleeve as it precludes adding another bolt to the assembly. And drilling out the rod leaves precious little metal on either side of the (now gigantic) hole for the bolt. I've seen one transmission where the rod broke at the roll-pin hole and it hadn't even been enlarged.

While there is still some slop if there is any wear to the rod and sleeve, replaceing the bushings or fileing the bushing insert generally makes the shifting "good enough" for most people. I added the second 5mm socket-head to remove the rest of the slop in mine.

Also - shortening the throw will neccesarily reduce the slop. If you have 1" of slop with a 6 inch throw, reducing the throw to 3" will reduce the slop to 1/2". Often that's enough to be tollerable.

It's a balancing act - what *can* you do that *probably* won't break, etc. If you just don't care at all about the transmission (as many folks don't about the 4 speed's) then you can just weld the thing solid.

The *real* fix for the 4 speed slop is to haul that heavy POS off to the scrap man and install a 5 speed.

GD

#6 torxxx

torxxx

    I void warranties

  • Members
  • 2,914 posts
  • Fairbanks

Posted 17 October 2009 - 09:08 PM

GD is right. the correct way to fix it is junk it and put a 5 speed in it.

I've done the roll pin drill out a few times and had great success with it. I used a stainless steel bolt that just had threads about 1/2 inch up the shaft and was solid the rest of the way and drilled it to the point where I had to actually hammer the bolt through. took out all the slop.

Now if I can figure out where I need to mod my 5 speed linkage I'll be golden. Keeps hitting my plastic trim that the shifter boot snaps into. broke about 10 of them this summer. only way I see to fix it is actually cut the shifter and weld it back behind the cut.. offset like this ------------______________

that should make up the difference

#7 Ricearu

Ricearu

    Official De-Ricer!

  • Members
  • 1,208 posts
  • DFW, TX

Posted 17 October 2009 - 09:35 PM

I changed the bolts out to a 1/4", then shoved a chunk of 5/16 fuel hose in there, then shoved the bolts in. That was a 5 spd, don't know the difference

#8 moped

moped

    New User

  • Members
  • PipPip
  • 27 posts
  • Cleveland

Posted 19 October 2009 - 05:30 PM

Oooh, I like that tapping the hole fix. I'll put that on the list after getting the exhaust leak taken care of and the driver's side front axle replaced. The exhaust leak really annoys me though.

When I got the Y-pipe from the yard, they had just cut it behind the coupler with a torch or sawzall. The muffler shop I took it to to have the back end built just welded on to the short piece of pipe aft of the coupler instead of chopping it off and replacing it. This wouldn't have been a problem, except that I had to split the coupler to drop the Y-pipe to drop the transmission. Unsurprisingly, it did not seal cleanly when I put it back on with all the rust and crap on it.

#9 clunkerbob

clunkerbob

    USMB Regular

  • Members
  • PipPipPip
  • 50 posts
  • northern Arizona

Posted 19 October 2009 - 06:46 PM

Yeh , I do too . My linkage is so bad I can hardly get into reverse .

THe exhaust fell off already , so it will be easy to get up there with a drill motor and tap . I'm gonna study the pictures and maybe do the mod to the lever to shorten up the shift patern . I'm not really understanding the procedure on that ........ but I'm certain it'll make sense in a bit . A couple of beers will help :)

Whats that lower pivot ? Is that nylon or rubber ? I wonder if making up a harder bushing like brass would hold up better ? Or would it transmit vibration up through the stick . I guess I'll know better when I get it torn apart this week sometime .

I have a mill and all that stuff here at the shop ... I like to mess around with these kinds of things

Bob

#10 moped

moped

    New User

  • Members
  • PipPip
  • 27 posts
  • Cleveland

Posted 19 October 2009 - 09:18 PM

Whats that lower pivot ? Is that nylon or rubber ? I wonder if making up a harder bushing like brass would hold up better ? Or would it transmit vibration up through the stick . I guess I'll know better when I get it torn apart this week sometime .


The lower bushing is hard, white plastic (nylon?) and is held on by a hard rubber "donut". The upper pivot is 5 pieces: an inner rubber and outer hard, white plastic bushing on each side, and a metal sleeve that runs through the assembled bushings.

For what it's worth, replacing all of the bushings did nothing to improve the shifting on my car. The problem was slop between the sleeve that runs over the rod on the transmission and the rod itself. There actually is wear in that rod from the slop. You can wiggle the outer sleeve assembly around the axis of the spring pin without the flashing shim in there.

I'm going to make GD's suggested mod at some point, but I'll probably leave the shim in too.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users