Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

2000 impreza


  • Please log in to reply
9 replies to this topic

#1 2000impreza

2000impreza

    USMB Regular

  • Members
  • PipPipPip
  • 45 posts
  • pontiac

Posted 24 October 2009 - 10:32 PM

Hey guys,

My impreza rs 2.5 did some crazy thing tonight. I was on my way home going about 80 mph, and notice a clunking noise right under the car in middle. It does this every time at a green light going about 10 mph. Drives fine after that. This sudden jerk kind of fells like something wrong with my trans or diff. Not sure what it is. Also the ATF Oil Light is flashing constantly. So I add some More ATF light goes away. When i got home turned the car off and started it again the Freaking ATF light came back on. I don't know if Trans-X will fix this.

NOT TO SURE WHAT THE PROBLEM IS??? HELP ME FELLOW SUBIE FRIENDS??

I have replace the duty c 6 months ago AND FLUID.

#2 svxpert

svxpert

    Certified Subaru Nut

  • Members
  • 777 posts
  • East Coast

Posted 24 October 2009 - 11:15 PM

jack the car up and check the driveshaft. the center bearing may have went.

#3 2000impreza

2000impreza

    USMB Regular

  • Members
  • PipPipPip
  • 45 posts
  • pontiac

Posted 24 October 2009 - 11:29 PM

would that cause the ATF Oil to Flash also.

#4 grossgary

grossgary

    Elite Master of the Subaru

  • Members
  • 20,494 posts
  • WV

Posted 25 October 2009 - 06:41 AM

no that wouldn't cause the ATF light to flash.

a better description would help. like specific stuff. it only does it at 10mph? (you also mentioned driving home at 80?)

here's a really important question:
was the ATF light flashing before this issue happened? or did they occur simultaneously. if they happened at the same time then obviously they are likely related.

#5 2000impreza

2000impreza

    USMB Regular

  • Members
  • PipPipPip
  • 45 posts
  • pontiac

Posted 25 October 2009 - 07:35 PM

All these symptom happened at the same. Just found out that I have a diff dip stick on the passenger side. It was also low.. wow.

Now what kind of fluid would I put in to the diff on the passenger side??? Any thing in particular?? 80 90 gear oil .

Edited by 2000impreza, 25 October 2009 - 07:37 PM.


#6 2000impreza

2000impreza

    USMB Regular

  • Members
  • PipPipPip
  • 45 posts
  • pontiac

Posted 06 November 2009 - 06:54 PM

guys I add 80 90 to the diff on the passenger side but i'm still getting that clunking noise. Checked the center bearing and everything is still good. I need some serious help.

#7 forester2002s

forester2002s

    Subaru Fanatic!

  • Members
  • 581 posts
  • Vancouver Canada

Posted 07 November 2009 - 01:04 AM

If this is an automatic, then don't add 80W90 oil to the transmission.

An automatic needs an ATF such as Dexron.
Check your documentation to see which type of Dexron ATF you should be using.

#8 Fairtax4me

Fairtax4me

    Sooberoo

  • Gold Subscribers
  • 10,219 posts
  • Charlottesburg, VA

Posted 07 November 2009 - 07:58 PM

If this is an automatic, then don't add 80W90 oil to the transmission.

Correct, You add it to the differential, which uses separate fluid from the transmission, which is what he did.


Bad U joint possibly. That may also make it wobble at higher speeds as well.

Might the trans be shifting into second gear around that speed? Do you accelerate fast?

#9 2000impreza

2000impreza

    USMB Regular

  • Members
  • PipPipPip
  • 45 posts
  • pontiac

Posted 07 November 2009 - 10:27 PM

No. i don't punch her at the light normal driving. It did start to happen when i was went on a 1.5 hr drive going 90 mph. Could that be the problem.

How many u joint do i have and will still problem ruin any part?

#10 2000impreza

2000impreza

    USMB Regular

  • Members
  • PipPipPip
  • 45 posts
  • pontiac

Posted 08 November 2009 - 11:14 AM

All u-joints inspected and is good. So I jacked up the whole car and put it in drive to 20 mph. Notice that passenger wheel does not spin. Even giving it a little spin she doesn't spin it's not lock up you can rotate her fine. I am not sure if it is my Transmission or front diff going bad. At 20 mph looking at the cluster gauge it just jump right up to 30 mph at the same acceleration.

Any suggestion to this fix??




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users