Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

wipres quit


  • Please log in to reply
2 replies to this topic

#1 AWD TURBO!

AWD TURBO!

    USMB is life!

  • Members
  • 205 posts
  • vancouver

Posted 22 December 2009 - 06:19 AM

need help the Winchell wipers stoped working

looked at the fuse box no bad fusees

washer stop working at the same time

this would be on a 8 gl10 turbo

relay?

switch?

wiper moter?

hmm going to look in to it in the morning any help in the mean time would be grate

#2 eulogious

eulogious

    Inspiring Subaneer

  • Members
  • 1,090 posts
  • Olympia, WA

Posted 22 December 2009 - 07:07 AM

You say the washer stopped working at the same time as well? Does the washer motor sound at all? If you run power directly to the washer pump, does it pump anything? How about running power directly to the wiper motor, does it do anything? I ask all this because if the washer pump works with direct power, and the wiper motor works with direct power, then it's the switch. Otherwise it's probably the motor. Since the washer quit working at the same time, I would lean toward the switch failing, or a wire getting grounded somewhere along the way. That would be where I would put my money given the info so far...

#3 AWD TURBO!

AWD TURBO!

    USMB is life!

  • Members
  • 205 posts
  • vancouver

Posted 22 December 2009 - 01:59 PM

was in the mud trying to wash the the mud off

going to run power to th moter & see if it works...

I'm thinking its the switch we will find out




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users