Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

What is it mark 2.0?


  • Please log in to reply
4 replies to this topic

#1 belyle

belyle

    New User

  • Members
  • PipPip
  • 19 posts
  • Renton

Posted 10 January 2010 - 04:07 PM

While I had the engine compartment all torn up yesterday while working on my Brat, I found this on the ground. I am 100% certain that I did not disconnect it, and had never seen it before. What is it?

http://www.ultimates...=1&d=1263157619

Attached Files



#2 Dirk

Dirk

    Lazy Perfectionist

  • Members
  • 489 posts
  • Wanaka New Zealand

Posted 10 January 2010 - 05:40 PM

Its a condenser. It should be conected to the distibutor. Deffinately put it back on cos you won't go far without it.:)

#3 cubastreet

cubastreet

    Eat, Live, Breath Subaru

  • Members
  • 281 posts
  • Wellington

Posted 10 January 2010 - 10:35 PM

It should connect across the distributor points. The body bit connects to your car's body (earth) and the wire to the side of your points that go to the ignition coil.

#4 belyle

belyle

    New User

  • Members
  • PipPip
  • 19 posts
  • Renton

Posted 11 January 2010 - 09:06 PM

Hmm, I didn't remove it. I just found it underneath my car after working on it. The car started and seems to run just fine.

I thought it looked like a condenser to me. Maybe it was dropped by a previous owner and never found.

#5 cubastreet

cubastreet

    Eat, Live, Breath Subaru

  • Members
  • 281 posts
  • Wellington

Posted 12 January 2010 - 11:55 PM

If you have a points disty and no condenser, your points will burn up pretty quickly.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users