Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Fixing a "Fried" 4EAT TCU Due to Bad Duty C


  • Please log in to reply
11 replies to this topic

#1 eulogious

eulogious

    Inspiring Subaneer

  • Members
  • 1,090 posts
  • Olympia, WA

Posted 16 March 2010 - 05:09 PM

Hello All,

So I am posting this in this in the New Gen forum, even though this is going into my loyale because there are more 4EAT in the new gen's than in the older gen.

To start off I would like to thank presslab and Gloyale for answering my questions leading up this whole deal, thanks guys!

So I have acquired a 1990 legacy AWD TCU so that I can adapt it into my 1990 loyale. But when I got the TCU and plugged it in I got instant torque bind, and I mean instant. It was apparent to me that the TCU wasn't going into limp mode, the hardware had to be bad somewhere. I was also getting the 16 power light flashes that mean that the TCU has a fault somewhere. So I took it for a drive, and man it was binding up like a no other in the corners, so the AWD was not working. I tried putting a fuse in the FWD fuse holder, nothing, still binding. I went and tripple checked my connections and verified all the voltages, and everything was fine except for the duty c circuit. I got nothing out of it.

So after saying a few curse words and after contemplating pissing on the stupid TCU, I sat down and PM'ed a couple people to see if they could help me. Presslab suggested that I check the board's transistors, and to start by following the duty c solenoid pin and tracing the circuit. Well low and behold I found the culprit!

Here's a diagram showing the TCU pinout, the Duty C solenoid is pin 3 on connector B33:

Posted Image

Posted Image

Blown transistor:
Posted Image

Duty C Solenoid Circuit Path:
Posted Image

The red highlight is the path, and the orange circle is the blown transistor, just in case you all didn't catch that.

As you can obviously see, this transistor was blown :eek: So my hopes shot up, I might have found the reason it wasn't working! So the next day I went to my local electronics wholesaler and picked up a new transistor and a solder sucker so that I could remove the old part.

New transistor:
Posted Image

Solder sucker:
Posted Image

So after getting home and only spending $6 :grin: it was time to attempt to get this bad transistor out.

So I would highly recommend getting a good soldering iron before you attempt this, heat will KILL the board, so be very careful. Use no more than a 30 watt iron. I didn't take pictures of me actually taking it out, but I will explain what I did. The first thing was to add a little bit of solder to the existing solder joints to heat it up so you can suck it out. You don't want to be hanging out too long heating up the solder, you could damage the board by getting it hot, so all this has to be fairly quick, which is a PITA. So heat up the exsisting solder and suck it out. Repeat for the other 3 holes. I had to repeat this process about 3 times on each hole to get most of the old solder out, so take your time, and repeat, it will come out. So once I had removed enough solder, I was able to wiggle the blown transistor out.

My Soldering Iron, Sears $50 special but it's a Weller :grin:
Posted Image

Here's the empty holes:
Posted Image

Here's the blown transistor:
Posted Image

The stuff circle in red is what you don't want to do :rolleyes: I was very lucky that the contacts were still on the bottom, so I was able to salvage this, but THIS IS WHAT YOU DO NOT WANT TO DO! I rip the traces out. Very BAD. So take your time! I didn't get enough of the solder on the top of the solder joint, so when I removed the transistor, I tore out the top part of the traces. So don't do as I did on this one :rolleyes: Man, I got lucky.

Okay so now that it was out, it was time to get the new one in:

Yellow circle shows the new transistor:
Posted Image

The bottom of the board:
Posted Image

Once that was done, all I had to do was add a little bit of solder and hope for the best!

All soldered up on the bottom:
Posted Image

Topside:
Posted Image

As you can see I didn't get solder all the way up to the top of the board. This is due to not using any flux. If I would have dipped the end in flux, the solder would have flowed better. But this doesn't bother me, since I ripped the tops of the traces out anyways, it really doesn't matter :rolleyes:

So then it was time to test it. So I went and plugged it in, started the car, turned it off, and then started it again. I did this because the first time the TCU won't show any lights, it's only after you turn on the key and turn it back on does it flash. And no flashing lights :banana: It worked! So to verify I took it for a drive. No torque bind, it shift smoothly and went into lockup and all. Everything worked great!

So in conclusion if your duty c solenoid fails and you fix it but the car still has the same symptoms, you might want to look at the TCU, since it can be blown by a bad duty c! So with a little patience and a steady hand you can fix it for about $1.50 and go on your marry way. I hope that this helps someone else out. If anyone has questions, just ask, I will help the best I can!

This is just the first part of my project that I am doing, so I will be posting more in various forums sections as I get more done!

Edited by eulogious, 16 March 2010 - 05:13 PM.


#2 Olnick

Olnick

    Ol' Subaru Guy

  • Members
  • 2,543 posts
  • Honolulu HI

Posted 16 March 2010 - 05:31 PM

Congratulations eulogious. I applaud your stick-to-it-iveness!

#3 eulogious

eulogious

    Inspiring Subaneer

  • Members
  • 1,090 posts
  • Olympia, WA

Posted 16 March 2010 - 05:55 PM

Congratulations eulogious. I applaud your stick-to-it-iveness!


Thanks! The real reason I stuck with it is that I need this exact TCU part number for my project to even have a chance at working, so I kinda needed to attempt to fix it to make my life easier. Now I have some experience in fixing circuit boards as well :grin:

This was my first attempt at repairing a circuit board, if you couldn't tell by my ripped out traces :lol:

#4 doc526

doc526

    USMB Regular

  • Members
  • PipPipPip
  • 113 posts
  • Dallas, GA

Posted 16 March 2010 - 06:18 PM

eulogious,

If you don't want to use a seperate flux for soldering, a few manufacutrers make solder with a flux core. I find it easier to get a good flow and stronger better looking joint using flux cored solder. Kester is one of the better solders out there, but most are satisfactory.

I repair electronics on a daily basis and nothing feels bettter than fixing a dead board. Congrats on the repair. :banana:

#5 hankosolder2

hankosolder2

    Subaru Nut

  • Members
  • 689 posts
  • Chicago

Posted 16 March 2010 - 06:55 PM

A vacuum desolderer is a real boon for double sided boards like this. (You use an air compressor with it and it has a venturi which creates suction from the air flowing by.) Get the joint nice and warm, pull the trigger and presto!

There are cheaper versions which use a squeeze bulb. Have not tried them but I bet you could hack one and attach your own vacuum source (pipe it to the intake manifold with an inline filter, fire that engine up and desolder away!) :)

Nathan

#6 GeneralDisorder

GeneralDisorder

    Elite Master of the Subaru

  • Members
  • 20,280 posts
  • Portland

Posted 16 March 2010 - 07:15 PM

Well done. Excelent information to add to the torque bind repair catalogue.

GD

#7 pearlm30

pearlm30

    Eat, Live, Breath Subaru

  • Members
  • 341 posts
  • Tampa, FL/ Bethlehem, PA

Posted 16 March 2010 - 07:39 PM

Very nice! Thank you:banana::banana::banana:

#8 Rooster2

Rooster2

    Subaru Master

  • Members
  • 3,514 posts
  • Indianapolis

Posted 16 March 2010 - 08:14 PM

very nicely done, not often do we get such a detailed picture by picture explanation of how to replace a transistor. What a great job you did.

BTW, I saw the box of donuts in the one picture, so I figure you must be a police officer. I hope you are doing as well in catching the bad guys, and keeping them off the streets!

#9 presslab

presslab

    Subaru Nut

  • Members
  • 853 posts
  • N. California

Posted 16 March 2010 - 08:20 PM

Excellent job! :banana: Now on to bigger and better things! :grin:

#10 eulogious

eulogious

    Inspiring Subaneer

  • Members
  • 1,090 posts
  • Olympia, WA

Posted 16 March 2010 - 08:47 PM

For those of you who are curious, I have created a thread showing how I made the harness to fit an EJ TCU into an EA car (4EAT). Here's the thread:

http://www.ultimates...0845#post910845

This was good times for sure :-\

#11 crws

crws

    New User

  • Members
  • PipPip
  • 12 posts
  • Vancouver

Posted 19 August 2010 - 09:55 AM

Excellent.
Some joker was chopping wires in our 93 Legacy and we have bind as well.
Swapped TCU's, still bind, so now the tracing begins.
Excellent information. Thanks for posting.

#12 eulogious

eulogious

    Inspiring Subaneer

  • Members
  • 1,090 posts
  • Olympia, WA

Posted 19 August 2010 - 10:00 AM

Excellent.
Some joker was chopping wires in our 93 Legacy and we have bind as well.
Swapped TCU's, still bind, so now the tracing begins.
Excellent information. Thanks for posting.


No problem, glad I could help! If you got anymore question feel free to ask, I will help where I can! Good luck!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users