Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

engine knock 93 legacy 2.2


  • Please log in to reply
4 replies to this topic

#1 coolskaterkid

coolskaterkid

    USMB Regular

  • Members
  • 143 posts
  • south lake tahoe

Posted 18 March 2010 - 08:58 PM

Got a 93 legacy for free, it has been very well maintained, oil always changed every 3 to 4 k, it has 184k miles, and has a knock. i think its a bearing but not sure, it does it really at any rpms, but with more gas, it seams to stop but if you hold it at a certain rpm above 2300 it will make the noise badly. So i believe with more rev the oil pressure goes up and its quiets down. But just took it and it passed california smog with flying colors. So i want to know if theres anyway to find out what it is, and possible fix. How long do i have running it this way. I had it at 6200 rpms before the smog to clean it out and didnt make a sound, until i let up on the gas and tried to hold speed and it made a racket

#2 ericem

ericem

    First Gen Legacy Master

  • Members
  • 2,477 posts
  • CANADA Maple,ON

Posted 18 March 2010 - 09:11 PM

Probably just the hydraulic lash adjusters. They fill with oil, yet sometimes they seize or get air trapped because a oil passage way is slugged up running them dry. It causes them to give a noise similar to a knock.

You can remove them and bleed them. You can also try getting a bottle of seafoam at your local parts store and dumping it in the oil and driving around aggressively hopefully it will clear out the sludge and the HLA's will be nice and quiet. You should only drive around for like 20minutes or so until the noise goes away, THEN replace the oil and filter.

#3 coolskaterkid

coolskaterkid

    USMB Regular

  • Members
  • 143 posts
  • south lake tahoe

Posted 18 March 2010 - 09:23 PM

ok will try the seafoam, and see what happens. But what would it take to remove and bleed them?

#4 lmdew

lmdew

    _______

  • Members
  • 2,825 posts
  • Colorado Springs

Posted 18 March 2010 - 09:52 PM

I'd put the Seafoam in but I would just let it idle or drive it under very light loads with the seafoam in.

I spun a bearing with seafoam in the oil. I had put it in and then I had to drive it for 15 miles.

It spun a bearing. Read the Seafoam directions.

It's great stuff.

Also try a quality 5-30w oil.

#5 coolskaterkid

coolskaterkid

    USMB Regular

  • Members
  • 143 posts
  • south lake tahoe

Posted 18 March 2010 - 09:56 PM

i have 5w-30 fully synthetic in it now, been in there for about 300 miles. I sure hope its only the valve lash. Will try the seafoam and hope for the best




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users