Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Best way to fix CTS connector


  • Please log in to reply
3 replies to this topic

#1 Txakura

Txakura

    Not the Stig

  • Members
  • 1,013 posts
  • Colfax, WA

Posted 30 March 2010 - 12:50 AM

That should not have been moved, I'm not looking to buy the pigtail, I'm wondering how I can fix a broken CTS connector on an ea82T.

Should I solder to the CTS pin directly and cut in new wire to the harness?

cut one form another car? are the SPFI and MPFI cts the same?

#2 Turbone

Turbone

    The Original Rob

  • Moderator
  • 12,139 posts
  • WA

Posted 30 March 2010 - 04:03 PM

The title to your first thread was I NEED a CTS.........so I moved it.
And from what you were saying, it also sounded like you needed one.

But to answer your question, I believe Bosch makes a connector thats the same.
I think I've seen a post over at subaruxt.com about, but I cant be 100% positive.
The plugs should also be the same for MPFI and SPFI.

#3 keppelk

keppelk

    USMB Regular

  • Members
  • PipPipPip
  • 37 posts
  • Dunedin, New Zealand

Posted 04 April 2010 - 06:44 PM

Injectors and the CTS use the same connector. You can find replacement connectors with pigtails on ebay if you search "bosch EV1". I've used these to replace my CTS and would highly recommend it! The EV1 connectors have a much better retainer clip, and are easier to remove without worrying about breaking the plastic.

#4 Txakura

Txakura

    Not the Stig

  • Members
  • 1,013 posts
  • Colfax, WA

Posted 04 April 2010 - 10:33 PM

Yah, my bad Turbone. I worded it poorly.

Thanks for the heads up on the connector body itself, I have two gm terminal pins on it right now - but it can't stay that way.

Excellent info, thanks.

edit ***Double point score, the Bosch EV1 connector is $3.25 ! ***

http://www.bmotorspo...products_id/942

thanks keppelk!

Edited by Txakura, 04 April 2010 - 10:39 PM.
NZ Rocks!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users