Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

My EJ22T swap.......and a few issues


  • Please log in to reply
104 replies to this topic

#76 suberdave

suberdave

    www.suberdave.com

  • Members
  • 1,000 posts
  • Covington

Posted 06 July 2010 - 09:56 PM

Hey, on a side note, does your ecm have a built in map sensor? Mine does, which I thought would be for a turbo model, but my brother has a turbo 1.8 and a turbo 2.2 and neither one has a map sensor.


Im pretty sure thats not a MAP sensor.
(manifold absolute pressure sensor)
But a BARO sensor.
(barometric pressure sensor)

A map would have to have a vacuum hose coming from the manifold and plugged into the ECU.

I have never seen a stock subaru with a vacuum line, however i have seen them with a hole that looks like a BARO sensor.

#77 phantomcrooner

phantomcrooner

    USMB is life!

  • Members
  • 138 posts
  • The mountains of Julian

Posted 07 July 2010 - 09:47 AM

I dont think mine does, its a 92.
What year is yours, if you know?.

Mine is from a a 94 Legacy Import.


Im pretty sure thats not a MAP sensor.
(manifold absolute pressure sensor)
But a BARO sensor.
(barometric pressure sensor)

A map would have to have a vacuum hose coming from the manifold and plugged into the ECU.

I have never seen a stock subaru with a vacuum line, however i have seen them with a hole that looks like a BARO sensor.


Thus my confusion, this is a 4 bar map sensor, with vacume line, which i plugged in to the manifold.

#78 Turbone

Turbone

    The Original Rob

  • Moderator
  • 12,105 posts
  • WA

Posted 07 July 2010 - 11:55 AM

Been working on the replacement tranny.

Posted Image
Posted Image

#79 baccaruda

baccaruda

    YOUR FAVORITE MOD

  • Moderator
  • 6,941 posts
  • SpoVegas, WA

Posted 08 July 2010 - 11:23 PM

Looks great! I have a replacement trans I need to get scrubbed up but you're obviously more qualified to do so than I am.. come on over when you're done!
:grin:



What'd you use, kerosene?

#80 Turbone

Turbone

    The Original Rob

  • Moderator
  • 12,105 posts
  • WA

Posted 09 July 2010 - 08:51 AM

Looks great! I have a replacement trans I need to get scrubbed up but you're obviously more qualified to do so than I am.. come on over when you're done!
:grin:



What'd you use, kerosene?



Sure, I only charge $20hr and my choice of beer.

I use the purple cleaner you can buy at the auto stores. Then rinse with water and finish off with the wire wheel and a quick spray of clearcoat.

#81 bratman18

bratman18

    ADIDASubarus

  • Members
  • 3,429 posts
  • Jefferson, Maine

Posted 09 July 2010 - 06:23 PM

Looks great!! Hows it coming?

#82 Turbone

Turbone

    The Original Rob

  • Moderator
  • 12,105 posts
  • WA

Posted 09 July 2010 - 10:52 PM

Still working on it.

Posted Image

Bellhousing

Posted Image

#83 bratman18

bratman18

    ADIDASubarus

  • Members
  • 3,429 posts
  • Jefferson, Maine

Posted 10 July 2010 - 07:11 AM

Great work. I really love your attention to detail!!! Too bad you couldn't bring this with you on your next trip to Maine!!!! I would really love to see this car in person!

#84 Turbone

Turbone

    The Original Rob

  • Moderator
  • 12,105 posts
  • WA

Posted 10 July 2010 - 10:27 AM

Yeah, that would be a loooong drive :eek:
As much as I have to tear into this car, I want it clean when I do.
I dont like reaching in to do something and pull my hand out all black and slimy.

#85 Turbone

Turbone

    The Original Rob

  • Moderator
  • 12,105 posts
  • WA

Posted 10 July 2010 - 04:58 PM

Ok, I think I'm done cleaning this lump...

Posted Image
Posted Image
Posted Image

Time for it to go back in (and keep my fingers crossed :rolleyes:)

#86 capn_r

capn_r

    Pseudo Soob Noob

  • Members
  • 335 posts
  • Morton WA

Posted 10 July 2010 - 09:07 PM

So should another old fart stop by and give you a hand putting it in tomorrow?

#87 Numbchux

Numbchux

    EJ conversion addict

  • Members
  • 5,983 posts
  • Duluth, MN

Posted 11 July 2010 - 01:14 AM

DANG!! That thing's clean!!

#88 Turbone

Turbone

    The Original Rob

  • Moderator
  • 12,105 posts
  • WA

Posted 11 July 2010 - 01:22 AM

So should another old fart stop by and give you a hand putting it in tomorrow?


Awesome! I could use the company (grunt grunt) :lol:

#89 phantomcrooner

phantomcrooner

    USMB is life!

  • Members
  • 138 posts
  • The mountains of Julian

Posted 12 July 2010 - 10:51 AM

DANG!! That thing's clean!!


Dito, That looks awesome man.

#90 Turbone

Turbone

    The Original Rob

  • Moderator
  • 12,105 posts
  • WA

Posted 12 July 2010 - 12:10 PM

Got the trans installed yesterday, thanks to capn_r for the help.
Need to button things up and then it will be fingers crossed till Aug 20th :rolleyes:

#91 Caboobaroo

Caboobaroo

    USMB Drunk

  • Members
  • 6,847 posts
  • Oregon City

Posted 12 July 2010 - 12:36 PM

Got the trans installed yesterday, thanks to capn_r for the help.
Need to button things up and then it will be fingers crossed till Aug 20th :rolleyes:

just don't drive it till then. Less risk of blowing something up again:lol:

#92 Turbone

Turbone

    The Original Rob

  • Moderator
  • 12,105 posts
  • WA

Posted 12 July 2010 - 03:26 PM

just don't drive it till then. Less risk of blowing something up again:lol:


I dont want to be halfway to Cashmere and have it go out on me :-\
And if something does happen, I will have time to fix it before the Show.

#93 Turbone

Turbone

    The Original Rob

  • Moderator
  • 12,105 posts
  • WA

Posted 13 July 2010 - 12:34 AM

Well, I've been at it again (cleaning).
I figured since I had the DP out, I was going to gut the cat.
And of course, I had to polish the sucker :rolleyes:

Posted Image
Posted Image
Posted Image
Posted Image

Edited by Turbone, 13 July 2010 - 12:37 AM.


#94 Numbchux

Numbchux

    EJ conversion addict

  • Members
  • 5,983 posts
  • Duluth, MN

Posted 13 July 2010 - 01:16 AM

wow, polished exhaust heatshields........I never thought :lol:

#95 Turbone

Turbone

    The Original Rob

  • Moderator
  • 12,105 posts
  • WA

Posted 13 July 2010 - 09:50 AM

wow, polished exhaust heatshields........I never thought :lol:


Yeah, I cant afford a nice aftermarket bellmouth DP...so this is the next best thing :rolleyes:

#96 Turbone

Turbone

    The Original Rob

  • Moderator
  • 12,105 posts
  • WA

Posted 14 July 2010 - 07:01 PM

Oh snap....

Noticed this when I was re-installing my trans.
Posted Image

Had a diff core laying around with a good bushing, so it was replaced.
And while I had the diff out replacing that, do you think I stuffed it back up there looking like this?

Posted Image

#97 phantomcrooner

phantomcrooner

    USMB is life!

  • Members
  • 138 posts
  • The mountains of Julian

Posted 17 July 2010 - 07:06 PM

LOL,
I'm thinking probably not.

#98 Turbone

Turbone

    The Original Rob

  • Moderator
  • 12,105 posts
  • WA

Posted 17 July 2010 - 11:29 PM

I messed up and forgot to take after pic :rolleyes:
I'll have to crawl under and take a pic sometime.

Well, after driving it almost a week all I can say is wow....what a difference.
This trans is a lot smoother and since gutting my DP the turbo spools up much quicker and I gained at least 10hp.
You can ask Russ what he thinks of it, he had a good ride in it today ;)

#99 bratman18

bratman18

    ADIDASubarus

  • Members
  • 3,429 posts
  • Jefferson, Maine

Posted 18 July 2010 - 07:43 AM

Nice, good to hear it's working well. A video would be sweet:grin:

#100 PoorManzImpreza

PoorManzImpreza

    Subaru Nut

  • Members
  • 546 posts
  • BARBADOS

Posted 18 July 2010 - 03:19 PM

nice, good to hear it's working well. A video would be sweet:grin:

+1




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users