Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

SVX idle issue


  • Please log in to reply
4 replies to this topic

#1 NWSubie

NWSubie

    USMB is life!

  • Members
  • 144 posts
  • St. Helens

Posted 04 June 2010 - 03:24 PM

So I don't see to much on the forum about SVX's but I was hoping someone sould help me out. My fathers 92 SVX is runnig great when driving but when slowing down to an idle it will go down to about 300rmps, and the car will start to die unless you hit the gas. Any ideas on what could cause it? Odd thing is it wont do it all of the time but is very annoying when it dose.

#2 Durania

Durania

    Elite Master of the Subaru

  • Members
  • 3,113 posts
  • Crossville, TN

Posted 04 June 2010 - 04:33 PM

Sounds like a MAF sensor on the way out or a dirty idle air control valve.

#3 Turbone

Turbone

    The Original Rob

  • Moderator
  • 12,087 posts
  • WA

Posted 04 June 2010 - 10:43 PM

^^^This. Could be a dirty MAF or IAC.
You can buy the MAF cleaner at a parts store, its made specifically for it.

#4 Durania

Durania

    Elite Master of the Subaru

  • Members
  • 3,113 posts
  • Crossville, TN

Posted 04 June 2010 - 10:49 PM

Posted Image

#5 NWSubie

NWSubie

    USMB is life!

  • Members
  • 144 posts
  • St. Helens

Posted 05 June 2010 - 02:06 AM

Thanks guys I'll clean out the MAF this weekend hope it works. The SVX is a really fun car to drive out here on the back country roads!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users