Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

- - - - -

IAC Motor


  • Please log in to reply
2 replies to this topic

#1 Guest_jimbo747_*

Guest_jimbo747_*
  • Guests

Posted 02 August 2003 - 09:13 AM

I've got an '87 GL Wagon, 1.8L SPFI. My mech. tells me I need a new idle air control. He wants over $400.00 for the part, plus installation. I found the part from a Subaru dealer in NJ for $270, but my mech. won't install it.

What's involved in installing this part? Is it a simple bolt-off / bolt on replacement, or is there special tools and/or adjustments required.

Thanks in advance for you help!

#2 Guest_Subi81_*

Guest_Subi81_*
  • Guests

Posted 13 August 2003 - 12:42 PM

is that the valve that is mounted ontop of the temostat? If so you could peobably find one in a junk yard for really check. I have never heard of one going out.

Good luck

#3 Guest_calebz_*

Guest_calebz_*
  • Guests

Posted 13 August 2003 - 01:06 PM

They do go out. someone else on the board is dealing with the same problem. usual symptoms are crappy idle when cold. motor bogs down when AC is on. stuff like that.. it isn't hard to install/replace. its right in front of the TB. check the error codes on your computer. heres how

<a href="http://www.westol.com/neper/ecucodes.html" target="top">Soob trouble codes</a>

Oh yeah, and get a new mechanic. stop getting screwed.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users