Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Found out why my car is sluggish


  • Please log in to reply
2 replies to this topic

#1 calebz

calebz

    Andys Coupe killed my cat

  • Administrator
  • 7,547 posts
  • Tacoma

Posted 23 February 2004 - 12:18 PM

Slapped a fuel pressure tester on my wagon yesterday.. never got above 30psi (kida oscillated from 22-30) :( ... Time for a new fuel pump.. This eplains quite a lot about the lack of power that I have had right after boost comes on.. also explains why passing anyone at 70+MPH on my trip to Austin last week was such a joke..Oh well.. I have new plugs, wires, air filter and fule filter.. after the pump, she should be a very happy car... Now if I can just find a good one that doesn't cost an arm and a leg...

#2 Skip

Skip

    Flatuous Blather

  • Moderator
  • 8,991 posts
  • Latrobe, Pennsylvania

Posted 23 February 2004 - 12:25 PM

Caleb, I am sure you pinched the return line from the FPR off to make sure the problem wasn't with it.
These are pretty tuff pumps, I'd try a boneyard model.


#3 calebz

calebz

    Andys Coupe killed my cat

  • Administrator
  • 7,547 posts
  • Tacoma

Posted 23 February 2004 - 12:27 PM

Yessir Skipper sir, I sure did pinch off the return line.

Boneyard pump it shall be!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users