Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Another small Legacy/Liberty issue


  • Please log in to reply
6 replies to this topic

#1 Brett_j

Brett_j

    USMB Regular

  • Members
  • PipPipPip
  • 48 posts
  • Perth

Posted 26 February 2004 - 06:49 AM

Ok just lately I'll driving along and then out of nowhere a high pitched alarm sounds,now its not a noise from anything Broken just sounds like an alarm of some kind.The weird part is it goes away as soon as I press the brakes,reappearing occasionally.Now there are no warning lights and I have checked fluid levels and all seems ok.Since I dont have the car manual I figured one of the many guru's here would maube know.

Thanks
Brett

P.S. Its the Legacy/Liberty

#2 Soup

Soup

    USMB Regular

  • Members
  • PipPipPip
  • 35 posts
  • Ottawa, Canada

Posted 26 February 2004 - 08:06 AM

What Speed, and from where is the sound coming from

#3 Brett_j

Brett_j

    USMB Regular

  • Members
  • PipPipPip
  • 48 posts
  • Perth

Posted 26 February 2004 - 08:14 AM

It happens at random speeds and sounds like it is coming from under the dash area.

#4 Nuwan

Nuwan

    USMB Regular

  • Members
  • PipPipPip
  • 69 posts
  • Brampton, Ontario, Canada

Posted 26 February 2004 - 11:13 AM

Does your car have an alarm or remote car starter on it? maybe from a previous owner?

#5 Soup

Soup

    USMB Regular

  • Members
  • PipPipPip
  • 35 posts
  • Ottawa, Canada

Posted 26 February 2004 - 01:25 PM

My 2000 legacy had a very loud squeal at high speeds (around 120 kph) It sounded like a warning horn. It was the rubber windshield trim on the r/h side vibrating. It drove me crazy til I located it. It sounded like it was coming from under the dash.

#6 Brett_j

Brett_j

    USMB Regular

  • Members
  • PipPipPip
  • 48 posts
  • Perth

Posted 26 February 2004 - 05:47 PM

This definatley sounds like a warning buzzer,kinda like on some cars when you leave the lights on but a bit quieter.Its continual until I hit the brakes and goes away?Might have to speak to Subaru.

#7 Soup

Soup

    USMB Regular

  • Members
  • PipPipPip
  • 35 posts
  • Ottawa, Canada

Posted 27 February 2004 - 12:29 PM

What kind of trim is on your windsield? I isolated mine by putting some tape over the trim. The trim on my 2000 is a flexible rubber, all around the outside edje.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users