Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo

hi from washington, 1st 1993 loyale few problems hope to fix


  • Please log in to reply
6 replies to this topic

#1 zacrody

zacrody

    New User

  • Members
  • Pip
  • 3 posts
  • stanwood

Posted 14 November 2010 - 11:41 PM

hi my name is zac i just got this car off craigslist for the snowboarding season since my bagged truck cant make it up to the mountain. well turns out its got trouble before its snow ready.
1. wen the throttle is 3/4 to wide open it dies or boggs down and will just die if i dont let up.
2. the car really doesnt heat up only stays on the bottom third of the temp.
3. my worst problem is not having heat its like a luke warm sometimes.

well i hope you guys can guide me in the right direction thanks in advance

#2 NorthWet

NorthWet

    Eeyore Incarnate

  • Members
  • 5,039 posts
  • Bremerton, WA

Posted 15 November 2010 - 01:37 AM

hi my name is zac i just got this car off craigslist for the snowboarding season since my bagged truck cant make it up to the mountain. well turns out its got trouble before its snow ready.
1. wen the throttle is 3/4 to wide open it dies or boggs down and will just die if i dont let up.
2. the car really doesnt heat up only stays on the bottom third of the temp.
3. my worst problem is not having heat its like a luke warm sometimes.

well i hope you guys can guide me in the right direction thanks in advance


!) Several possible causes, but dirty fuel filter tops my list. Others include the usual tune-up items (Plugs, wires, distributor cap/rotor, and timing). If it runs fine most of the time and starts to fall flat on its face under load, low fuel flow due to clogged fuel filter is most likely.

2) Subaru temp gauges are notoriously inexact. Just because it reads low doesn't mean that it is. However, coupled with your "not having heat" (I assume from the heater/defroster), I would guess that someone removed the thermostat. If true, they might have done so in some misguided attempt to relieve a cooling problem... like a clogged radiator.

3) see 2)

#3 swampbrat

swampbrat

    USMB is life!

  • Members
  • 169 posts
  • Page Az

Posted 15 November 2010 - 02:08 PM

ditto! and welcome to the board! do you know the history of the car? can you tell if it's been monkeyed with or well maintained?

#4 zacrody

zacrody

    New User

  • Members
  • Pip
  • 3 posts
  • stanwood

Posted 15 November 2010 - 02:37 PM

well ill defnetly check out that fuel filter but i got the car from some random guy up in the hills and i think the thermostat might be removed cause its got another fan next to the stock one that always runs its all ghettoly put in there just jumped to a fuse in the panel... i dont think the heater core is plugged cause i took off the lines and they flow coolant. is there i way i can check to see no thermo? or just tear it apart and replace? do you know were this fuel filter could be located?

#5 Olnick

Olnick

    Ol' Subaru Guy

  • Members
  • 2,613 posts
  • Honolulu HI

Posted 15 November 2010 - 03:13 PM

Welcome aboard, zacrody. If you post your questions in the New Gen Forum you'll get a lot more response.

#6 True2Blue

True2Blue

    SU<3ARU

  • Members
  • 776 posts
  • Belfair WA

Posted 17 November 2010 - 01:42 AM

well ill defnetly check out that fuel filter but i got the car from some random guy up in the hills and i think the thermostat might be removed cause its got another fan next to the stock one that always runs its all ghettoly put in there just jumped to a fuse in the panel... i dont think the heater core is plugged cause i took off the lines and they flow coolant. is there i way i can check to see no thermo? or just tear it apart and replace? do you know were this fuel filter could be located?



Hey man.. it COULD be a fuel filter but by the way it sounds you may not have one :lol: your gas tank can have a vacuum/not vent right.. if you want to find the filter simply follow the fuel line.. These cars are stupid simple

or ill just take 5 minutes to make a pic for you :)

Posted Image


Looks like this from the side


Posted Image


I'd just pull the thermostat housing and check er out.. with a ghetto fan rigged up and no thermostat (low/no heat from heater core) ill promise you that your radiator is plugged up and that was a cheap "fix" look for a radiator and remove the rigged fan heres a parts link http://seattle.craig...2058059213.html

#7 zacrody

zacrody

    New User

  • Members
  • Pip
  • 3 posts
  • stanwood

Posted 18 November 2010 - 07:54 PM

alright thanks man you guys are really helpfulll




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users