Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

gas milage/ecs


  • Please log in to reply
4 replies to this topic

#1 DaveAP

DaveAP

    Subaru Fanatic!

  • Members
  • 386 posts
  • Prescott, Arizona

Posted 28 February 2004 - 06:07 PM

'84 auto brat, stock carb.
I was getting 12 mpg, ecs light was always on. Last week I took the top off the air cleaner, the ecs light quit coming on, and I got closer to 20+ mpg.
Today I bought a new air filter, put the top back on the air cleaner, and I'm back to the ecs light being on,and assuming I'm back to poor milage.
What should I be looking at in the smog system (?) to clean/ and or replace to improve my milage?
Thanks for any help, dp.

#2 DaveAP

DaveAP

    Subaru Fanatic!

  • Members
  • 386 posts
  • Prescott, Arizona

Posted 29 February 2004 - 11:35 AM

no takers?

#3 subarubrat

subarubrat

    1000+ Super USER!

  • Members
  • 1,234 posts
  • Bealeton, VA

Posted 29 February 2004 - 11:49 AM

Try just unplugging the ECS all together. When my 82 had the ECS it gave me all sorts of problems from bad mileage to stalling because the feedback solenoid would cut the fuel. I unplugged it and threw it into the woods and it ran just fine for a few weeks until I did the 6cyl swap.

#4 Skip

Skip

    Flatuous Blather

  • Moderator
  • 8,991 posts
  • Latrobe, Pennsylvania

Posted 29 February 2004 - 11:53 AM

Dave your Brat must have an 02 sensor, it may be the problem, the carb is controled by a set of duty solenoids also.
These may have problems.
and if
you mean "Check engine" light when you say
"ecs light was always on
the error code is stored in the ECU.
Why not retrieve the code and find out what is not to spec?

ECU code retrieval instructions and code chart

BTW most newer Brats do not have ECU's maybe because your's is an automatic or a CA model?
You don't mean "erg" light by chance do you?


#5 DaveAP

DaveAP

    Subaru Fanatic!

  • Members
  • 386 posts
  • Prescott, Arizona

Posted 01 March 2004 - 12:07 AM

I'd like to chuck it, if it won't affect anything. We don't have emission testing up here.
Skip, it is the ecs light, haven't seen the check engine light come on.. Is the o2 sensor on the exhaust somewhere. I've never messed with one before.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users