Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

81 hatch wont stay running


  • Please log in to reply
2 replies to this topic

#1 Uberoo

Uberoo

    Subaru Wheeler

  • Members
  • 3,393 posts
  • lewiston,ID

Posted 14 December 2010 - 05:26 PM

Im posting this for a friend of mine.

He has an 81 FWD hatch with the EA71. All of the dash lights are on and the car constantly stalls.It will fire up immediately after it stalls then it will stall again in 1-5 minutes.

Im thinking the alternator or the regulator is bad, but I haven't heard of a bad alternator stalling a carbed engine.

Any idea what would cause the the stalling?Im thinking if either the alt or the reg went bad it would somehow take power away from the coil or ignition and somehow stop it from fireing?

#2 3eyedwagon

3eyedwagon

    Build it, don't buy it!

  • Members
  • 708 posts
  • Apache Junction

Posted 14 December 2010 - 06:02 PM

[quote name='Uberoo']Im thinking the alternator or the regulator is bad, but I haven't heard of a bad alternator stalling a carbed engine.

quote]

Has nothing to do with being carbed or not. A bad alternator on a carbed motor will still let the battery run dead if it has electronic ignition.

I'm pretty sure the ea71s are points though. I don't know for certain, so, you should check.

I'd check the coil from the get go. As well as all the other ignition parts.

I've seen alot of aged coils get hot, give up on making spark until they can rest, and then go again.

#3 Uberoo

Uberoo

    Subaru Wheeler

  • Members
  • 3,393 posts
  • lewiston,ID

Posted 14 December 2010 - 07:13 PM

I swapped the regulator from one I had on a parts car.Got rid of all the lights in the dash being on, and also stopped it from stalling.However the battery still went flat just from running so the alternator is not charging.

Im thinking the alternator went and took the regulator with it.Then after a certain amount of time there wasn't a stable reference voltage for the ignition then the car would stall.I dunno just my guess.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users