Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Electrical fuel glitch GL-10 1988


  • Please log in to reply
1 reply to this topic

#1 Soiuxbwarrior

Soiuxbwarrior

    New User

  • Members
  • PipPip
  • 12 posts
  • Obese City

Posted 03 March 2004 - 05:23 PM

My first posting on my 23rd subaru.
Had an intermintent electrical short. The short is now letting me crank the starter after changing some cabels.
Now the fuel pump hums and squirts intermintantly when the key is on "on". It fires with a prime down the intake.
I think a relay or control unit or bad fuel pump pressure.
MPFI with all options,digital dash,pnu-maniac shocks,etc.
Need help please. I`m off to the magnet store to get that socket out of the intake.
Thanks Dan.
There is more to the story. Of course the check engine light has been on for a long time.

#2 calebz

calebz

    Andys Coupe killed my cat

  • Administrator
  • 7,547 posts
  • Tacoma

Posted 03 March 2004 - 05:38 PM

Now the fuel pump hums and squirts intermintantly when the key is on "on".



Does it cycle on and off every 1.5 seconds or so?

If so, the green diagnostic connectors are probably plugged in and it is supposed to do that when they are plugged in.

You said the check engine light is on.. Have you pulled the codes yet? Those will probably give you some direction in diagnosing the problem.

PS.. Sockets do not belong in the intake.. I usually store mine in the tool box :D




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users