Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

engine wiring help


  • Please log in to reply
19 replies to this topic

#1 shuffbag

shuffbag

    New User

  • Members
  • PipPip
  • 25 posts
  • adelaide

Posted 06 June 2011 - 07:56 PM

yes i have serched for days :banghead:

im going to be fitting a ej25 dohc in to a vortex (xt). now my problem is i cant find a pin out.below is a picture of the ecu and plug, if anyone can point me to a pinout?
Posted Image
Posted Image
Posted Image
now im guessing this is like a usual ej wiring chop with only the main relay and fuel relay being needed from this mess of wiring with the exception of some fan wires im going to save from the smj (see below)
Posted Image

and im also guessing all this gear can go, keyless cont module and cruz module
Posted Image
oh and this is what its going into
Posted Image
Posted Image

#2 grossgary

grossgary

    Elite Master of the Subaru

  • Members
  • 20,004 posts
  • WV

Posted 06 June 2011 - 08:00 PM

where are you - aus?
is that an aus engine?

are the pinouts the same as in the US?

you can swap Ej25 and EJ22 ECU's all day long. i swapped an EJ22 ECU into my 1996 EJ25 equipped legacy - plug and play, no difference at all.

so this means, if this holds down there where you are, that an EJ22 pin out would do you just fine.

the DOHC doesn't mean anything as far as EJ25/EJ22 goes, the computer doesn't know, it's only a mechanical difference - EJ25 and EJ22 both use one crank and one cam sensor (same part even!).

over here a 1996-1998 EJ22 pin out would be identical to all DOHC EJ25 pin outs.

just saying that in case an EJ22 pin out is easier to find.

Edited by grossgary, 06 June 2011 - 08:04 PM.


#3 grossgary

grossgary

    Elite Master of the Subaru

  • Members
  • 20,004 posts
  • WV

Posted 06 June 2011 - 08:01 PM

first hit on a google search gave this:
http://www.sl-i.net/...t=13168&start=0

might want to plug around there a bit too.

#4 shuffbag

shuffbag

    New User

  • Members
  • PipPip
  • 25 posts
  • adelaide

Posted 06 June 2011 - 08:08 PM

and its from a bg outback

#5 shuffbag

shuffbag

    New User

  • Members
  • PipPip
  • 25 posts
  • adelaide

Posted 06 June 2011 - 08:13 PM

thanks for the help i have seen that page before, my problem is i cant find any for my specific plug. are all pinouts numbered the same way? like can i take that info and just count across the pins on the ecu? from the top right counting to the left?

#6 Gloyale

Gloyale

    It's a sickness

  • Members
  • 9,403 posts
  • Corvallis, OR PNW

Posted 07 June 2011 - 10:41 AM

FWIW, if the XT (vortex) has cruise already, you can leave the cruise computer in the EJ harness, and mate the XT buttons and Vac pump to the EJ cruise computer. The EJ cruise units are much better. Use the EJ cruise cable/actuator......the XT one, mounted to the pedal box with the little chain to pull the peddle SUCKS.

#7 shuffbag

shuffbag

    New User

  • Members
  • PipPip
  • 25 posts
  • adelaide

Posted 07 June 2011 - 07:51 PM

nah i have no cruze, this was only a injected ea82 fwd vortex, it now has a L 4wd rear end and is awaiting engine and box. which i have but i need to sort the wiring first.
im not going to be running cruze or aircon and only require wiring for engine and maybe the thermo fans

#8 shuffbag

shuffbag

    New User

  • Members
  • PipPip
  • 25 posts
  • adelaide

Posted 16 June 2011 - 03:41 AM

ok so i started triming the loom down today, got almost everything stripped and have hit a wall again...
VV does this look like a NORMAL amount of wires to be remaining from the ecu?
Posted Image
ignighter/afm/o2 all plugged in
Posted Image
green/black plugs, main relay and pump relay
Posted Image
my main unknown issue is from the 2 plugs on the passanger side (your drivers side) is a green and purple wire from the smaller of the 2 plugs, are no longer attached to any thing?? and i cant recall were they might have come from?
Posted Image

so after all this im still scratching my head as to were im going to tap in the power and if one ground is enough?

#9 subaruguru

subaruguru

    Scammer

  • Members
  • 1,642 posts
  • Yakima Wa,

Posted 16 June 2011 - 04:00 AM

One ground should be plenty for the ECM it would be a good idea to put at least 2 from the engine,trans to the body then one good one from the body to the - on the battery.

Cheers R.

#10 shuffbag

shuffbag

    New User

  • Members
  • PipPip
  • 25 posts
  • adelaide

Posted 16 June 2011 - 04:42 AM

hooked it to a battery today and the main relay clicked but fuel pump relay did not :confused:
i couldnt see any light flash within the ecu.
i also didnt get spark while turning it over.

aaarrrrggggghhhhhh i now remember why i havent done a swap in years

#11 Benoit

Benoit

    New User

  • Members
  • Pip
  • 6 posts
  • France

Posted 16 June 2011 - 05:12 AM

Hi,
Did you finally find the pinout of your ECU?
I'm stuck with the same since weeks...

Please help ;-)

Benoit

#12 shuffbag

shuffbag

    New User

  • Members
  • PipPip
  • 25 posts
  • adelaide

Posted 16 June 2011 - 06:19 AM

still looking, i only manage to find ecu pinouts that use multi plugs. not just one like mine.
i am going by feel and working off colours atm

#13 Benoit

Benoit

    New User

  • Members
  • Pip
  • 6 posts
  • France

Posted 16 June 2011 - 07:23 AM

Ok, I have exactly the same ECU, with only one connector.
I found an interesting stuff :
http://imageshack.us...calculateu.jpg/

but there's only the half of it...

I found too that the same ECU was mounted on Nissan Altima, and found the pinout. But the numbers doesn't match with the subaru one :confused:
Posted Image

Posted Image

Hope this help...

#14 Benoit

Benoit

    New User

  • Members
  • Pip
  • 6 posts
  • France

Posted 19 June 2011 - 03:39 PM

Hi suffbag,

I tried the ecu and my circuit today, but neither ignition (main) relay neither fuel pump relay are clicking.

Can you just tell me the pins you connected all +supply, and all ground please?

will help me a lot... I'm stuck :confused::confused:


Benoit

#15 shuffbag

shuffbag

    New User

  • Members
  • PipPip
  • 25 posts
  • adelaide

Posted 20 June 2011 - 03:07 AM

my ign relay clicks but not my fuel pump relay.

i have no power to my ignighter/coil pack either. power is getting to the ecu but i dont think i have it grounded, so power isnt being passed on were its needed.

more probing is needed :-\

#16 Benoit

Benoit

    New User

  • Members
  • Pip
  • 6 posts
  • France

Posted 20 June 2011 - 03:20 AM

I'm affraid of toasting the ECU with testing :-\

Still searching...

#17 subaruguru

subaruguru

    Scammer

  • Members
  • 1,642 posts
  • Yakima Wa,

Posted 20 June 2011 - 03:30 AM

try here http://jdmfsm.info/Auto/Japan/Subaru/

cheers r.

#18 Benoit

Benoit

    New User

  • Members
  • Pip
  • 6 posts
  • France

Posted 20 June 2011 - 03:43 AM

Thank you subaruguru, but I've already explored this link.
The pinout doesn't match our specific ECU... (not the same connector)

#19 shuffbag

shuffbag

    New User

  • Members
  • PipPip
  • 25 posts
  • adelaide

Posted 20 June 2011 - 04:30 AM

well i brought the loom inside to work on and didnt get anything done :(
there is no led in this ecu so no easy give away if its powered correctly.

tomorrow im going to reconect it to the engine and just group what appear to look like powers and grounds and give it a spin, see if i get spark!

if not people have been saying ej22 looms work? with the ej22 ecu? i have stripped one of those looms before with no problems. so maybe if a 22 loom will work with all my 25 sensors i'll just use that?

my main problem is no specific pinout for the ecu on the first page, yes it is out of a AUS 1998 OUTBACK BG9

#20 Benoit

Benoit

    New User

  • Members
  • Pip
  • 6 posts
  • France

Posted 20 June 2011 - 04:34 AM

Mine is exactly like yours, and can't find this f**** pinout :eek:

Posted Image
Posted Image




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users