Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo

What's up fellow suby lovers


  • Please log in to reply
4 replies to this topic

#1 mpudz

mpudz

    New User

  • Members
  • PipPip
  • 14 posts
  • Arlington

Posted 29 July 2011 - 03:31 PM

Hey guys,

My name's Mike... just moved to Texas from New Jersey (not easy to put up with the heat here >.<). I've got a 1997 Legacy GT with quite a few modifications on it... I'll post some pictures later on. I used to be quite active on SL-i.net, but haven't had too much time to spend on the car lately. Now, however, with over 150k on the car, I'm starting to have some issues (random misfires being the major one) so I'm hoping to get some help with that as well as provide help to others based on my many experiences working on my suby.

#2 1-3-2-4

1-3-2-4

    Subaru Mike!

  • Members
  • 3,727 posts
  • Greenwich

Posted 29 July 2011 - 05:33 PM

Hey guys,

My name's Mike... just moved to Texas from New Jersey (not easy to put up with the heat here >.<). I've got a 1997 Legacy GT with quite a few modifications on it... I'll post some pictures later on. I used to be quite active on SL-i.net, but haven't had too much time to spend on the car lately. Now, however, with over 150k on the car, I'm starting to have some issues (random misfires being the major one) so I'm hoping to get some help with that as well as provide help to others based on my many experiences working on my suby.


Hey I'm on SL-i as well same user name

#3 mpudz

mpudz

    New User

  • Members
  • PipPip
  • 14 posts
  • Arlington

Posted 29 July 2011 - 09:32 PM

I thought your car looked familiar... I was "shizznats" on SL-i

#4 1-3-2-4

1-3-2-4

    Subaru Mike!

  • Members
  • 3,727 posts
  • Greenwich

Posted 30 July 2011 - 06:43 AM

Ah cool about those misfires it could be anything.. plug wires, coil pack, ignition module.. spark plugs.. exhaust valves..

#5 mpudz

mpudz

    New User

  • Members
  • PipPip
  • 14 posts
  • Arlington

Posted 30 July 2011 - 01:18 PM

Yeah, thank you. I read through your thread about your misfire issues... did you get yours resolved? I posted my issue in detail here: http://www.ultimates...116#post1035116 ... as you can see it's quite similar to what you described happening in your car.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users