Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
* * * * * 1 votes

1984 GL Wagon Fwd Build


  • Please log in to reply
441 replies to this topic

#401 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,349 posts
  • Worcester, VT

Posted 19 February 2013 - 09:01 PM

Picking up some RS five spokes tomorrow, either for this or the brat! 



#402 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,349 posts
  • Worcester, VT

Posted 20 February 2013 - 09:07 PM

Well I went and got my RS five spokes tonight, I probably should have waited due to how bad the roads were. I had to go over a mountain pass, and I knew it was bad around the time the suv behind me passed me in the oncoming lane sideways... Props to the outback I have been driving, the thing is a tank! Anyway I got the wheels, and they need to be painted, but are in super nice shape. 

 

My outback after tonights drive (turned over 226k too!) 

 

 

1-90_zps0c5c8a99.jpg

 

 

My new wheels, they need paint, silver if they go on the brat, gold if they go on this

 

2-59_zps89aca41c.jpg

 

 

 

 

 



#403 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,349 posts
  • Worcester, VT

Posted 16 March 2013 - 04:41 PM

Long time no post, I've been too busy flipping some cars to work on my own. Today I got a chance to bring the wagon in and start prepping it for the fi swap, and wire tuck. Probably going to start on the five lug swap soon as well. I need to buy my wheels and then I can start that! Anyway a few pics from today.
 
 
 
Also deleted the ac, there's no longer room for it in this bay, plus it didn't work. Also weight reduction yo. 
 
 
Also since my last post I picked up a 93 legacy ss for 900 bucks ($300 was the wheels) 270k and rusty as can be, but very fun fun so far! 
 
 


#404 88wacaroo

88wacaroo

    USMB Regular

  • Members
  • 235 posts
  • Denver,Co.

Posted 16 March 2013 - 08:55 PM

Nice Job on the WGN. I just Read Thru THE Whole Post W/Pics-Alot of work, :popcorn:  :drunk:  It"s a Shame it Sat for so long before you did anything with it- The Rust Issue :( You made more work for yourself....I"m glad we don"t have Rust Bad like that here-COLO. We have it but it"s Mag Chloride Just as bad in my opinion-It likes to Weld Aluminum and Steel Together On top of the Coroding Factor Too <_< I wash the crap out of the underneath of everything to avoid it!! I liked the all BLK. No Chrome-I don"t like chrome much either...I was gonna say paint the bumpers Blk.and paint the rubber strip Wht. and on the Whls. paint the center and the spokes Blk. W/ the center caps gold to break up the gold but it"s a moot point now W/changing Whls. and all...I Really Dig that you drove it cross country and you didn"t act like it was a Big deal at all W/ Throwin the used MTR. in it an goin Right On :headbang: I"d hop in my hatchie{Zumi} W/Dogs right now and wouldn"t hesitate to Drive it anywhere in the US-Canada {I"d have to change the oil 1st it"s due} And OH Yea U Lucky b**&^&* A :brat: And A uncracked dash :slobber: Some guys have all the luck :huh: Props on the WGN.though Nice Job!!!!



#405 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,349 posts
  • Worcester, VT

Posted 17 March 2013 - 06:02 PM

The rust seems to be a way of life up here, most of us just get used to it. This car was still savable so I fixed it, it it had been much worse I would have just found another from elsewhere in the country. I never drove it cross country, I picked up parts while taking a road trip in a 350 dollar volvo. But thanks for the complements! 

 

Anyway, today I got the harness pulled out. I also removed the tire jack mount (I'm just going to put the jack under one of the front seats) And I also removed the battery box as I'll be moving that to the opposite side of the car due to the air intake location. I wanted it too look factory in there when I'm all finished with it. I'm also going to sand down the bay and paint it again while I have it all apart. Here's some pics of the progress. 

 

 
 
 
It turns out that I won't be able to run the harness the way I wanted to on the driver's side due to the fuel line locations, but I should be able to make it work. I also ordered some parts for it today including hella H4 headlights, ss brake lines for when I do the brake swap, and I'm hopefully going to be ordering my wheels tonight. 


#406 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,349 posts
  • Worcester, VT

Posted 18 March 2013 - 06:16 PM

New enkeis are on the way! 



#407 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,349 posts
  • Worcester, VT

Posted 19 March 2013 - 06:07 PM

Well that was crazy fast! The wheels came in today, now I just have to figure out what to wrap them in, and find someone to retaper my control arms for ej ball joints! I still have to get lug nuts for them, and center caps from other enkei wheels as they don't offer them for these. 
 
 


#408 Mechanical_misfit

Mechanical_misfit

    Eat, Live, Breath Subaru

  • Members
  • 397 posts
  • Muskegon, MI

Posted 21 March 2013 - 04:14 PM

This wagon just keeps getting cooler and cooler. Care to shed some light on what your front suspension will consist of? Nice work as always!

#409 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,349 posts
  • Worcester, VT

Posted 21 March 2013 - 06:03 PM

Thanks man! Yours is looking great as well! The front suspension I still have to figure out. I know I need to have the control arms re-tapered I'll be using front spindles off a newer ej car, probably a 2000 forester I have around. The brakes will be off a 97 outback (dual pistons) And I'll be mismatching the cv's using the outer drivers for a newer ej car. As far as the struts go I'm not sure. I've tried to use ej struts in an ea81 body before and it doesn't work as the top spring plates hit the towers. I was thinking of trying to modify stock struts to fit the lower section of an ej strut (just the mounting points), or getting some coil sleeves for ej struts. Rear brakes are going to be ej, with xt6 fwd hubs, hopefully a ej e-brake, and cables will work as I plan on using ej rear backing plates too. But I would like to finish up the five lug first before I start on all the suspension stuff. Hopefully I'll sell my audi as well so I can have some extra cash too.... 

 

In other news I picked up a hole saw to rout my harness (hopefully this weekend) And my hella h4 headlight conversion came in! 



#410 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,349 posts
  • Worcester, VT

Posted 24 March 2013 - 01:25 PM

Got my holes cut to run my harness. I still need to pick up some hose to glue on to the shape edges so the harness doesn't get worn into. 

 

The new lights

 

 
This is where the harness is going on the drivers side. 
 
After some welding, grinding, filing, and paint.
 
cut out some shapes to fill in holes that will no longer be used. 
 
This is to fill the hole more in the center of the photo. The one in the lower right is the one I cut to run the harness.
 
And where the harness goes back into the car on the passenger's side. 


#411 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,349 posts
  • Worcester, VT

Posted 05 May 2013 - 04:53 PM

Got around to working on this some today. I can't let the legacy, beetle, and the rs I just picked up take all my time lol.gif

Anyway I added some loyale sheet metal to it today, and did a fair amount of welding deleting all of the non used holes in the engine bay. 



The section under the air box so it can get some air outside of the engine bay I also added a hole for the loyale window wash res.
 
1-90_zpsfbbb9fd3.jpg
 
Drivers side
4-33_zps91fba5be.jpg
 
air box (still need to make mounts for this, and the reservoir in place.
 
2-59_zpse725fcc4.jpg
 
From the other side (and yes I did fit the fender to make sure everything was going to clear)
3-50_zps60021b0f.jpg
 
Where the old harness used to go. 
 
5-19_zps41929828.jpg
 
That's all for this weekend. Next weekend I hope to get everything sanded down, and maybe even painted! 

Edited by 1982gl4, 05 May 2013 - 05:03 PM.


#412 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,349 posts
  • Worcester, VT

Posted 23 July 2013 - 10:28 AM

Work on this has been pretty slow, because I have a lot going on, but I have gotten some work done in the last couple of weeks. Engine bay is painted, and I finished up my distributor yesterday. I've also started running all of the wiring harnesses, and reassembling the engine bay. 

 

 


#413 AKghandi

AKghandi

    87 GL-10 2" lift 27" tires, 86 GL 2" lift 29"

  • Members
  • 1,056 posts
  • Anchorage, Alaska

Posted 23 July 2013 - 11:56 PM

how come, you have a rusty legacy ss, and a CLEAN 2wd gl wagon.....and the little voice in the back of your head isn't screaming...EJ22t IT!!

 

seriously, if you can find a 2wd legacy or imp trans thats what i would be doing..

 

I'm usually against the EJ IT voice but cmon.. you have most of the parts and a sweet car to put it in.



#414 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,349 posts
  • Worcester, VT

Posted 24 July 2013 - 06:01 PM

how come, you have a rusty legacy ss, and a CLEAN 2wd gl wagon.....and the little voice in the back of your head isn't screaming...EJ22t IT!!

 

seriously, if you can find a 2wd legacy or imp trans thats what i would be doing..

 

I'm usually against the EJ IT voice but cmon.. you have most of the parts and a sweet car to put it in.

 

I would, but I have plans for the 22T, I'm going to rebuild it, and put it in my nice 91 ss for it's performance build when the time comes, I may then put my good stock 22t in my brat, but I'm undecided for right now. This car is staying an ea81, I just like it in this car, i want to keep it somewhat old school. 

 

 

Today my friend Will and I got a lot done, he got the fuel pump in, and worked on the wiring some, as did I. I also got the manifold bolted down, all the fuel lines ran, new filter in, alternator back on. Basically just some wiring left, and then it should fire up! I gave up on a full wire tuck, it was just going to be too much cutting an moving things. I cleaned everything up, and it's much better than it was even stock, so for now I'm totally happy with that. 
 
 
And my wiring mess. 


#415 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,349 posts
  • Worcester, VT

Posted 26 July 2013 - 08:28 PM

Getting close, I have to hook up power to a couple relays and wire the fuel pump, it should be almost ready to start. I need to get the correct thermostat, and an upper radiator hose as well, but I would love to hear this fire up in the next couple of days even for just a few seconds! 


Edited by 1982gl4, 28 July 2013 - 07:31 AM.


#416 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,349 posts
  • Worcester, VT

Posted 28 July 2013 - 08:35 PM

Finished up all the wiring this afternoon. All is good, except I keep blowing the fuse to the coil/fuel pump relay, so I haven't started it yet. I've traced down the issue to the coil/ignitor. I swapped a spare coil I had and the same issues keeps happening, I think I have the post coil connections mixed up, I'm going to look into wiring diagrams tomorrow at work, and then it should run! 



#417 turbosubarubrat

turbosubarubrat

    Subaru Nut

  • Members
  • 1,018 posts
  • Sandy, OR

Posted 29 July 2013 - 12:55 AM

looks great and i really like what you have done with this one. im definently watching to see how this is going together because i might do this to my brat if its a worth while swap that runs good.



#418 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,349 posts
  • Worcester, VT

Posted 29 July 2013 - 07:16 PM

Figured out the problem. Turns out there was supposed to be a condenser. I grabbed one off my old coil, and boom, it started. Runs great, only ran it about 20 sec due to no radiator, now I need to put it together enough to take it for a test drive!!

 

Here's a video of it running:

 

http://s1207.photobu...016bb3.mp4.html

 

 



#419 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,349 posts
  • Worcester, VT

Posted 04 August 2013 - 10:37 AM

It's all back together now. I took it for a drive last night, seems to go pretty good. I need to time it now and then I think it will be great. It does have some check engine light issues right now, but I know why. I need to get some resistors for the egr, and purge solenoids. And on top of that I don't have the clutch switch hooked up as I didn't feel like swapping peddles right now... The radiator fans didn't come on during the drive last night so I have to figure that out, probably just a bad connection. I'm also having issues with the headlights due to the odd way these light are powered/grounded. I have the high beams working well, but the low beams I'm having issues with.... 
 
Some pics now that is is all back together! 
 
 
 
 


#420 Crazyeights

Crazyeights

    SubaRube Goldberg

  • Gold Subscribers
  • 892 posts
  • PNW

Posted 04 August 2013 - 10:47 AM

It looks like the factory did it. Good work!



#421 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,349 posts
  • Worcester, VT

Posted 04 August 2013 - 02:29 PM

Thanks! That's what I was going for, I really wanted to keep a semi stock appearance. Someone that knows these old subarus would take a second look, but someone that didn't know would think it came this way. Now I just need to get cracking on the five lug! 



#422 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,349 posts
  • Worcester, VT

Posted 09 August 2013 - 11:04 PM

Wrapped some things up in the engine bay tonight. I got a smaller battery for it, which fits in the bay much better, and it weighs about half as much as the old one. I had to make a hold down for it, I also mounted my ej fuel filter, using a modified bracket off a legacy, and the stock mount for the gl. I also wired in my hellas again, and hooked up the parking lights. I relocated the coolant overflow I had with the old carb set up to the other side of the bay, because the battery is now taking up its old space. Tomorrow it goes to a car show, and for it's first real drive since the swap so hopefully all goes well. 
 
 
 


#423 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,349 posts
  • Worcester, VT

Posted 10 August 2013 - 09:23 PM

 
I'd say today was pretty successful, I drove the car 50 miles, and nothing eventful happened at all. I swapped on my Subaru alloys as they have much better tread, and don't go flat after a day. I'll be using these until I five lug it. Not sure when that is going to be as I really want to enjoy it some before I have to park it for winter.... I took it to the Stowe Antique Car show, I was one of two Japanese cars there, the other was a Datsun 240. A lot of people seemed to take interest as there are none of these left here. It was also great to talk to some car guys, and see what everyone else brought. I really like this show because of the verity of cars that show up. Here are a few pics of today, I didn't take a ton, as I was talking to people most of the day, mostly about VW's as I recently acquired  a 72 bus... 
 
 
 
 
 
 


#424 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,349 posts
  • Worcester, VT

Posted 13 August 2013 - 06:10 PM

Adjusted the valves, timing, and changed the oil today. I still think it could use a bit more timing advance, but it idles much smoother now. I'm driving it quite a bit, and I'm very interested to see what it is getting for milage. Starting to gather things for the five lug swap. Picked up some new ej ball joints, and I'm looking for the spare set of ea81 control arms I have around somewhere.... 



#425 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,349 posts
  • Worcester, VT

Posted 30 August 2013 - 05:26 PM

Still messing with the timing some, tonight I tried it with the connectors hooked up, I think that may have made a difference. Also checked the codes. So far I only have two, which both should be in there. 34, and 35 egr, and evap, now I just need to get some resistors for them. I also have started to gather a lot of parts for the five lug swap. I have front spindles now off a 97 brighton legacy, 1991 legacy turbo brakes, stainless brake lines, all the stuff for the rear, with the exception of e-brake stuff. I picked up new control arm bushings for it today, and I have a couple of leads to re taper the control arms. All I really have left to figure out is front struts, and tires, and I need to get a proportioning valve.






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users