Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
* * * * * 1 votes

1984 GL Wagon Fwd Build


  • Please log in to reply
442 replies to this topic

#176 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,372 posts
  • Worcester, VT

Posted 04 March 2012 - 03:11 PM

Lookin Great! :slobber:
Wish I had a set of those wheels... :slobber:


Thanks! They do look awesome on there. Glad I got them when I had the chance.

You took it out in the snow!!! :slobber:

The rear bumper looks good on there, the front does need a little, something.

Is the Rack factory? Or is that a retrofit?


Yeah I took it out in the snow :cool: they don't salt the dirt roads here because the salt would just turn them to mud. It was pretty frozen this morning so I didn't see any harm in a mile drive.

I'm thinking up designs already for a new bumper :popcorn:

The rack is factory. At first I really didn't like it (when it was chrome) but now that it's painted I really think it makes the car. Your car has the other style, I think it was called the four seasons rack. Which is what my 82 wagon has. I like that one a bit better, but without one these cars just look too plain.

#177 TheLoyale

TheLoyale

    Safariwagon: The Legend

  • Members
  • 6,755 posts
  • Waukesha, WI

Posted 04 March 2012 - 03:25 PM

You are lucky over there with no salt. WI just pours down the salt, I actually think the waste a lot of it for no reason.

Yeah, I absolutely love that rack, It does look good black. Its better then mine (I'm also missing the crossbars which sucks)

Subarus with no rack suck, the roof pops A LOT. At least in an EA82.

Thanks! They do look awesome on there. Glad I got them when I had the chance.



Yeah I took it out in the snow :cool: they don't salt the dirt roads here because the salt would just turn them to mud. It was pretty frozen this morning so I didn't see any harm in a mile drive.

I'm thinking up designs already for a new bumper :popcorn:

The rack is factory. At first I really didn't like it (when it was chrome) but now that it's painted I really think it makes the car. Your car has the other style, I think it was called the four seasons rack. Which is what my 82 wagon has. I like that one a bit better, but without one these cars just look too plain.



#178 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,372 posts
  • Worcester, VT

Posted 04 March 2012 - 03:32 PM

You are lucky over there with no salt. WI just pours down the salt, I actually think the waste a lot of it for no reason.

Yeah, I absolutely love that rack, It does look good black. Its better then mine (I'm also missing the crossbars which sucks)

Subarus with no rack suck, the roof pops A LOT. At least in an EA82.


We use tons of salt as well, just not on dirt (well a tiny bit) but nothing like the pavement here. My legacy is taking it hard this winter....
I may have some cross bars for that rack from when I parted the turbo wagon. I'll have to look. It probably won't be until next weekend at this point but I'll let you know if I fine anything.

#179 Chips900s

Chips900s

    New User

  • Members
  • Pip
  • 2 posts
  • Vermont

Posted 04 March 2012 - 05:57 PM

Damn you do nice work! Can't wait to see this in person :)

-Chip

#180 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,372 posts
  • Worcester, VT

Posted 04 March 2012 - 06:04 PM

Chip! You joined a Subaru forum? Now that is hard to believe :grin:. Welcome aboard, now we just have to get you in one of these fine automobiles.

And thanks for the compliment.

#181 Chips900s

Chips900s

    New User

  • Members
  • Pip
  • 2 posts
  • Vermont

Posted 04 March 2012 - 06:09 PM

Haha I'll stick with the Saabs and Benzes for now but I do like your WRX I would totally rock one of those someday.....

#182 TheLoyale

TheLoyale

    Safariwagon: The Legend

  • Members
  • 6,755 posts
  • Waukesha, WI

Posted 04 March 2012 - 07:19 PM

Cool, that'd be nice!

Cheers,
-Tom

I may have some cross bars for that rack from when I parted the turbo wagon. I'll have to look. It probably won't be until next weekend at this point but I'll let you know if I fine anything.



#183 Mechanical_misfit

Mechanical_misfit

    Eat, Live, Breath Subaru

  • Members
  • 430 posts
  • Muskegon, MI

Posted 04 March 2012 - 07:57 PM

It's lookin' great Shaun!

I gotta find that same roof rack. Mine is long gone. I can wait though. When I re-paint mine I may just weld up the mounting holes and go without one.

Also, thanks for the info on the BRAT 5 lug swap.

#184 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,372 posts
  • Worcester, VT

Posted 04 March 2012 - 08:22 PM

It's lookin' great Shaun!

I gotta find that same roof rack. Mine is long gone. I can wait though. When I re-paint mine I may just weld up the mounting holes and go without one.

Also, thanks for the info on the BRAT 5 lug swap.


Thanks! I debated welding mine and putting another rack like a basket type, but I'm glad I stuck with the stock one. It fits this car pretty well. And anytime if you need any more info on it let me know!

#185 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,372 posts
  • Worcester, VT

Posted 16 March 2012 - 04:22 PM

Center caps came in! About time. The ones on the left side are a little loose for some reason. I may heat them and bend the tabs out, or just put some black tape around the edges so they sit better. Schools wrapping up (last month!!!) so I haven't had much time to work on this. I have however taken advantage of my snap-on discount $3500 dollars worth of stuff ordered today :headbang:

Posted Image

Posted Image

If you're wondering why it's sitting outside, it's because I picked up a new project...

72 beetle, picking up an engine to rebuild for it tomorrow hopefully!
Posted Image

#186 jonas

jonas

    Subaru Nut

  • Members
  • 1,056 posts
  • Oakridge

Posted 17 March 2012 - 12:50 PM

Do you sleep?

#187 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,372 posts
  • Worcester, VT

Posted 17 March 2012 - 01:01 PM

Do you sleep?


:D
Sometimes.

#188 jonas

jonas

    Subaru Nut

  • Members
  • 1,056 posts
  • Oakridge

Posted 18 March 2012 - 08:19 PM

how did you get the badging off without breaking them?

#189 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,372 posts
  • Worcester, VT

Posted 18 March 2012 - 08:30 PM

Which badging?

#190 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,372 posts
  • Worcester, VT

Posted 19 March 2012 - 09:03 PM

This getting registered tomorrow? Possibly insured and inspected as well?! I think yes! I'm swapping the plates from my other ea81 so it is kind of a sad day at the same time. I need to find a new body for that one. I can't wait to drive this thing.

Edited by 1982gl4, 19 March 2012 - 09:05 PM.


#191 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,372 posts
  • Worcester, VT

Posted 20 March 2012 - 04:05 PM

On the road! Drove it around all day today and it was awesome. Went to DMV this morning 58 dollars later I waked out with my transferred plates! Had some charging issues with it due to a junk wiring repair. I swapped out the alternator before realizing this. All was well as it charged after that and the wiring fix. Gauge on the inside is still off a bit, but it's charging 14.3v so good enough for me. Needs front brakes that's next. I have rotors I need pads they shake like crazy, but that is not going to stop me from driving it back to school tonight :)

#192 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,372 posts
  • Worcester, VT

Posted 21 March 2012 - 09:09 PM

Put on 100 miles so far! She's pretty slow, but I don't mind. I'm in no hurry. I would like to do FI to this I think. I'm going to start looking for a Loyale that's a rusty heap, which may be challenging as there are none of those left up here. But I'm going to keep an eye out.

Some issues with the car thus far:

Brakes, the rears need adjusting, and the fronts need to be replaced, stops fine, just shakes.

Heat, I have none, not sure why coolant level is great, and temp stays right where it should. I'm going to flush the heater core with a hose. I also may look into the ducting to see if it is clogged of I forgot to hook something up.

I had some issues with the charging system due to a P.O's repair using tape and twisting wires together :-\ Fixed that, it's charging fine, but the gauge reads low.

Fuel gauge doesn't work.

Distributor is well.... On its way out. May try to get a use or a new one, or try to fix the one I have.

Needs to be inspected in the next 14 days.

Then I have to finish all the fun things I have been plaining for it :cool:

It's amazing all the people that have asked me about it this far, for some reason they all think it is older than a 1984. Not sure why, maybe because they all rusted away long ago. Man do I love driving this :burnout:

#193 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,372 posts
  • Worcester, VT

Posted 23 March 2012 - 02:14 PM

Going to work tonight to address some of my issues :rolleyes: Oh and I'm getting 25mpg with it right now. I don't think that that's too bad for it's first week out in a few years. I'll be adjusting the timing and doing some other stuff to hopefully improve it :cool:

#194 TheLoyale

TheLoyale

    Safariwagon: The Legend

  • Members
  • 6,755 posts
  • Waukesha, WI

Posted 23 March 2012 - 03:29 PM

Right on!

#195 TomRhere

TomRhere

    Certified BRAT nut!!!

  • Members
  • 4,030 posts
  • Hillsdale, Mi. USA

Posted 23 March 2012 - 07:19 PM

Rear brakes most likely need adjusting. But,,, you'll find the adjusters are froze up.

Rockauto lists them for the EA81's, and the EA82 FWD ones are the same. Atleast going by Son's '88 GL10 FWD Wagon they are.

Good to see you have it on the road.
Here's hoping your Inspection goes well. :drunk:

#196 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,372 posts
  • Worcester, VT

Posted 23 March 2012 - 07:43 PM

I spent some time freeing everything up while it was at work the last time some time with a torch and vice-grips they came out of it. Everything went pretty smoothly tonight. I have new front brakes so the steering wheel is no longer shaking out of my hands :rolleyes: I spent some time painting the hubs up, along with the calipers. The rears I adjusted up, and they are 100% better, but I think there may be some air in the lines as the peddle is a bit low. I'll bleed them tomorrow. I also changed the trans fluid with synthetic 75w90 shifts like butter now. I may go back down tomorrow to change a bulb I noticed that was out tonight, find some muffler to put on along with an ansa tip I picked up. That's all for tonight.

#197 jonas

jonas

    Subaru Nut

  • Members
  • 1,056 posts
  • Oakridge

Posted 23 March 2012 - 08:11 PM

Which badging?

emblems on the fenders

#198 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,372 posts
  • Worcester, VT

Posted 23 March 2012 - 08:28 PM

I waited for a warm day (could use a hair dryer or a heat gun as well) and used a very small screwdriver to work around the edges, once I've done that I get a larger flat head and pry it off starting at the edge by the door, and moving lengthwise toward the front of the car. I've had ones where they are unavoidable to break in those cases I've glued them back together.

#199 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,372 posts
  • Worcester, VT

Posted 24 March 2012 - 09:48 AM

Washed it this morning. Also cleaned the interior up some as well.

Posted Image

#200 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,372 posts
  • Worcester, VT

Posted 24 March 2012 - 03:43 PM

What's this on my windshield :cool:
Posted Image
Inspected!

Today I also pulled the front brakes back part due a noise. Turns out one of the anti rattle clips had folded up and was grinding on the rotor. I took that out, cranked the rears up some more, and now I have some brakes. Peddles like a brick :headbang: Changed out the bulb that was bad, and I adjusted the e-brake. I also pulled the heater fan out and took some junk out of there. I'm still not sure why it doesn't have heat... Has a new subaru thermostat, coolant level is good, and the doors in the dash are working....




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users