Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Ea 81 Timing


  • Please log in to reply
3 replies to this topic

#1 louisianasubaru

louisianasubaru

    New User

  • Members
  • Pip
  • 2 posts
  • south east louisiana

Posted 05 October 2011 - 04:16 PM

I have a EA81 subaru in one of my boats. not sure what year its out of but it has points in the distributer and has push rods no timing belt.(this is what the auto part store always ask me when i go in). i put a weber 32/36 carb on it and made a huge difference. i was woundering if anyone could tell me what is the timing settings for it? it back fires to the exhaust and gets the headers so hot they actually messed up the fiberglass in the boat. it has what i think is where u can time it off the fly weel by a hole in the flywheel. i have a timing light and my dad is a mechanic. we are just trying to get the settings. any help would be greatly apprechiated.

I would like to know if anyone knows the points gap for the distributer. Also my motor does not have the timing tab with marks for me to get 8 degrees. once it gets to operating after about 15 minutes of running it starts to miss. tried adjusting on the fly but it doesnt clear up so im figuring its something with the points? I will aslo add some pictures of the boat to put up on here.

Edited by louisianasubaru, 15 October 2011 - 10:20 PM.
need a few more things


#2 Turbone

Turbone

    The Original Rob

  • Moderator
  • 12,104 posts
  • WA

Posted 05 October 2011 - 04:30 PM

8deg @ 700rpm

#3 Loyale 2.7 Turbo

Loyale 2.7 Turbo

    The Mighty "BumbleBeast"

  • Gold Subscribers
  • 5,507 posts
  • Roatán, Honduras.

Posted 08 October 2011 - 08:27 PM

I'll Like to See your EA81 powered Boat...

Any Pics?

Kind Regards.

#4 louisianasubaru

louisianasubaru

    New User

  • Members
  • Pip
  • 2 posts
  • south east louisiana

Posted 15 October 2011 - 10:27 PM

I will get some pictures. have plenty of the boat but not of the motor sitting in it. will post soon. Its in a mud boat, which is exactly what it sounds like. doest need much water as long as the mud is soft it will go through it. its been in just mud and grass with no problem and is a blast




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users