Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

96 ls problems


  • Please log in to reply
7 replies to this topic

#1 raynmaker

raynmaker

    New User

  • Members
  • Pip
  • 4 posts
  • colorado

Posted 23 December 2011 - 11:03 AM

I was given a 96 legacy ls auto trans because it has some issues. I have read about the AWD and the duty C solenoid but I'm not sure if that is the problem. My questions:
Does the cel come on if the awd doesn't function?
if so what would be wrong if awd doesn't work and no cel?
I have part numbers for clutch and duty c but not the mtp (the other side of the clutch) is this a jy part or dealer only?
And does the ABS have anything to do with AWD? someone pulled the fuse for the abs instead of fixing it :eek:

Also I was told that it loses power/hesitates getting on the highway going uphill. The code reads misfire #4. But it runs great. I have no idea of where to start with this one.

Thanks for any help you can give.

#2 lmdew

lmdew

    _______

  • Members
  • 2,901 posts
  • Colorado Springs

Posted 23 December 2011 - 12:25 PM

If there is a Trans problem, the AT Temp Light will flash 16 times after you start the car.

You can have torque bind without any codes. Drive in tight circles on dry pavement. If it chirps or fights going around the corner, you have torque bind.

TB could be the C-Duty or the clutch pack.

Put the FWD fuse in, do you get the FWD light on the dash?
Does that take care of the TB?

As far as the miss fire, make sure you have Subaru of NGK plug wires and NGK copper core plugs. Both are recommended here at the USMB.

The ABS has codes as well, do a search and you will find the procedure to pull the codes after you have put the fuse in.

#3 raynmaker

raynmaker

    New User

  • Members
  • Pip
  • 4 posts
  • colorado

Posted 23 December 2011 - 07:16 PM

Didn't have TB would just spin fronts (in snow) and not back. No light when starting. Put in FWD fuse and get blink light (16times) but no FWD light. I'm wondering if the rear diff has issues and not tranny.

Put ABS fuse back in and no problems! Go figure!

#4 grossgary

grossgary

    Elite Master of the Subaru

  • Members
  • 19,889 posts
  • WV

Posted 23 December 2011 - 08:35 PM

rear diffs *never* fail on subarus, i wouldn't even waste my time looking there yet - the issue will be trans related.

1. check that the driveshaft is connected to the trans and rear diff. maybe someone pulled the shaft.

2. the clutch drum (is that the MPT thing?) can shear off giving no power to the rear, i've sold them before. get one used or price it out from Subaru and see if it's worth it?

3. in general the codes aren't that necessary or helpful with 4WD component issues, it's usually diagnosed easily enough via symptoms.

4. cylinder misfire is usually simply tune up stuff - OEM NGK spark plugs and Subaru ignition wires are best. other stuff can cause it but those are the most common causes and considered maintenance items anyway.

as to the ABS - sometimes the ABS is fine except in inclement weather, so be wary. the only real issue will probably be if you have poor tires, aged, low tread, bad in snow tires, etc.

some early ABS around your year - actually i think it was 1996 had an ABS issue where the fuse or relay associated with the hydraulic pump up in the front passengers side of the engine by in front of the air filter - would freak out and continuously run after the car was shut off. pulling the fuse is a work around for that issue....you could probably google or serach it here but i think it was 96?

bad tires freak the ABS system out, i can't over state that, it is a scary proposition when you see it for the first time. i swore the ABS system was terrible (and many others do as well when they see this) when i had a 1997 Impreza that could not stop down steep snow covered grades - it was impossible to stop, the brakes would continually pulse without ever bringing the car to a stop - but i could stop with the emergency brake. the tires had plenty of tread on them but i guess they were just aged or weathered and while i could stop with the ebrake it was flipping out the ABS - getting new tires completely solved the issue.

so just be ware it might not be immediate but something could still show up if you haven't hit snows yet.

#5 raynmaker

raynmaker

    New User

  • Members
  • Pip
  • 4 posts
  • colorado

Posted 23 December 2011 - 11:51 PM

yeah the clutch drum. What is the part number?

Thanks

#6 grossgary

grossgary

    Elite Master of the Subaru

  • Members
  • 19,889 posts
  • WV

Posted 24 December 2011 - 12:17 AM

striking out on part number, can't find that thing anywhere. call the dealer i guess (great timing to try and do that huh?)

most folks seem to just get a used one. i've sold them before, might even have one more, not sure and won't be home for awhile.

they take forever to wiggle out, just keep gradually trying. the turtle wins the race pulling them out.

#7 raynmaker

raynmaker

    New User

  • Members
  • Pip
  • 4 posts
  • colorado

Posted 24 December 2011 - 10:14 AM

Thanks for the help. I know I have to tear into the tranny but I'm not looking forward to it.



And I just have to put this here cause its funny :horse: lol

#8 grossgary

grossgary

    Elite Master of the Subaru

  • Members
  • 19,889 posts
  • WV

Posted 24 December 2011 - 10:47 AM

Thanks for the help. I know I have to tear into the tranny but I'm not looking forward to it.



And I just have to put this here cause its funny :horse: lol


good work, you're getting really good at using the forum, most excellent!

someone had a welded hub/transfer clutch set up for sale that never sold on the add here - so if you wanted a full time locked set up or run RWD you could get that - LOL.

might want to just put an add in the parts wanted forum for a used one? actually i am looking at buying a legacy with a blown transmission - they don't say what it is but my guess is front differential or something ominous like that, in which case that rear MPT part would be fine. won't know until next week though as i'm out of town.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users