Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Engine ping while at highway speeds


  • Please log in to reply
4 replies to this topic

#1 heep70

heep70

    Subaru Fanatic!

  • Members
  • 496 posts
  • Bonney Lake

Posted 19 March 2004 - 08:36 PM

My EA82 non-turbo pings on acceleration and while at cruising speeds. I have timed it back to 6 degrees. Added octane boost. Unplugged EGR. If I give it gas while it pings (cruising) it will go away.

Its almost like it is getting to much vacuum.

#2 GLCraig

GLCraig

    Livin' the live

  • Members
  • 2,706 posts
  • LV, Washington

Posted 19 March 2004 - 08:57 PM

When you say Unplugged the EGR i'm assuming that you mean you cleaned out the EGR valve. Did you also clean out the tube as well? Also check to see if your EGR solenoid is working.

#3 rallyruss

rallyruss

    Subaru Master

  • Members
  • 1,653 posts
  • San Jose CA

Posted 19 March 2004 - 09:47 PM

yeah I am confused about the EGR too. EGR should reduce cyl. temp and therefore pinging too.

try 5deg. my 85 gl would not take any more than 5 deg of advance.

seafoam carbon cleaner may be helpfull too.

#4 speedbump

speedbump

    USMB is life!

  • Members
  • 179 posts
  • North Vancouver,Canada

Posted 19 March 2004 - 09:55 PM

try pulling back to STOCK timing (?? BTDC) remember to unplug the vacuum advance!

#5 GeneralDisorder

GeneralDisorder

    Elite Master of the Subaru

  • Members
  • 20,281 posts
  • Portland

Posted 19 March 2004 - 10:03 PM

Exhaust leaks can sound like pinging.... just thought I would toss that out there. Doesn't sound like that's your problem tho, since it goes away if you lay into the gas. Generally and exhaust leak will get louder when you do that.

GD




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users