Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

95 2.2: Cleaned MAF Sensor, now getting knock sensor code


  • Please log in to reply
5 replies to this topic

#1 95LEGOBW

95LEGOBW

    USMB Regular

  • Members
  • PipPipPip
  • 116 posts
  • hither, yon

Posted 24 April 2012 - 06:29 PM

I cleaned the MAF sensor on my 95 LEGOBW with CRC MAF spray. The sensor looked fine before and after the cleaning. The car wasn't running poorly, but I had the spray, and it was easy to do. At the same time, I pulled off the PCV valve and cleaned it out. It appeared to be fine, clicking back and forth like it's supposed to. Lastly, I sprayed some of the CRC MAF sensor cleaner in the throttle body, while I had the air inlet pipe off. Buttoned it all back up and it ran fine.

Next day, get a Check Engine Light (CEL) for a P0325 code, for the Knock Sensor. I had the code cleared, but it came back in about 20 miles of highway driving. The car runs fine, just slow, as usual.

So, what should I check? I wasn't getting the P0325 code before I did the cleaning, so I don't think the Knock Sensor is bad.

Thanks, y'all.

#2 98obster

98obster

    USMB is life!

  • Members
  • 248 posts
  • Greeley

Posted 24 April 2012 - 08:32 PM

i would clear the code and if it comes back you probably need a new knock sensor. they do go bad (~100k). not sure why you have a OBDII on a '95 but that's my diagnosis.

#3 WoodsWagon

WoodsWagon

    Formerly 91Loyale

  • Members
  • 3,945 posts
  • NH

Posted 24 April 2012 - 08:36 PM

The knock sensor and MAF are completely unrelated, so I think the knock sensor code happening after your cleaning was probably chance. The knock sensors do fail, many of them have cracks in the plastic they're cast in. It's relatively cheap and pretty easy to replace and it's one of the main sensors the computer uses to optimize power and efficiency.

Check the connectors under the throttle body that are attached to a bracket coming up off the bellhousing to make sure you didn't disconnect or yank on the wires when you cleaned the throttle body.

All 95 legacys are OBDII. It wasn't legally required until 96, but a few manufacturers switched over early.

Edited by WoodsWagon, 24 April 2012 - 08:39 PM.


#4 Fairtax4me

Fairtax4me

    Su bah roo'n

  • Gold Subscribers
  • 8,438 posts
  • Charlottesburg, VA

Posted 24 April 2012 - 10:49 PM

Knock sensor is bad. All too common on these. Just a coincidence that it happened after you cleaned the MAF.
Here's some help on replacement:
http://www.ultimates...ad.php?t=120610

#5 Recian

Recian

    USMB is life!

  • Members
  • 194 posts
  • New Bern

Posted 25 April 2012 - 06:38 AM

Yep happened to my 95 too. It was melted when i bought the car at 130k. Seems common. I put a oem one in at $95. Theyre pretty easy to change or mine was and i have 0 knock now even under heavy loads. My car has obd2 also. Its mandatory for all 96 and newer vehicles but some companies put them in as early as 93 to test them and make sure they functioned properly by the mandated date in 96.

#6 Rooster2

Rooster2

    Subaru Master

  • Members
  • 3,517 posts
  • Indianapolis

Posted 25 April 2012 - 02:09 PM

Yea, I very recently replace the knock sensor on my '95, 2.2 motor. They do go bad. It is not the easiest to get at, but with perseverance you will be able to swap it out. A bad knock sensor causes reduced gas millage, and engine power.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users