Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Was looking at my fuel sender


  • Please log in to reply
2 replies to this topic

#1 1-3-2-4

1-3-2-4

    Subaru Mike!

  • Members
  • 3,717 posts
  • Greenwich

Posted 16 May 2012 - 02:40 PM

and I was only able to get the passenger side out I used a eraser to clean it, however the driver's side I could get all but one out because the studs got so rusty (ended up snapping one) So I guess it's a nut extractor for me I guess.

Funny thing was unplugging the connection to the fuel pump did not cause my gas gauge to go to empty, regardless it's stuck between empty and 1/4

and I'm going to guess those studs on the tank are not replaceable.

#2 1 Lucky Texan

1 Lucky Texan

    I read a lot about Subarus

  • Members
  • 4,713 posts
  • Texas

Posted 16 May 2012 - 02:50 PM

maybe there's some kinda RTV or hondabond that could work there?

#3 1-3-2-4

1-3-2-4

    Subaru Mike!

  • Members
  • 3,717 posts
  • Greenwich

Posted 16 May 2012 - 02:51 PM

well it's between two good nuts so I don't think I should have a problem or anything... it took a lot to break the seal anyways.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users