Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

"New" utility Brat


  • Please log in to reply
25 replies to this topic

#1 wallaby

wallaby

    USMB Regular

  • Bronze Subscribers
  • 146 posts
  • clarkston,wa

Posted 05 July 2012 - 11:22 AM

my wife pointed this one out in a tow yard.....i think she is encouraging the habit......

so we got it for $100 - will become her farm vehicle,
we use subys instead of expensive ATV's and UTV
was missing some parts and is rusty as hell, but will work great for us
had another car paked on the tailgate when we picked it up

repairs done -
- rebuild carb - removed everything i could from the hitachi, now has manual choke, mechanical secondary, and no extra vacumn/pollution stuff
- replace missing starter motor, battery cables, wipers
- replaced wheels and tyres
- fixed rust in cab floor and painted
- beat out tailgate and replaced latches
- exhaust -was in the bed
- paint - she picked the colour, foam roller, safety yellow - my 4th roller paint job and i think i am getting pretty good at it....:)

runs pretty good now, needs axles and a dual range - probably after the summer when i have some more time

still to do
valve cover gaskets - leaks onto exhaust
reinstall interior
build rear bumper
front bumper/bullbar/bash plate

before

Posted Image

now

Posted Image

Posted Image


more to come soon

Edited by wallaby, 05 July 2012 - 12:14 PM.
spelling....


#2 wallaby

wallaby

    USMB Regular

  • Bronze Subscribers
  • 146 posts
  • clarkston,wa

Posted 05 July 2012 - 11:27 AM

yesterday i had my first attempt at installing a windshield....
getting the rubber seal out of the parts car did not go so well, ended up taking the windshield out with my boot:D

this brat came with a windshield but no seal

i got it reinstalled....not a real pro job but i don't think it will fall out
got black urethane EVERYWHERE.....
and will have to repaint some places..
i don't think i would attempt this on a road car, just for future reference:

#3 l75eya

l75eya

    Subaru Nut

  • Members
  • 1,421 posts
  • Hoboken, NJ

Posted 05 July 2012 - 09:45 PM

haha! That paint came out great! Jeszek would approve of the color ;)

And I don't know why, but every time I see those rims, I want a set, really bad.
What are they? They're after-market right?
I think I've seen a set of those on maybe four or five members' cars on here..

#4 TheLoyale

TheLoyale

    Safariwagon: The Legend

  • Members
  • 6,641 posts
  • Waukesha, WI

Posted 05 July 2012 - 11:08 PM

They are the Cal-Masters :) They aren't to hard to find on the West-coast.

nice Brat btw! Is that a Hilux in the background?

#5 Loyale 2.7 Turbo

Loyale 2.7 Turbo

    The Mighty "BumbleBeast"

  • Gold Subscribers
  • 5,529 posts
  • Roatán, Honduras.

Posted 05 July 2012 - 11:38 PM

Very Nice Subie, I Like the Idea of Using Subarus instead ATV's. :)

haha! That paint came out great! Jeszek would approve of the color ;) ...


Yes, it is really JesZeK's Approved! Posted Image

Kind Regards.

#6 turbosubarubrat

turbosubarubrat

    Subaru Nut

  • Members
  • 1,017 posts
  • Sandy, OR

Posted 06 July 2012 - 12:15 AM

looks great nice paint job especially for a home job:headbang:, 82 brat right? got to love these brats have 4 1/2 at home:cool:

#7 l75eya

l75eya

    Subaru Nut

  • Members
  • 1,421 posts
  • Hoboken, NJ

Posted 06 July 2012 - 01:38 AM

4 1/2


:lol:

#8 turbosubarubrat

turbosubarubrat

    Subaru Nut

  • Members
  • 1,017 posts
  • Sandy, OR

Posted 06 July 2012 - 02:32 PM

yah i have 4 1/2 i have 2 78's, 79, 85, and a 1/2 of a 86:Di tore it apart and have everything off it that was still good and when i mean everything i mean everything i have the wheel wells:grin:but i didnt get all the parts i needed for mine because the 86 got hit a 60mph:-\

#9 wallaby

wallaby

    USMB Regular

  • Bronze Subscribers
  • 146 posts
  • clarkston,wa

Posted 06 July 2012 - 04:18 PM

i have 3 brats - 2 UTVs, this one and a brown one that will be getting a safety orange paintjob at some point, then my DD blue one (that has a bad engine at the moment
then a couple wagons as well,.......

Posted Image

subys work really well around our farm - my wifes family have a small direct market and upick fruit and vegetable operation.

Yes thats a hilux or toyota pickup 76 shortbox (never seen another) belongs to my Brother in law and i am looking after it while he works for the gov, was my daily driver for a while but it has a LOT of issues, but starts and runs every time - has been in the family since new, transfered and gifted so many times between family members it crazy.

more on the yella peril this weekend

#10 turbosubarubrat

turbosubarubrat

    Subaru Nut

  • Members
  • 1,017 posts
  • Sandy, OR

Posted 06 July 2012 - 04:34 PM

where do u find all of these hard tops:slobber:i like the t-tops but still those hard tops are rare and hard to find:cool:

#11 BratRod

BratRod

    USMB is life!

  • Members
  • 491 posts
  • Dallas, Texas

Posted 06 July 2012 - 08:33 PM

6lug conversion? Nice :brow:

#12 TheLoyale

TheLoyale

    Safariwagon: The Legend

  • Members
  • 6,641 posts
  • Waukesha, WI

Posted 06 July 2012 - 09:11 PM

Its probably a redrill. I have a write up about it in the USRM.

http://www.ultimates...ad.php?t=132536

And yes, the Hardtops are awesome! I like them more then the Fun-top versions. :popcorn:

#13 Mugs

Mugs

    Subaru Fanatic!

  • Members
  • 544 posts
  • Spokane & Hobart, Wa.

Posted 07 July 2012 - 03:27 AM

Lookin good mate'

Definitely going to see that one going down the road.

So when are you gonna EJ one of those bad boys. :burnout:

#14 BratRod

BratRod

    USMB is life!

  • Members
  • 491 posts
  • Dallas, Texas

Posted 07 July 2012 - 01:16 PM

Its probably a redrill. I have a write up about it in the USRM.

http://www.ultimates...ad.php?t=132536

And yes, the Hardtops are awesome! I like them more then the Fun-top versions. :popcorn:


Oh yeah, i knew that :lol:

#15 wallaby

wallaby

    USMB Regular

  • Bronze Subscribers
  • 146 posts
  • clarkston,wa

Posted 09 July 2012 - 03:45 PM

yeah blue one is a redrilled on Mazda alloys
i can't seem to find ttop units to buy......i would like one, but it hasn't happened.....yet

Mugs - this one won't be on the road any time soon, the amount of rust underneath is almost to midwest standards- fixable but i don't need to at this time this one is for on-farm only.
Engine is toasted in the blue one...now might just be the time for EJ......??????......:burnout:

back on topic.......
got the interior back in this weekend, still have to finish fitting the seats, had GL seats that were badly fitted, will punch some plates after work today.

bed trim back on and started on the tailgate latches - bought some pin type latches and will just mount them on the outside, originals were too beat up to work right.
drove it around a bit, need to bleed the brakes.....

1 question for the gurus,- have an electric fuel pump hooked up to the key, if i leave the key on (pump running) for a few minutes the fuel leaks past the needle valve and runs into the intake, filling up whichever cylinder has the intake valve open? new needle valve, used fuel pump,
do i need a pressure regulator?
i have done this before and not had the issue

#16 SubieTrav

SubieTrav

    USMB Regular

  • Members
  • 136 posts
  • Denver

Posted 09 July 2012 - 11:14 PM

Good job on the Brat, the rolled on paint job came out great I just finished doing a roller paint job on my 92 Legacy wagon in International Red.

#17 VaporTrail

VaporTrail

    Brattitude Adjustment

  • Administrator
  • 11,149 posts
  • Central Iowa

Posted 11 July 2012 - 09:34 AM

is the float not working. what kind of PSI are you running for the external pump?

#18 wallaby

wallaby

    USMB Regular

  • Bronze Subscribers
  • 146 posts
  • clarkston,wa

Posted 11 July 2012 - 12:31 PM

is the float not working. what kind of PSI are you running for the external pump?


no idea what the pressure is but i can check it....what pressure do i need?

its just a standard square type NAPA or something fuel pump - had a collection of them lying around - gradually using them on subarus......:-p

the next part of this is last night it wouldn't stay runnnig - so maybe that pump is no good either, may actually have to buy a new one

#19 VaporTrail

VaporTrail

    Brattitude Adjustment

  • Administrator
  • 11,149 posts
  • Central Iowa

Posted 11 July 2012 - 12:56 PM

I think the hitachi only requires like 2psi or something like that.... regulator might not hurt ...

#20 TheLoyale

TheLoyale

    Safariwagon: The Legend

  • Members
  • 6,641 posts
  • Waukesha, WI

Posted 11 July 2012 - 02:01 PM

Yeah, The carb system has a max pressure of 3psi. It goes down to 1psi at idle so much book says.

#21 wallaby

wallaby

    USMB Regular

  • Bronze Subscribers
  • 146 posts
  • clarkston,wa

Posted 11 July 2012 - 05:01 PM

thanks, will check it out tonight.

#22 wallaby

wallaby

    USMB Regular

  • Bronze Subscribers
  • 146 posts
  • clarkston,wa

Posted 26 July 2012 - 03:09 PM

still having fuel issues with this car.....
i think i have several problems
fuel is not coming out of the tank, -is there a screen? how do you clean it?
so i have it hooked up to a jerry can in the back for now.
the hitachi carb i have on it worked OK before then i removed everything that i thought was extra from it - electric choke, vac secondary, a ton of vacumn lines...
will run now but if i let the fuel pump run without the engine running it will just flood into the throttle body - maybe i removed something important....???


i am at the point where i am going to put an old carter/weber single barrel on it that i am pretty sure works.

#23 VaporTrail

VaporTrail

    Brattitude Adjustment

  • Administrator
  • 11,149 posts
  • Central Iowa

Posted 27 July 2012 - 08:12 AM

is your fuel return line plugged?

you can blow compressed air backwards through the line to clean the screen if there's one there...

hows the fuel filter under the bed?

#24 wallaby

wallaby

    USMB Regular

  • Bronze Subscribers
  • 146 posts
  • clarkston,wa

Posted 27 July 2012 - 12:09 PM

is your fuel return line plugged?

you can blow compressed air backwards through the line to clean the screen if there's one there...

hows the fuel filter under the bed?


i don't have a return line.....maybe that's the problem, the fitting on the carb broke so i just replaced it with a straight hose tail, no return outlet.

have changed the filter underneath,
i guess, blow air into the tank, then drain it out the bottom....i figured blowing it out would just put all the gunk back into the tank.

thanks Mcbrat i will replace the return line....

#25 wallaby

wallaby

    USMB Regular

  • Bronze Subscribers
  • 146 posts
  • clarkston,wa

Posted 03 August 2012 - 01:27 PM

found some new info....
seems i removed something i needed from this carb, swapped on an old single barrel that i know worked and it started right up and ran fine.
although now it seems i have a leak in the tank....:( , just on the fill tube i think.
will look at it this weekend, also am pulling the engine from the blue brat to get it back on the road....:burnout:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users