Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Fill Vent Repair - P0440 Code


  • Please log in to reply
11 replies to this topic

#1 Injulen

Injulen

    New User

  • Members
  • PipPip
  • 20 posts
  • Augusta, Maine

Posted 05 July 2012 - 08:19 PM

Hey all. Did some service today and figured I would snap some photos and do a quick write up.

I had a CEL code P0440, that one has something to do with the EVAP system leaking. After weeks of searching for the cause and scratching my head, today I finally found it. Where the fill vent goes through the frame rail near the passenger side rear tire, the metal pipe simply rusted away. I had already checked my fill pipe a few times since that is one of the most common causes of the P0440 code but this little piece escaped my eye for quite awhile!! One of the worst things was that I couldn't put more than 1/2 a tank of gas in the vehicle without getting a horrendous headache inducing gasoline fume smell.

Once I found where the fumes were leaking out, I despaired a little. It was a kind of a pain in the butt spot and I couldn't find that part for sale anywhere without buying the whole filler neck assembly for $100+.
Enter my step-dad: he recently repaired his truck's filler neck with some 1 1/4" copper pipe. He showed me his repair work and we decided to give the same concept a go on the Subaru. Scrounged up some 5/8 OD copper tubing, cut & bent a piece, voila!!

No more fume smell, no more CEL!!!!!! Oh, and it cost me $0. Free labor and a piece of scrap copper.

Imgur Album:
http://imgur.com/a/k05np

Posted Image
Car is jacked up and ready to go.

Posted Image
The smaller diameter pipe on the right is the one that rotted through. These "Before" images are actually from a '95 Legacy, I forgot to take photos before doing the work to my '97 Legacy.

Posted Image
Close up of where the vent pipe goes through the frame. The plastic grommet extends through the frame and trapped a lot of dirt and moisture, causing the pipe to rust right through.

Posted Image
This is the other side of the frame rail where the vent pipe ends and connects to the rubber vent hose that goes to the gas tank. The hardest part of this service was getting up in there to unhook that clamp. On my '97 Legacy there are three hoses that aren't on this '95 which go to the charcoal canister. (The '95 has the canister under the hood instead of behind the rear passenger wheel)

Posted Image
You can see that the pipe is quite corroded and swollen from the rust. I was able to grab on and wiggle it quite a bit. The part of the pipe that is visible on the outside of the frame rail wasn't moving whatsoever so I knew there was a break inside the frame.

Posted Image
After pulling out the filler neck and vent assembly, here is the rusted out vent pipe and the grommet it runs through.

Posted Image
You can clearly see that the worst of the rust happened right inside the protective grommet.

Posted Image
Pic without the grommet. Nasty.

Posted Image
Here you can see my tungsten carbide ring is nice and shiny despite the road grime xD

Posted Image
5/8" OD copper tubing. Bent it to shape and size, wrapped some electrical tape to bump up the OD for a snug fit, went together smoothly. I accidentally broke the bolt that holds the vent pipe bracket and filler neck to the chassis but oh well. Zip ties are in my future! Will probably also stuff some cloth or rubber around the copper pipe so it doesn't rub too much against the frame. In this pic you can actually see the three black rubber hoses that come to and from the charcoal canister. They are visible in the bottom left of the photo.


One last note, this was made much easier by removing the filler neck tube. It wasn't completely necessary but it opened up a lot of maneuvering space for my hands.

Attached Files

  • Attached File  1.JPG   46.34K   1 downloads
  • Attached File  2.JPG   38.67K   2 downloads
  • Attached File  3.JPG   33.41K   2 downloads
  • Attached File  4.JPG   37.74K   3 downloads
  • Attached File  5.JPG   44.48K   4 downloads

Edited by Injulen, 06 July 2012 - 07:00 PM.
Added more photos


#2 edrach

edrach

    RIP 6/28/14

  • Members
  • 12,326 posts
  • Bothell, WA

Posted 05 July 2012 - 08:54 PM

Nicely done and written up. This should really be reposted in the USMB repair manual. Perhaps a moderator can move it or copy it there.

#3 Injulen

Injulen

    New User

  • Members
  • PipPip
  • 20 posts
  • Augusta, Maine

Posted 05 July 2012 - 09:16 PM

Ah yes thanks for pointing that out. I will post it in there and moderators, please feel free to delete this one.

Edit: Just went to the USMB repair manual section and couldn't quite figure out where this belongs. Engine?

Double Edit: Nevermind, there is a section for submissions.

Edited by Injulen, 05 July 2012 - 09:21 PM.
More info


#4 jarl

jarl

    Subaru Fanatic!

  • Members
  • 548 posts
  • Ann Arbor area

Posted 05 July 2012 - 09:58 PM

Which year is your car? That filler tube doesn't look like the ones I have seen...

#5 987687

987687

    Rally Suby!

  • Members
  • 3,603 posts
  • Northern Maine

Posted 06 July 2012 - 07:02 AM

Since the canister isn't in the back, it's probably a 96. I suppose it could also be a 97 or 95..

#6 Injulen

Injulen

    New User

  • Members
  • PipPip
  • 20 posts
  • Augusta, Maine

Posted 06 July 2012 - 10:18 AM

The car that I did the work on is a '97 with a '96 EJ22 in it. The canister IS in the back on that one, large square box behind the passenger side rear wheel. I had to maneuver around the purge and vent lines to do the work.

The "Before" pics of the vent pipe are actually from my '95 Subaru which has the canister in the engine compartment. I forgot to take before pictures of the '97 so I substituted the images from my '95.

#7 grossgary

grossgary

    Elite Master of the Subaru

  • Members
  • 20,084 posts
  • WV

Posted 06 July 2012 - 12:19 PM

Could a picture be put in this thread? It seems over time that many pictures links are lost and become dead links.

#8 Injulen

Injulen

    New User

  • Members
  • PipPip
  • 20 posts
  • Augusta, Maine

Posted 06 July 2012 - 12:50 PM

Sure, but doesn't the "Insert Image" button just embed the offsite image that is linked? If there is a way to upload the image directly to the forum I would definitely do that.

#9 grossgary

grossgary

    Elite Master of the Subaru

  • Members
  • 20,084 posts
  • WV

Posted 06 July 2012 - 01:32 PM

Sure, but doesn't the "Insert Image" button just embed the offsite image that is linked? If there is a way to upload the image directly to the forum I would definitely do that.

yes you can, but maybe you can't if you don't have enough posts yet?

i think people actually prefer hosting elsewhere but i see so many broken links/missing images it just doesn't seem like a good long term fit.

#10 Injulen

Injulen

    New User

  • Members
  • PipPip
  • 20 posts
  • Augusta, Maine

Posted 06 July 2012 - 06:48 PM

It must be 10 posts because this is my 11th and I can now add attachments.

#11 pearlm30

pearlm30

    Eat, Live, Breath Subaru

  • Members
  • 342 posts
  • Tampa, FL/ Bethlehem, PA

Posted 07 July 2012 - 12:45 PM

Thanks for the write up!:headbang: I have the same code for MY 98 forester. I replaced the filler pipe but that didnt fix the code. I will take a look at the vent pipe as you suggested.

#12 Injulen

Injulen

    New User

  • Members
  • PipPip
  • 20 posts
  • Augusta, Maine

Posted 07 July 2012 - 02:38 PM

If you don't find the vent leaking, check the solenoids. From another thread:

Ok, underneath the steering drivers side dash, there are two green connectors. Connect them, and turn the IGN to On. You will hear every solenoid, relay in the car turning on and off.

Check the following solenoids by feeling them with your finger. If you can feel a click, they (and the wiring to them) are most likely good.
Purge control solenoid (under intake manifold, passenger side)
Vent solenoid (right by the charcoal canister)
Pressure control solenoid (front passenger corner of fuel tank)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users