Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo

Had to re-sign up.


  • Please log in to reply
No replies to this topic

#1 tincan

tincan

    USMB Regular

  • Members
  • PipPipPip
  • 67 posts
  • Carmel, NY

Posted 20 July 2012 - 11:03 PM

Posted a few months back looking for some ideas on how to deal with a broken automatic in my Legacy. I wound up deleting my email address and forgot the pw. Whoops

In any case, transmission is fixed. Got a warrantied unit, too.

My two cars are a 93 Loyale FWD Sedan, and a 92 Legacy in the same FWD flavor, but automatic.

Just got done with struts, timing belts, fuel filter, and retro fitted the A/C system on the Loyale. One fill and it sprung back to life. No more driving to class or the shop in the near 100 degree temps, kudos to grossgary for his tutorial on the o rings, and otherwise giving me the idea to at least see if it worked still. Saved my rear and wallet!

In auto mech 1 and moving onto body and general welding after that. Hoping to get into ASE courses.

Ordered owner badges for each of them, too. Six weeks.

The theme for my Loyale is going to be "Eco-turbo". I love the 43mpg, but, the engine in the car has no power for hills, which is where the car suffers most and i wind up slowing down and having to downshift.

I'm thinking a Suzuki G10T for the turbo parts. Small turbine, about 5psi of boost, and a small intercooler to match...

How about you guys? Toss me some small turbines and other parts, and let me know your ideas.

Thanks, and its good to be back.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users