Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

fuse under the hood on my RX?


  • Please log in to reply
2 replies to this topic

#1 Meeky Moose

Meeky Moose

    Subaru Master

  • Members
  • 2,343 posts
  • Grants Pass

Posted 30 March 2004 - 04:20 PM

well this fuse is next to a little white canister with vacuum lines running to it (the canister) its a single 15 amp fuse.. i know it is NOT the FWD fuse.. my rx does not have one of those..

anyways, i have no clue what its for but everytime i replace it and check it a day later its blown out again.. no adverse affects, everything seems to work as it should..

anyone know what its for?

#2 Marck

Marck

    Certified Subaru Nut

  • Members
  • 776 posts
  • Nipomo

Posted 30 March 2004 - 10:11 PM

It is for the A/C.

#3 Meeky Moose

Meeky Moose

    Subaru Master

  • Members
  • 2,343 posts
  • Grants Pass

Posted 31 March 2004 - 07:20 AM

lol ok, maybe thats why my AC hasn't been working.. time to track down the short..


thanks




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users