Jump to content

Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse

- - - - -

I know i know, not another no spark thread :(

  • Please log in to reply
7 replies to this topic

#1 subaruguru



  • Members
  • 1,642 posts
  • Yakima Wa,

Posted 28 September 2012 - 10:17 PM

ok my issue is no spark or fuel i went exactly as the 2.2 swap from chux but no spark or fuel. The grey plug in diode is burned up so how can i fix it aside from finding another?

I searched and searched tried new solutions that others have found but no spark or fuel. I keep getting feed back to the car harness also.

Any help would be awesome the car ran fine before i parked it and two days later (sat with no battery) and now nothing.

Thanks guys.


#2 GeneralDisorder


    Elite Master of the Subaru

  • Members
  • 22,064 posts
  • Portland

Posted 29 September 2012 - 12:40 PM

Battery hooked up backwards?


#3 subaruguru



  • Members
  • 1,642 posts
  • Yakima Wa,

Posted 29 September 2012 - 01:40 PM

Nope lol, I checked both my ecu's both good checked all my sensors both relays and the ignitor. The only thing i can think it would be is that diode. It is the plug in style with the grey cap looking thing. Not the little brown flat style.

I tested all my parts by putting them in my legacy and they all checked out. I have done a few harnesses and i do not claim to be a wiring wizard, i think there is just something small i am over looking.

My ignition relay clicks on but nothing else when the relay clicks on though the IAC clicks at the same time. i have the cover off the relay and can see it function.

when i put the power to the back up power wire (b48-15) the relay wont release when the key is turned off. like it powers back through.

idk. just at a loss here i have had a lot of trouble with this harness maybe i snipped where i should not have, mistakes do happen.

Cheers R.

#4 Prwa101


    Subaru Fanatic!

  • Members
  • 832 posts
  • Sandy, OR

Posted 29 September 2012 - 03:57 PM


Read up, Sounds like the same problem I had... You fried the Ecu and doide like me, got the Battery cables back words, even for a second will fry it... Check you posts. I was stumped for a couple months and almost gave up... Do you have power in the car when it's hooked up? And weird sparkage when hooking the battery up?

Edited by Prwa101, 29 September 2012 - 04:00 PM.

#5 subaruguru



  • Members
  • 1,642 posts
  • Yakima Wa,

Posted 30 September 2012 - 12:12 AM

I have read everything there is on the EJ swap that i can find including your threads. Both ECUs i have are known good i put them both in my legacy and ran it along with all my other sensors one at a time and all together to double check.

I hate asking for help if you cant tell :cool:. But i am stumped i have done at least 5 harnesses and they have worked with little to no issue like a wrongly hooked hot so the car would start but not shut off easily fixed but i'm really stumped on it.

Everything is hooked up per the Chux EJ diagram. Everyting that is supposed to be grounded is, the powers (switched and not) all have it where they are required. I am going to the junk yard to snag another harness (I HOPE) and cut it down lightly just to get my car going. I

I lost the front tire on my motorcycle going south on evergreen way tonight coming from work the GF has the legacy on the east side of the state and i am now car-less.

I do thank you for the help though :) it is what it is.

Cheers Or not


#6 Fairtax4me



  • Members
  • 13,034 posts
  • Charlottesburg, VA

Posted 30 September 2012 - 01:11 AM

Assume you tested the diode with a multimeter? Diodes are usually labeled similarly to resistors, with several colored bands. I guess the one in the harness is probably covered up. If you can pry the covers off you may be able to match it up with a new one for RadioShack. Probably just easy to get one from a junkyard though.

#7 subaruguru



  • Members
  • 1,642 posts
  • Yakima Wa,

Posted 30 September 2012 - 02:40 AM

thats the plan tomorrow if i dont have time to get a full harness i hope i can get a harness.

#8 subaruguru



  • Members
  • 1,642 posts
  • Yakima Wa,

Posted 01 October 2012 - 12:55 AM

got another harness and had the same issue cut by another person though. Still no spark or fuel.

I tested for hot at the FP relay nothing then i tried a jumper from the small yellow wire to the big yellow wire and i got life the FP cycled and i turned it over sure enough it fired right up.

Its always something simple....

Cheers R.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users