Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Starter Issue?


  • Please log in to reply
29 replies to this topic

#26 jj421

jj421

    USMB is life!

  • Members
  • 587 posts
  • Carnation, WA

Posted 08 October 2012 - 07:13 PM

My battery is not leaking. It's only about six months old or so, and the terminals were like that when I bought the car. The previous owner had left the car sitting unattended for a few months before selling, and that caused the previous battery to go bad. I will try cleaning it though. I'm glad the solution was so simple. Thanks again for everything you guys.

#27 djellum

djellum

    Eat, Live, Breath Subaru

  • Members
  • 640 posts
  • Vancouver WA

Posted 08 October 2012 - 09:19 PM

the fuzz is from fumes. it will leak fumes and you won't be able to tell its leaking except that corrosion and on the under of the hood maybe. if any of the crust is new or it has more than just the crud that was there when you got it, your battery could be leaking fumes.

Not saying it is, but keep an eye on it. just being new doesnt mean it wont do it.

not the end of the world, but be careful with sparks around the leaky ones. thats the reason your not supposed to hook the jumper cable ground to the battery.

#28 jj421

jj421

    USMB is life!

  • Members
  • 587 posts
  • Carnation, WA

Posted 08 October 2012 - 09:39 PM

No, the corrosion on my battery is not new. It hasn't become any more corroded since I bought the car. The stuff that's on there is old stuff that's been on there for a while. But I understand what you're saying. Considering I open the hood probably a minimum of twice a week, it won't be hard to keep an eye on it, haha. That's why I wasn't thinking this problem was caused by my battery or wire, because the terminal hasn't become any more corroded over time.

#29 GeneralDisorder

GeneralDisorder

    Elite Master of the Subaru

  • Members
  • 20,281 posts
  • Portland

Posted 09 October 2012 - 12:44 PM

I probably should say I told you so.

Nothing personal - just who I am.

GD

#30 jj421

jj421

    USMB is life!

  • Members
  • 587 posts
  • Carnation, WA

Posted 09 October 2012 - 01:16 PM

I probably should say I told you so.

Nothing personal - just who I am.

GD


Hahaha, well, you did tell me so. I just didn't believe it. I never take things personally; don't worry about it. :)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users