Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
* * * * * 1 votes

'86 Subaru GL Turbo


  • Please log in to reply
78 replies to this topic

#1 TOsborn

TOsborn

    USMB Regular

  • Members
  • 142 posts
  • Everett

Posted 15 October 2012 - 02:09 PM

Since winter is rapidly approaching in the PNW, my truck ('65 Ford F-100) wasn't going to cut it as a daily commuter, neither was QS (ongoing turbo GL hatch project).

I originally wanted another GL hatch that I could drive, then eventually use as a parts car. After driving everywhere between Portland and Seattle, multiple times, looking at rusted out GL's, I settled on this. It's not the same body style, but will make an excellent fun commuter.

'86 GL three door, 1.8 Turbo, LSD in rear, 5sp with hi/lo tcase, power everything (and it all works!), 85k stock miles, and a mediocre respray paint job.

Story is it blew a head gasket a long time ago and sat. Earlier this year the guy I bought it from fixed the head gasket issue, drove it for a bit, then I bought it for a reasonable price.

It's quick, handles well for a stock old car, and very minimal rust!

Plans for now: fix little issues (trim/exhaust leak/interior/etc), then tackle the engine as it's idling rough. Already began the process of replacing broken/cracked vacuum lines which seems to be helping.

Photos:

Posted Image

Posted Image

Posted Image

Posted Image
^Pile after first couple hours of owning car. Removing old alarm system/previous owners sub/amp harness. Unfortunately he removed/unwired the stock speakers in the rear so those will have to be replaced.

#2 AKghandi

AKghandi

    87 GL-10 2" lift 27" tires, 86 GL 2" lift 29"

  • Members
  • 1,114 posts
  • Anchorage, Alaska

Posted 15 October 2012 - 10:15 PM

thats a really nice 3 door!..

its almost like a stealthy RX lol winter is almost here and that things going to be a blast! :headbang:

as for the rough idle check the intake pipe. if thats all good and theres no CEL i would try seafoam.

#3 TOsborn

TOsborn

    USMB Regular

  • Members
  • 142 posts
  • Everett

Posted 16 October 2012 - 01:25 AM

Whats the difference between the RX and GL three door? The title paperwork reads GL, but I really should check the door plate.

Rough idle has been intermittent, as for 90% of today it was fine (much better than yesterday). Which leads me to think it may be a leaky/loose vacuum hose bouncing open and closed or a loose connection in the ignition somewhere.

Spent time deep cleaning on it today, and driving the wheels off of it. No complaints so far!

#4 O.C.D.

O.C.D.

    Subaru Fanatic!

  • Validating
  • 690 posts
  • Colorado Springs

Posted 16 October 2012 - 08:10 AM

Bad @$$ find there. Looks to be in great shape. :popcorn:

#5 TOsborn

TOsborn

    USMB Regular

  • Members
  • 142 posts
  • Everett

Posted 19 October 2012 - 01:47 AM

Car is coming along slowly, no new photos thanks the recent deluge of rain.

-new axle/CV
-new tstat (old gasket was leaking, replaced the tstat while in there)
-tons of interior/exterior trim fixes
-more new vacuum lines to replace old rock hard and cracked ones
-many new hardware bits off a junkyard wagon
-engine bay cleaning/organizing

And the bad news
-plug threads are chewed up, going to need a heli coil job or if possible squeaking by with a quick cleaning/running a tap through them
-injectors are leaking, planning on taking them to an injector shop to see if they can be cleaned, or rebuilt, or if they should be replaced.
-still needs exhaust work, as it is pinched almost shut where it bends over the rear axle. This would explain the holes drilled in the exhaust right after the cat.
-might need a new efan, as the shroud on the old one was dented so that it interfered with the fan blades. Bent the shroud back into shape, but haven't seen the fan turn on yet. Does anyone know at what temp it's supposed to activate?

After digging into it more, the last owner really did a sloppy job of re-assembling the engine bay after he 'supposedly' replaced the head gaskets. Many important bits of hardware missing/loose. It's been a bit of a learning experience running through everything.

Going to keep plugging away at it as low budget as possible. The EA82 turbo seems to be a finnicky engine from what I've heard, should be an interesting project/driver. Going to try and keep it all stock and maintained perfectly to hopefully ebb as much life out of it as possible!

#6 l75eya

l75eya

    Subaru Nut

  • Members
  • 1,472 posts
  • Hoboken, NJ

Posted 19 October 2012 - 02:50 PM

What's with everybody getting these 3-doors. I want one *so* bad but they are nowhere to be found on the east coast. Congrats on that buy! Hope it doesn't turn into tractor pole's $200 winter car has turned into an obsession. =P

#7 TOsborn

TOsborn

    USMB Regular

  • Members
  • 142 posts
  • Everett

Posted 19 October 2012 - 02:58 PM

Score today at the junkyard.

-working dash clock + non broken clock trim piece
-the rest of the battery holdown I found prior
-front mudflaps
-some original radio wiring harness to help fix the hack job aftermarket stereo someone put in it
-spare tire + mounting hardware
-and found a '89 ea82 turbo wagon, with a complete engine! Got even more fasteners to replace on mine, and considering buying the injectors off it to use as cores for rebuilds, as mine need replacing. Also a great resource for comparing my vacuum lines too.

#8 AKghandi

AKghandi

    87 GL-10 2" lift 27" tires, 86 GL 2" lift 29"

  • Members
  • 1,114 posts
  • Anchorage, Alaska

Posted 19 October 2012 - 08:09 PM

if i were you id pull those heads off the 89 just to have. the gen 3 heads are stronger than the gen 1 or 2 heads i believe they went to gen 3 in 87.5?

hell id pull the whole motor just to have..with the ea82t's you might as well have a second one as its just a matter of time.. i would almost bet money the guy you got it from found cracks between the exhaust and intake valves(not entirely fatal) and decided to cut and run. if i were working on a car that nice i would have done a perfect job on the reassembly and kept it for ever. which is why im suspicious.. but i could be completely wrong.:-p

its sad to see a subaru improperly maintained, but if they were all properly maintained how would we get them so cheap? lol

#9 TOsborn

TOsborn

    USMB Regular

  • Members
  • 142 posts
  • Everett

Posted 19 October 2012 - 09:59 PM

^He's asking $450-500 for the whole engine, "supposedly" it runs, and it has 150,xxx miles. What are they worth? Seemed a little steep to me, are these heads available new anywhere, or is hoarding the old ones the way to go?

I think he ran it for at least awhile after he fixed it, or else I don't see why he'd go through the time to install his "sweet" stereo, then uninstall it for the sale. I'd bet he found cracks too, as they seem inevitable!

I did find out how much he paid for the car earlier this year though, the first owner donated it to one of those charities that takes non running vehicles (this one was not running), he bought it from them for...$600!

And I ordered new injectors today since the old ones are leaking, Dr. Injector (has a shop in Tacoma, and a few other in the PNW) ordered them for significantly less than I found them at any auto parts store. Will be replacing fuel filter when I swap the new injectors in.

#10 AKghandi

AKghandi

    87 GL-10 2" lift 27" tires, 86 GL 2" lift 29"

  • Members
  • 1,114 posts
  • Anchorage, Alaska

Posted 20 October 2012 - 01:40 AM

$450 is really steep for an ea82t. $200 would be the most I'd go for a good one. most of the GL turbo's i get cost half as much as he wants for just the engine.

they are a very temper-mental motor. so keep an eye out, there is always deals popping up. especially the ea82ts.

Random coincidence, i just got back from looking at an 89 gl turbo full time 4x4 wagon 203k miles/
But the rest of it was COMPLETELY trash and it was an auto.
Honestly i have no where to put another engine right now so i had to pass.

Heres the kicker though, he wanted to GIVE it to me.:cool: LOL

new injectors should help a lot what did you end up paying for them?

Edited by AKghandi, 20 October 2012 - 01:48 AM.


#11 TOsborn

TOsborn

    USMB Regular

  • Members
  • 142 posts
  • Everett

Posted 20 October 2012 - 02:12 AM

$58.60 a pop for brand new injectors. I'm pretty content with the price, as it's less than the reman's for my old '96 Legacy cost.

#12 AKghandi

AKghandi

    87 GL-10 2" lift 27" tires, 86 GL 2" lift 29"

  • Members
  • 1,114 posts
  • Anchorage, Alaska

Posted 20 October 2012 - 04:39 AM

Thats a pretty good price, i cant wait to see what you do to this sleeprx :D:popcorn: not to mention quattro san:headbang:

#13 TOsborn

TOsborn

    USMB Regular

  • Members
  • 142 posts
  • Everett

Posted 22 October 2012 - 10:38 AM

Spent the weekend driving the crap out of it waiting for something to break, and nothing did! Haven't done much repair to it, as I was kind of busy all weekend, but did find time to remove a couple pounds of mud from my inner fenders. Luckily it hadn't been there long enough to rust them out, but would of eventually. Also have kept up with removing exterior engine bits, cleaning and inspecting them, and re-installing them correctly.

Tonight new injectors and fuel filter are going in.

And decided to go for a quick hike up above Lake Cushman, on Mt Ellinor, this sunday morning. Found snow!

Posted Image

#14 AKghandi

AKghandi

    87 GL-10 2" lift 27" tires, 86 GL 2" lift 29"

  • Members
  • 1,114 posts
  • Anchorage, Alaska

Posted 22 October 2012 - 03:25 PM

mmmmm snow..:slobber:

i bet that was alot of fun!... we know you drifted it lol\

so theres snow in the pnw but it hasnt really snowed here in AK....weird..

#15 natext6

natext6

    Relax, smoke a dübaru.

  • Silver Subscribers
  • 168 posts
  • calgary

Posted 22 October 2012 - 04:11 PM

Posted Image


THAT. Is a gorgeous picture.:headbang:

#16 SmashedGlass

SmashedGlass

    Eat, Live, Breath Subaru

  • Members
  • 669 posts
  • From CO, stuck in FL

Posted 22 October 2012 - 04:38 PM

WHY did I move away from the mountains?!? :banghead:


edited: why don't they have a cry emoticon?

#17 TOsborn

TOsborn

    USMB Regular

  • Members
  • 142 posts
  • Everett

Posted 22 October 2012 - 06:21 PM

New injectors made a huge difference! Idle is smoothed out a ton. After removing the old injectors, it became very apparent that they were leaking between the plastic/metal parts of the body. Also, the old o-rings were rock hard.

The fuel filter also appeared to be OEM '86 Subaru, so good to change that as well.

#18 TOsborn

TOsborn

    USMB Regular

  • Members
  • 142 posts
  • Everett

Posted 27 October 2012 - 02:02 AM

Rough idle came back after after a bit of driving unfortunately after a bit of driving, but have made a bit of progress in eradicating it.

First removed and cleaned the EGR valve. It functioned well (when sucking on the vacuum line, the pintle actuated fine) and after soaking the bottom of the valve in carb cleaner, re-installed it with a new gasket. No discernible difference on idle smoothness, but at least it's clean now, and I know it works.

Also noticed a fair amount of corrosion on the top part of my coolant temp sensor. Since they are only $15 at my local parts store, I bought a brand new one (the box it came in looked like it had been on the shelf for a long time), and installed it. Surprisingly this seems to have helped a fair amount. In the last five key cycles since I installed it, no random check engine light flashes, and a smooth idle at 800-1k rpms when warm. I thought this may be a problem area, as the car was seeming to have a hard time adjusting the idle speed as the engine warmed up.

Driving the car up north to Bellingham this weekend as another road test, the back is loaded with rally tires and steelies from my old Legacy that I'm selling to a friend (for a boosted Corolla AllTrac project), so it'll be a heavy load for it! Also stopping at the Pick and Pull in Arlington, looking for a drivers side headlight (mine's fogged) and dash doo dads. Hopefully the drive goes well and uneventful.

Also, did this car come with a front skidplate from the factory? I've been looking at a '89 Turbo Wagon at a local junkyard that has one, and wondering if it will fit on mine.

#19 el_freddo

el_freddo

    Eat, Live, Breath Subaru

  • Members
  • 515 posts
  • Lancefield, Vic, Aust.

Posted 27 October 2012 - 02:26 AM

What's with everybody getting these 3-doors. I want one *so* bad but they are nowhere to be found on the east coast. Congrats on that buy! Hope it doesn't turn into tractor pole's $200 winter car has turned into an obsession. =P


Me too mate, Me too! But they never rolled off a showroom floor in Australia :(

-working dash clock + non broken clock trim piece


To save you some coin the old clock could have been opened up, the dry solder joint(s) found and re-soldered. It's worked a treat for me on 3 clocks so far!

Also, I'm guessing that with your three door that it is an RXII from what I've researched. The grille, RX turbo dash and the fact that it's an EA82T are dead giveaways. The rear LSD is also a good indicator. I'd put my money on it that IF it has the factory gearbox it is AWD with a centre diff lock. Awesome box, can't wait to have mine sorted (again, rare as hens teeth over here!).

Further to the above, the LHS button pad on the dash board, where the flat grey blank buttons are. These grey ones can be replaced with any L series buttons that are the same style as the black rimmed ones with the grey pad in the centre. The flat grey ones are from the earlier model L's ;)

Look after that coupe, I'm sure I'm not the only jealous forum member that's drooling over yours!

Cheers

Bennie

#20 AKghandi

AKghandi

    87 GL-10 2" lift 27" tires, 86 GL 2" lift 29"

  • Members
  • 1,114 posts
  • Anchorage, Alaska

Posted 27 October 2012 - 03:04 AM

adding a skid plate is as easy as bolting it on. and its very worth it.
theres 2 bolts on the core suport and 2 on the engine cradle.

#21 Idasho

Idasho

    Lost in the woods....

  • Members
  • 958 posts
  • North ID

Posted 27 October 2012 - 01:44 PM

I like this car!

:headbang:

#22 TOsborn

TOsborn

    USMB Regular

  • Members
  • 142 posts
  • Everett

Posted 29 October 2012 - 02:07 AM

300+ mile weekend and no issues again! Reached 31 MPG on the freeway which really surprised me, in town I've been getting low to mid 20's.

Stopped by the Arlington Pick-a-Part, and as usual came out with a good haul of hardware/vacuum switches. And found a cherry spare drivers side headlight.

Also, on the way out I decided to check the last row of the import section, and found a '83 Hatch, which then led to more spending on parts for Quattro San.

#23 TOsborn

TOsborn

    USMB Regular

  • Members
  • 142 posts
  • Everett

Posted 08 November 2012 - 03:07 PM

More progress, and finally after putting 2k plus miles on the car, something broke!

Recently I have been continuing fixing little things on the car, such as cleaning the fuel line connections (one was leaking due to age by the pump, cleaned the hose barb and no further leaks). Do these EA82's have a second fuel filter by the pump? I looked but didn't see anything.

Also have been resealing parts of the engine, most recent project was valve cover gaskets, as the old ones were leaking. I also cleaned the valve covers while I was in there, and they came out nice.

Posted Image

Over the past week it has been picking up the dreaded lifter tick. I decided to see if an oil change would do the trick, as it was due. And fortunately it did for now. I have new lifters for the side that was ticking, but if the oil change keeps it in check I'll just live with it, as the tick is a nice reminder to change the oil!

Here's the obligatory engine shot, nothing special, but here it is (the MAF and such is missing as I was in the middle of puling the valve cover):

Posted Image

And finally, the broken part was the hood release cable. Will be heading to the junkyard tomorrow to buy another one.

Next week I will be starting a very long road trip with the car, as I am finally (mostly) confident it can make it. Starting in Washington, I'm driving to LA, California, to visit an old friend. From there I plan on going east. Colorado, Utah, and possibly further east depending on how the car is doing at the time. Should be a great adventure, and the car has been doing fine the last 2k miles, so hopefully it's ready to do a ton more! I have inspected just about every bit of the car back to front, and everything checks out for the journey. Any extra advice on prepping EA82T's for a long trip would be nice.

#24 l75eya

l75eya

    Subaru Nut

  • Members
  • 1,472 posts
  • Hoboken, NJ

Posted 09 November 2012 - 12:15 AM

Bring any/every extra part you got, just in case.

When I drove to NV last summer I had in the car
-ALL of my tools
-oil pump
-water pump
-timing belts
-acc. belts
-jack
-jackstands
-full spare tire under the hood
-duct-tape
-a ton of zip-ties
I'm sure there's more, but you get my point.

Bring more than what you think you'll need. I went through 3 quarts of oil in 7,000 miles btw.

#25 TOsborn

TOsborn

    USMB Regular

  • Members
  • 142 posts
  • Everett

Posted 10 November 2012 - 03:55 PM

The leaky radiator has been bugging me for awhile, and had to be fixed before the long drive:

Posted Image

So found a shop with one in stock, and installed a new radiator today! While I was in there I also took time to re-inspect timing belts and water pump, and everything looked okay, the timing belts appeared to be new! The cam seals didn't appear to be leaking either, which was good.

Posted Image

Surprisingly, the new radiator ($99.99 at Oreilly's) seems to fit better than the old. Made putting it back in and bolting the fans back on a breeze.

Edited by TOsborn, 10 November 2012 - 04:06 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users