Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
* * * * * 1 votes

'86 Subaru GL Turbo


  • Please log in to reply
78 replies to this topic

#26 TOsborn

TOsborn

    USMB Regular

  • Members
  • 142 posts
  • Everett

Posted 12 November 2012 - 10:45 PM

Did some final work on the car today before leaving on the trip.

Had it up on my friends lift for exhaust repair/rebuild. Succeeded in welding the holes drilled in the pipe after the cat, and installed a new muffler. Ended up using and old truck muffler from the scrap pile, as it is in much better shape then the stock Subaru one (somebody attacked it with a screwdriver, and generally beat the heck out of it). Used all of the stock mounting bits of the old muffler and welded them to the new one, it came out pretty slick.

And now I don't sound like and idiot running around with no exhaust, so bonus there. Also, the small tip tucked up in the stock relief makes it virtually noticeable from behind, which I prefer. One day I'd like to remove the cat (it's beat to heck, and probably isn't doing too much anyways) and make a full new exhaust to help it breathe a bit better, but that's down the line.

While I had it up in the air,
-rotated tires
-new LSD oil
-new rear brake pads
-fixed leaky oil pan gasket

Posted Image

#27 TOsborn

TOsborn

    USMB Regular

  • Members
  • 142 posts
  • Everett

Posted 15 November 2012 - 04:48 PM

Road trip in the GL has begun!

Started out in Tacoma, WA and am currently in Crescent City, CA. Taking the coast hwy south, started on 101 in Olympia, and will be taking that till Hwy 1 (in CA) and following that to LA. And camping out the whole way. Car has run flawlessly so far, except for it picked up a slight lifter tick again today. Will be doing an oil change at a campground in the next day or so to fix that. After LA, planning on going east, through vegas, and then north to visit Bonneville. After that North to Idaho for some hiking, then back home!

Fingers crossed the EA82T holds out for the trip!

#28 TOsborn

TOsborn

    USMB Regular

  • Members
  • 142 posts
  • Everett

Posted 08 January 2013 - 05:43 PM

Just thought I'd post that this car has been running great! Put 7k miles on it since purchased, and it keeps on going. It's been from the Canadian border to the Mexican border, up and down forest service roads, and through deep snow and rivers without getting stuck (this could be due to me being more cautious than I used to be...). And the dual range rules.

Other than minor maintenance, it's required no large repairs. Only on road failure was the voltage rectifier calling it quits, easy repair. Quite happy with it, as everyone locally advised me that it will explode immediately. Since my '96 Outback only lasted about 6k till it needed head gaskets (at 160k) I'm hoping this one makes it well over 100k till I have to pull heads. Currently its almost at 93k, and I'm stoked to hit 100k!

#29 AKghandi

AKghandi

    87 GL-10 2" lift 27" tires, 86 GL 2" lift 29"

  • Members
  • 1,148 posts
  • Anchorage, Alaska

Posted 08 January 2013 - 06:39 PM

my ea82t has 249k and it just keeps on goin! gotta love it:headbang:

#30 marcusgl10z28

marcusgl10z28

    USMB is life!

  • Members
  • 240 posts
  • tacoma wa

Posted 29 March 2013 - 12:44 AM

mines at 272k she needs some work but i just cant kill it!!! oil is crystal clear



#31 TOsborn

TOsborn

    USMB Regular

  • Members
  • 142 posts
  • Everett

Posted 29 March 2013 - 01:10 AM

Just rolled over to 96k a few days ago!

 

It finally doesn't sound idiotic anymore while running.  Found out that my horrid exhaust leak was caused by both passenger side exhaust studs having pulled out of the head.  Heli-coiled them (from laying under the car, it sucked) and now it purrs.  Also fixed the horrid bearing squeal, found it was the tensioner bearing for the A/C belt.  Repacked it with grease and it's fine.  So for the first time ever, no exhaust leak or bearing squals!

 

Though in the last few days my oil pressure guage and temp guage have been reading off.  The oil pressure guage will go to 85PSI and sit there, even while idleing.  Maybe the pressure sensor is going out.  And the temp guage will go straight to red to, even when it is obvious that the engine isn't overheating.  Going to look into that one soon, as in tomorrow.  Might be a good idea to throw a water pump at it, just in case.



#32 zukiru

zukiru

    EJ22T

  • Members
  • 1,229 posts
  • Oak Grove, AL

Posted 29 March 2013 - 01:10 AM

Okay. I want that steering wheel for my sedan. Is that an 86 thing, or a 3 door coupe thing?


Also love this car! Nice to see a coupe in blue. Most of them i see pics of are white.

Edited by zukiru, 29 March 2013 - 01:11 AM.


#33 TOsborn

TOsborn

    USMB Regular

  • Members
  • 142 posts
  • Everett

Posted 29 March 2013 - 01:22 AM

I don't know, I think I've seen it around before in junkyards.  Maybe someone smarter than me will chime in.  I like how "thin" or skinny the wheel is, feels good.  Plus the little thumb rests are kind of nice.  The blue is the original color, but somewhere down the line this one was repainted.  It matches great though with the original paint.

 

I'm heading out to Quilcene tomorrow for some hiking, will try and take some more shots of the car if the weather isn't too bad. 



#34 zukiru

zukiru

    EJ22T

  • Members
  • 1,229 posts
  • Oak Grove, AL

Posted 31 March 2013 - 04:26 PM

I keep looking at this. It's like my xt and my sedan had a love child.. Love it.
IMG456_zps733a27ef.jpg

#35 TOsborn

TOsborn

    USMB Regular

  • Members
  • 142 posts
  • Everett

Posted 01 April 2013 - 12:15 AM

Holy crap, the cars's family lives in Alabama.  That's trippy!



#36 TOsborn

TOsborn

    USMB Regular

  • Members
  • 142 posts
  • Everett

Posted 01 April 2013 - 05:58 PM

Okay, a few new photos of the tiny beast.

 

^Front end needed a bit of cleaning.

 

^Up hiking around the Vance Creek area above Shelton.  Snow got way too deep, way too quick...

 

^Today, after a quick wash.

 

^Bumped the rear end up one adjustment on the OEM struts to level the car out a bit.  Was a bit nose high when both the front/rear are adjusted to their lowest setting.

 

^And just for fun, a license plate frame.  A friend was drunk on ebay looking for vintage WA GMC dealer frames for his truck, and ended up buying these.  Of course his Jimmy isn't an import, and I have no idea what a GM import is.  Maybe they sold import cars at the GM dealer in Renton, WA?  Any history on these would be cool.



#37 TOsborn

TOsborn

    USMB Regular

  • Members
  • 142 posts
  • Everett

Posted 01 April 2013 - 06:05 PM

Okay, and a question for everyone.  I've finally found two headlights that don't fog up (after trying about four from pick a part...).  But how do I keep my corner clearance lights from fogging up/moisture building up in there?  They are vented stock, so is this just inherent?  I've replaced the prior broken bulb holders with good junkyard ones that seal well, but the plastic keeps filling with condensed water.  I've never really noticed it on other GLs.  Thanks!



#38 zukiru

zukiru

    EJ22T

  • Members
  • 1,229 posts
  • Oak Grove, AL

Posted 12 April 2013 - 01:28 AM

Make sure the vents are clear. I had an Escort that would fog the corners. I blew out the vents and it quit fogging. My theory is that the moisture escapes out these vents on the sunny days.

#39 TOsborn

TOsborn

    USMB Regular

  • Members
  • 142 posts
  • Everett

Posted 20 April 2013 - 05:14 PM

Picked up a less ripped rear seat back from a member, doesn't match the interior but way better than the original exploded one.

 

Also, picked up 5 Peugeot 505 wheels today from another member, plan is to powdercoat them white.  This photo is after an hour of wet sanding a bit of curb rash off of them.

 



#40 Reza

Reza

    USMB Regular

  • Members
  • 137 posts
  • Portland, OR

Posted 20 April 2013 - 07:53 PM

Killer car



#41 zukiru

zukiru

    EJ22T

  • Members
  • 1,229 posts
  • Oak Grove, AL

Posted 20 April 2013 - 09:24 PM

Why white? I'd go bronze or gunmetal

#42 TOsborn

TOsborn

    USMB Regular

  • Members
  • 142 posts
  • Everett

Posted 21 April 2013 - 02:22 AM

I've always like white alloys for some reason, and I think they'd look pretty killer on this car.  Bronze would be pretty neat, but I want these to be bright!



#43 TOsborn

TOsborn

    USMB Regular

  • Members
  • 142 posts
  • Everett

Posted 23 April 2013 - 08:09 PM

And here's the next improvement, picked this up for free.  EA82 multi port injection intake, seems to have never been run.  I've just ordered up new gaskets to reseal it, OEM thermostat, new water pump, and then will be swapping it for my nasty filthy dirty (and leaky) intake that's on the car.  While I'm in there planning on doing water pump and cleaning the living crap out of the engine.  The freeze plugs on the back of my intake have been weeping coolant since I bought the car, so this will be a huge improvement. 

 

Does anyone know if there are any specifics to the turbo intake that I should watch out for?  I've compared the two (one on car to this one) and they seem identical.  Thanks!

 



#44 rpholz

rpholz

    Subaru Fanatic!

  • Members
  • 556 posts
  • Concord, NC

Posted 23 April 2013 - 09:22 PM

Only differences I can recall is the turbo coolant line

#45 TOsborn

TOsborn

    USMB Regular

  • Members
  • 142 posts
  • Everett

Posted 23 April 2013 - 11:10 PM

Thanks, I'll look into that.

 

Only differences I can recall is the turbo coolant line



#46 TOsborn

TOsborn

    USMB Regular

  • Members
  • 142 posts
  • Everett

Posted 25 April 2013 - 01:00 AM

So I just compared intakes, and it looks like the hard line coming from under the thermostat is the turbo coolant line, correct?  If so, I'm stoked it's a turbo intake and the swap should go smoothly!



#47 rpholz

rpholz

    Subaru Fanatic!

  • Members
  • 556 posts
  • Concord, NC

Posted 25 April 2013 - 08:03 AM

Oh, yea

For some reason I didn't think the intake you posted was the new one,lol yea your good to go.

I was just stating standard MPFI vs turbo intake

#48 TOsborn

TOsborn

    USMB Regular

  • Members
  • 142 posts
  • Everett

Posted 04 May 2013 - 02:44 AM

Well, started the intake swap today.  Everything went fine, except one of the intake bolts broke off in the engine block.  After much coaxing it wouldn't budge, then snapped.  Shouldn't be too hard to drill out with a LH bit, or heli coil worse case scenario.

 

Start of the evening:

 

Getting closer:

 

Swapping parts between the two:

 

Around midnight called it a night:

 

While draining the coolant, I found a ton of metal shavings.  Not too stoked on that, but I was planning on installing a new water pump anyways so glad I caught it now!  Also found out one of the wire to what I think is a knock sensor (?) is severed in the connector.  Going to need to source a new connector at the junkyard and solder it on. 

 

At the end of this I should have a car that doesn't heat up at idle on hot days, and doesn't puke coolant out of leaky freeze plugs in the intake constantly! 



#49 TOsborn

TOsborn

    USMB Regular

  • Members
  • 142 posts
  • Everett

Posted 04 May 2013 - 02:46 AM

Also, what seals the metal pipe to the water pump?  Currently it appears to have a large amount of sealant goo on it, which is working.  But I'd rather not do that if I can avoid it.



#50 rpholz

rpholz

    Subaru Fanatic!

  • Members
  • 556 posts
  • Concord, NC

Posted 04 May 2013 - 01:58 PM

That metal pipe uses a large o-ring to seal it. Not sure of the part number or if the seals are still available. So large amounts of sealant are usually the answer




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users