Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Blower motor question


  • Please log in to reply
3 replies to this topic

#1 LeakingOil

LeakingOil

    Siren of the Pleiades

  • Members
  • 536 posts
  • Pittston

Posted 07 April 2004 - 08:11 PM

(Also posted on XT6.net)

My blower motor just crapped out! Took it apart and one of the little brushes was totally gone, wore down right to the wire. Now the question:
Can I replace them myself of do I have to take it somewhere to have it done? If I can do it myself...where do i pur chase the brushes? Need to have my A/C for summer and heat for when it gets nipply out! Any help is greatly appreciated!

Smiles,
Melis

#2 Partsman

Partsman

    Eat, Live, Breath Subaru

  • Members
  • 262 posts
  • sunny Eugene, OR

Posted 07 April 2004 - 08:55 PM

My motor was exactly the same - was running on the wire instead of the brush! I suppose you could replace the brushes, but it looked like a bi**h to put back together and I wasn't sure where to get brushes anymore, so I replaced the unit. The NAPA new one is $59.99 over the counter - part# 655-1617. However, I'm cheap (even though I get the employee discount) so I got a JY unit from a 93 loyale with 78k on the odometer for $20.

#3 LeakingOil

LeakingOil

    Siren of the Pleiades

  • Members
  • 536 posts
  • Pittston

Posted 07 April 2004 - 10:45 PM

Thanks for the info.! Hopefully I can get to the yard before the Godsmack show <I like to tinker so I'm still ganna search for the brushes>

Smiles,
Melis

#4 Dennis ex24

Dennis ex24

    Subaru Disaster

  • Members
  • 2,683 posts
  • Phila, Pa

Posted 08 April 2004 - 02:16 PM

melis,

go grab one out of any everyday loyale/gl/dl/xt at the yard and toss it in there. any of them will work in your xt6.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users