Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

need info on pressure plates asap!


  • Please log in to reply
2 replies to this topic

#1 maozebong

maozebong

    USMB is life!

  • Members
  • 274 posts
  • Seattle, WA

Posted 25 December 2012 - 10:42 PM

so i just installed a clutch on my loyale, and it doesnt feel right. the clutch disk is right, but i think the PP is wrong. the clutch cable is nearly bottomed out, and when i push on the clutch, it only has a short bit of travel and then feels like it hits a wall, and im just stretching the clutch cable. it also slips when cold, but grabs when warm.

it bolted up to the flywheel just fine, so it has to be an EA PP, but i think the installed height of the teeth might have something to do with it.

im tearing it out right now in my garage, pics soon...

btw the clutch was a brute power 4wd kit from rock auto. i bought it because the disk has more dampening springs than the other kits.

so, USMB, spill post what you know and pics if you have them on EA pressure plate differences. maybe they gave me an EA81 PP.

#2 maozebong

maozebong

    USMB is life!

  • Members
  • 274 posts
  • Seattle, WA

Posted 26 December 2012 - 01:55 AM

ok, update... got the other plate out and the original back in. the teeth were sucked all the way down, and when removed, the original one was shorter and had a different ID of the teeth.

in the end, it made a difference of about at least a 5/8" on the clutch cable, from nearly bottomed out adjustment, to a perfectly acceptable range on the cable.


so, lesson learned. drink less while working late. you miss little things that have you doing a clutch on xmas.

Edited by maozebong, 26 December 2012 - 02:13 AM.


#3 ivans imports

ivans imports

    1000+ Super USER!

  • Members
  • 2,954 posts
  • lumby bc canada

Posted 26 December 2012 - 11:26 AM

i have the step on the flywheel machined to compensate but sounds like a ea81 pp mixup to me




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users