Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

My pickup tube is clogged with paper???


  • Please log in to reply
29 replies to this topic

#26 dballs

dballs

    USMB Regular

  • Members
  • PipPipPip
  • 56 posts
  • Western Ny

Posted 30 April 2013 - 11:59 AM

Update: Still holding strong pressure, 80 psi on startup. 40psi cruising. Hopefully the internals hold up for the long haul.



#27 WoodsWagon

WoodsWagon

    Formerly 91Loyale

  • Members
  • 3,945 posts
  • NH

Posted 01 May 2013 - 08:55 PM

Did you ask the guy who did the headgasket about it and show him your bucket of paper towel bits? If he was decent, the least he could offer is a 50k warranty on the engine. It's highly likely the rod bearings took a fair bit of damage, but they won't start knocking until they are really gone. On a non-turbo motor that can take a while.



#28 dballs

dballs

    USMB Regular

  • Members
  • PipPipPip
  • 56 posts
  • Western Ny

Posted 03 May 2013 - 12:02 PM

I asked him but he replied with "we don't use shop towels when we do head-gaskets" and I got nowhere. I think I am going to send the oil sample out to blackstone and have them take a look to see how much metal is in it.



#29 rverdoold

rverdoold

    Subaru Nut

  • Members
  • 640 posts
  • Netherlands

Posted 04 May 2013 - 05:37 AM

There is another port toward the rear of the block that can be used as well. And I think the thread on the rear port is 1/2" NPT.

I have been searching for this port to mount an oil pressure/temp sensor but could not find it. Could you give bit more precise description where it is located?



#30 95legwagon

95legwagon

    USMB is life!

  • Members
  • 221 posts
  • west hartford

Posted 08 May 2013 - 06:30 PM

i believe its on the back of the block..... ive read that it looks like either a big bolt or big allen head. **dont quote me on that as i dont know for sure**  there is one on the top of the block pass side towards the back but is hard to get to. there is like 4 or 5 of them around the block






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users