Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Oxygen sensor problem - error code P0420

Subaru outback oxygen sensor bank one

  • Please log in to reply
6 replies to this topic

#1 shilborn

shilborn

    Newbie

  • Members
  • Pip
  • 2 posts
  • Bosnia and Herzegovina

Posted 20 February 2013 - 10:31 AM

Hi there,

 

I'm living overseas in southeastern europe. There is a dealer nearby in Croatia and Slovenia but it's a lot cheaper to just have a mechanic here help with my problem.

 

The check engine light comes on when I drive over 3 hours on the highway - it's happened a couple of times. I now just clear the error message when it comes on. It is error code P0420 - catalyst efficiency below threshold  (Bank one). The dealer checked it out for 15 minutes and said I needed to replace the catalytic converter. A mechanic in Bosnia told me that the catalytic converter looked ok and I should just replace the oxygen sensor.

 

My question is - what is bank one on a Subaru Outback 2005 limited? How do I know which sensor to replace?

 

I'm nowhere close to being a car expert so appreciate any advice.Attached File  oxygen sensor.JPG   129.49K   8 downloads



#2 ivans imports

ivans imports

    1000+ Super USER!

  • Members
  • 2,950 posts
  • lumby bc canada

Posted 20 February 2013 - 10:37 AM

have fixed a bunch in a row putt a tank or two of premeum feul in it and drive it hard make shure has no exhuast leaks leave factory catts if at all posibble the last one took a month of runing premium gas to turn the light off. Have heads been done ? i find that if gaskets were bad the burnt coolant plugs up catt takes a while running good to clean them out. Spend your money on good gas first before expensive catts. 420 is not a 02 code 02 will not fix thiss problem have had luck taking catts off and preshure washing them out and reinstall.



#3 davebugs

davebugs

    I don't "friend"

  • Members
  • 3,112 posts
  • Pittsburgh suburbs (NE)

Posted 20 February 2013 - 10:50 AM

I've had tremendous luck for several thousand miles using Seafoam thru a vacuum line.

 

But she SMOKES a LOT!!  Serious white smoke while doing this!



#4 grossgary

grossgary

    Elite Master of the Subaru

  • Members
  • 19,900 posts
  • WV

Posted 20 February 2013 - 01:35 PM

It is NOT the converter, though that's often blamed.

Let it be known that you can drive indefinitlely with this code, it causes no problems at all and is strictly an emissions code...and a really lame one at that.  Cars with a P0420 code would actually pass an exhaust analyzer test were able to take it.

 

The engine is not running 100% and the 0420 code is waaaaaay too sensitive.

 

The cheap and easy fix is to install a $5 spacer and never deal with it again (hopefully). 

 

The proper fix is to find the fuel issue, tune up, ignition, exhaust leak or whatever causing the code.  Cardoc has an elaborate post...with videos i think...of how to properly nail this thing down.  But there are very few mechanics that will go to that depth to track it down, and the cost could be high depending on their willingness to learn/help you.



#5 shilborn

shilborn

    Newbie

  • Members
  • Pip
  • 2 posts
  • Bosnia and Herzegovina

Posted 20 February 2013 - 05:53 PM

Hi Gary,

 

Thanks for your response. The mechanic looked at it and took apart the car to look at the converter. He suggested replacing the oxygen sensor. They have been cleaned a couple of times and were last replaced three years ago. A bit more context - I have been driving the car in countries with poor fuel quality, Panama, which I have been told degrades the sensors faster.

 

What is cardoc? And where would you install the spacer? Do you have any suggestions for what the mechanic could look for? If I gave him specific things to look for, I imagine he could try to nail it down. I was going to go for a sensor in the meanwhile as apparently the car is less fuel efficient when the oxygen sensors aren't working.  Any thoughts?

 

Stephanie



#6 J A Blazer

J A Blazer

    Eat, Live, Breath Subaru

  • Members
  • 365 posts
  • Fairfax, Virginia

Posted 20 February 2013 - 06:00 PM

There are others on this forum far more knowledgeable than I, but understand in the 4 cylinder engine there are two sensors, one pre-cat (also called 'upstream') and the other post-cat (aka 'downstream.')  Failure of the upstream one will affect performance; failure of the downstream one won't.  But yes, the check engine light glaring in your face is a real pain, and regardless of whether your car passes emissions tests will jeopardize mandated safety/emissions checks and attempts to sell.



#7 ivans imports

ivans imports

    1000+ Super USER!

  • Members
  • 2,950 posts
  • lumby bc canada

Posted 21 February 2013 - 10:24 AM

I did heads on a 04 impreza 2 days ago had a 420 code when i looked at the #2#4 pistons the uper skirt was scratched very bad and piston was loose had fairly bad piston slap when started cold. I knurlled #2#4 pistons and cleaned the oil ring oil feed holes out all were pluged. Anyway when the pistons get worn like thiss it burns some oil and plugs the catts thiss car ran good no piston slap and stoped burning oil after and the 420 code whent away. When you start it cold is there any piston slap ? and any puffs of oil on start up ?







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users