Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Exhaust leak on 97 Legacy. Big $$$$. I'm torn on what to do.


  • Please log in to reply
27 replies to this topic

#26 Gloyale

Gloyale

    It's a sickness

  • Members
  • 9,007 posts
  • Corvallis, OR PNW

Posted 09 March 2013 - 12:54 PM

I spoke with the seller of the 98 Outback exhaust.  http://nh.craigslist...3625761662.html   He says he has the cat/s (not sure if both or just one) and the o2 sensors as well.  I'm going to check it out this afternoon. 
 
Bratman said above that the 98 outback exhaust should fit my 97 brighton as long as it is wagon to wagon.  I have gotten mixed part numbers from different sites.  Some match, some don't.  Does anyone else have any experience with this as I don't think i will be able to tell just looking at ).


The front section won't fit. 97 Brighton would have single port 2.2.

Everything else should fit fine.

#27 Nbe1210

Nbe1210

    USMB Regular

  • Members
  • PipPipPip
  • 69 posts
  • Dover, NH

Posted 09 March 2013 - 06:55 PM

I got one bolt off on Friday but couldn't even get a wrench on the other bolt. I'll use a lift and get it eventually. I need to get the heat shields off and I should be able to get it but I didn't want to be cutting them off right next to my face.
The new exhaust looks identical. I dragged it under the car and it seems to be the same. I am connecting from the flange just upstream from the first cat. Is there something I don't know?
Is it really important to reinstall the heat shields? They will probably be a pain as the screws are rusted to junk. Thanks for the help

#28 Nbe1210

Nbe1210

    USMB Regular

  • Members
  • PipPipPip
  • 69 posts
  • Dover, NH

Posted 11 March 2013 - 05:57 AM

New exhaust is on. It fit perfect but now i have a bunch of codes. I started anew thread for new problem. It seems like whenever I fix something on this car something else goes wrong before I'm finished.

http://www.ultimates...-now/?p=1151758




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users