Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

question about power steering in a 2002 h6 3.0 out back


  • Please log in to reply
5 replies to this topic

#1 penna22

penna22

    Newbie

  • Members
  • Pip
  • 7 posts
  • ellwood city pa

Posted 23 February 2013 - 08:44 PM

 i just replaced engine in my 2002 out back h6 3.0...  Before engine was removed power steering was excellent ..During engine removel  I  had power steering lines drained & then dropped power steering down because I was thinking i needed to do this to get at tourque converter bolts till i discovered there on engine top thats another story .. any way moter in and runs great..I learned allot thanks to you good people.  The power steering was  installed the same way plenty of fluid but now its noisy and whiney still has power steering going down road , my question Do these systems have to have air bled out or something I can't figure out whats wrong.. Any help would be appreciated...Jim



#2 johnceggleston

johnceggleston

    Lite Master of the Subaru

  • Gold Subscribers
  • 6,286 posts
  • Virginia

Posted 23 February 2013 - 11:46 PM

the pump is succking air. typically this is a bad o-ring on the suction hose bolted to the top of the pump coming from the reservoir.

so i would check there first.



#3 grossgary

grossgary

    Elite Master of the Subaru

  • Members
  • 19,750 posts
  • WV

Posted 24 February 2013 - 01:14 PM

needs primed more possibly - turn the steering wheel lock to lock multiple times should bleed all the air out.

 

or the lines/oring/pump/hose got compromised during install like JCE just said.



#4 penna22

penna22

    Newbie

  • Members
  • Pip
  • 7 posts
  • ellwood city pa

Posted 24 February 2013 - 09:38 PM

i CHANGED THE O RING AND INSTALLED NEW HOSE IT WORKS GREAT NOW THANKS FOR ALL THE HELP .....jIM



#5 isaac.jam

isaac.jam

    Newbie

  • Members
  • Pip
  • 1 posts
  • Nashville

Posted 01 February 2014 - 03:17 PM

Do you know the part number for the hose that connects to the o-ring/housing? I'm having a hard time finding the correct part. I have that 34611AE110 is the part number from this site: http://opposedforces...teering_system/

 

Nothing seems to come up when I search on the dealers site with that part number. Also I found one for the 2.5 I'm not sure if it would fit on a 3.0?



#6 johnceggleston

johnceggleston

    Lite Master of the Subaru

  • Gold Subscribers
  • 6,286 posts
  • Virginia

Posted 01 February 2014 - 09:30 PM

that part number is for europe.

 

search again and use the US catalog.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users