Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

check engine light and intermitent high idle


  • Please log in to reply
3 replies to this topic

#1 goat

goat

    New User

  • Members
  • PipPip
  • 15 posts
  • where l lay my head....

Posted 02 March 2013 - 04:23 PM

good day all

its been a while sincel was on here

 

but my sweetys 92 loyale is acting up

 

here is her description:

 

so for a while now the car seems to get stuck in high idle when I start it up and go down a big hill in first and second gear. It revs very high for a bit and then normalizes when I'm on the road in a higher gear.

It may be fine all day with no signs of problems, but lately it has been idleing erattically when I am sitting in traffic, higher then lower then higher then lower...etc rapidly. When it is doing this the check engine light comes on, but when I get going again the light turns off and the problem goes away.

 

l've been tryign to serarch but not finding many similar threads...

 

thoughts

sugestions

places to start

 

thanks

goat



#2 superpoo93

superpoo93

    New User

  • Gold Subscribers
  • PipPipPip
  • 81 posts
  • las vegas

Posted 02 March 2013 - 06:47 PM

I had same type of idle issues w/ up and down idle when stopped an high idle when first started. I was not even using my A/C or heater when stopped because idle would be up/down or so high or so low that it would not charge battery right. Clean your IAC first if that does not work, check EBAY for a good deal. I just bought a reconditioned one for $50 W/ free shipping. It works just like it should mow... There are posts here on the subject sometimes hard to find. Hope this helps

Edited by superpoo93, 02 March 2013 - 10:27 PM.


#3 86 Wonder Wedge

86 Wonder Wedge

    USMB Regular

  • Members
  • 347 posts
  • Akron, OH

Posted 04 March 2013 - 01:22 AM

Is the idle real slow to respond, like if you rev it, it'll take a few seconds to come back down?

 

Could be a coolant temp sensor, or a vac leak of some kind... I know when my 91 Loyale is COLD (like 20F outside temp), it's a bit slow in bringing the idle back down when coming to a stop, until the blood starts flowing a little bit better..



#4 mikaleda

mikaleda

    1000+ member!

  • Members
  • 1,329 posts
  • priest lake, Idaho

Posted 05 March 2013 - 05:52 PM

First check the codes there are connecters under the dash they are usually taped up there should be two sets of single connecters one set is black the other is green, connect the black connecters to get the codes. There are step by step instructions on the board do search and you should find them
Edit: here is the instructions for a legacy I think the loyals are similar but the connecters might not be under the dash.
http://www.surrealmi...aru/engine.html

Edited by mikaleda, 05 March 2013 - 05:56 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users