Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

need turbo for ea82t?


  • Please log in to reply
4 replies to this topic

#1 marcusgl10z28

marcusgl10z28

    Eat, Live, Breath Subaru

  • Members
  • 261 posts
  • tacoma wa

Posted 27 March 2013 - 12:30 AM

I need a turbo for my ea82... I think.. Engine makes some raket near the turbo in 1300-2000 rpm range.. some fresh oil residue in intake plenum and smokes at idle and after shutdown.. Most smoke is after shut down.. Seems to run fine.. But stopped driving it... Anyone have a turbo mines vf5 I think

#2 NorthWet

NorthWet

    Eeyore Incarnate

  • Members
  • 5,039 posts
  • Bremerton, WA

Posted 27 March 2013 - 01:10 AM

Most likely IMHO is that your uppipe has cracked at the turbo flange... a very common problem.  Oil often comes from PCV system: you might want to check in the rubber inlet boot for oil.

 

I might have an extra turbo lying around.



#3 marcusgl10z28

marcusgl10z28

    Eat, Live, Breath Subaru

  • Members
  • 261 posts
  • tacoma wa

Posted 28 March 2013 - 09:34 PM

ok... ill check now... lemme know f you do have one though... thanks... and i do have a new exhause leak i never heard befor seems to be coming from that area  



#4 marcusgl10z28

marcusgl10z28

    Eat, Live, Breath Subaru

  • Members
  • 261 posts
  • tacoma wa

Posted 28 March 2013 - 09:39 PM

just looked annd yup... its got an fair coat of oil in it and in the maf... what on earth would cause that... its no over filled with oil...



#5 NorthWet

NorthWet

    Eeyore Incarnate

  • Members
  • 5,039 posts
  • Bremerton, WA

Posted 29 March 2013 - 01:26 AM

PCV system needs some attention.  The PCV valve itself may need replacing.  The cam-cover PCV vents tend to gunk-up and narrow (easily visible if you pull the hoses off of the cam-covers), and this tends to pump oil upwards.  The breather at the back of the block (near the timing window of the bell housing) might also be gunked up... as might the hoses.  Check over the entire system, but BE GENTLE with the molded hard-plastic "tree that all of the PCV hoses connect to:  It tends to get brittle with age, heat and oil, and may be impossible to buy new.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users