Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

O2 sensor wires pulled out of plug


  • Please log in to reply
13 replies to this topic

#1 mightGETaSUBARU

mightGETaSUBARU

    New User

  • Members
  • PipPipPip
  • 88 posts
  • Kansas City, MO

Posted 16 May 2013 - 11:58 PM

Well the O2 sensor wires pulled out of the plug...  any idea what order they go in?



#2 mightGETaSUBARU

mightGETaSUBARU

    New User

  • Members
  • PipPipPip
  • 88 posts
  • Kansas City, MO

Posted 16 May 2013 - 11:59 PM



#3 Rooster2

Rooster2

    Subaru Master

  • Members
  • 3,875 posts
  • Indianapolis

Posted 17 May 2013 - 09:03 AM

Is this from the front or rear O2 sensor?

 

I just replaced my rear sensor that is a three wire unit. The sensor wiring and connector wiring are color coded the same. So, the colored wires matched up the same upon pushing the connector together from the sensor pig tail to the car wire harness (receiving) connector.



#4 ocei77

ocei77

    Eat, Live, Breath Subaru

  • Members
  • 554 posts
  • Monticello,NY

Posted 17 May 2013 - 06:50 PM

Which engine and what year?

 

O.


Edited by ocei77, 17 May 2013 - 06:51 PM.


#5 mightGETaSUBARU

mightGETaSUBARU

    New User

  • Members
  • PipPipPip
  • 88 posts
  • Kansas City, MO

Posted 17 May 2013 - 09:46 PM

98 Legacy outback 2.5 DOHC, front o2 sensor



#6 ocei77

ocei77

    Eat, Live, Breath Subaru

  • Members
  • 554 posts
  • Monticello,NY

Posted 18 May 2013 - 07:35 AM

Attached File  101_15461.JPG   69.46K   11 downloadsAttached File  101_15461.JPG   69.46K   11 downloadsThis is from a 96. Seems to be the same..

As shown with locking clip on top,

Left is yellow with a red stripe, right is white and the bottom is black.

 

O.


Edited by ocei77, 18 May 2013 - 07:35 AM.


#7 mightGETaSUBARU

mightGETaSUBARU

    New User

  • Members
  • PipPipPip
  • 88 posts
  • Kansas City, MO

Posted 18 May 2013 - 08:35 AM

attachicon.gif101_15461.JPGattachicon.gif101_15461.JPGThis is from a 96. Seems to be the same..

As shown with locking clip on top,

Left is yellow with a red stripe, right is white and the bottom is black.

 

O.you it looks correct, the part numbers for the upstream o2 sensor are the same on both years

 

Thank 



#8 mightGETaSUBARU

mightGETaSUBARU

    New User

  • Members
  • PipPipPip
  • 88 posts
  • Kansas City, MO

Posted 21 May 2013 - 01:37 PM

weird mine are White, White and black   :(



#9 ocei77

ocei77

    Eat, Live, Breath Subaru

  • Members
  • 554 posts
  • Monticello,NY

Posted 21 May 2013 - 04:32 PM

Not a big deal.  Sometimes they change wire colors between years.

As long as the left wire on top is the white one, all else follows in sequence.

 

O.



#10 mightGETaSUBARU

mightGETaSUBARU

    New User

  • Members
  • PipPipPip
  • 88 posts
  • Kansas City, MO

Posted 21 May 2013 - 06:24 PM

Not a big deal.  Sometimes they change wire colors between years.

As long as the left wire on top is the white one, all else follows in sequence.

 

O.

please explain in picture...  my brain needs pictures



#11 ocei77

ocei77

    Eat, Live, Breath Subaru

  • Members
  • 554 posts
  • Monticello,NY

Posted 21 May 2013 - 08:53 PM

I "assumed" the harness side pulled out.

I will have to pull it in the morning and see what goes to where on the sensor side.

 

O.



#12 ocei77

ocei77

    Eat, Live, Breath Subaru

  • Members
  • 554 posts
  • Monticello,NY

Posted 22 May 2013 - 07:31 AM

Attached File  O2 sensor wiring.jpg   28.87K   9 downloads

 

if the plug side pulled, the white wires go to the top  two pins. Black to bottom. They should still be in the correct orientation.

 

 

 

O.


Edited by ocei77, 22 May 2013 - 07:45 AM.


#13 mightGETaSUBARU

mightGETaSUBARU

    New User

  • Members
  • PipPipPip
  • 88 posts
  • Kansas City, MO

Posted 22 May 2013 - 10:09 AM

So it does not matter what order the whites go in, so long as the black is in position 3?  Ok thank you



#14 ocei77

ocei77

    Eat, Live, Breath Subaru

  • Members
  • 554 posts
  • Monticello,NY

Posted 22 May 2013 - 03:16 PM

One white goes to ground and the other goes to pin 38 on ecu., when mated.

I can't say it's gospel, but I don't think it will matter which goes where, since there are no other circuits in between or connecting, except ground.

For future ref:http://www.main.expe...u_manual_scans/

and http://opposedforces.com/parts/legacy/

 

O.


Edited by ocei77, 22 May 2013 - 03:20 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users