Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
* * * * - 1 votes

still have ny first subaru 86gl10 turbo


  • Please log in to reply
45 replies to this topic

#1 marcusgl10z28

marcusgl10z28

    USMB is life!

  • Members
  • 243 posts
  • tacoma wa

Posted 21 May 2013 - 09:13 PM

Ok so wanted to be able to keep track of my biuld for this car... this is a 86 gl10 turbo 5mt full time fwd w diff lock orange digi dash and rear discs... yes it origional... a guy at the subi dealer says its a very rare modle. I don't like rare but she is still kicking

Bought it in 2008 as a family car because I was having my first kid and I didn't want to get rid of my camaro z28..( this car has made me come to hate my camaro). Paid 200 bucks flat but anyways it was a rally car for pacific rally group it ran and drove at least knocked and ticked and the front was all smashed up ... it was emerald gree with a spongebob on the hood...

I found a parts car got the front end fixed paid 100 for the broken car and scrapped it for 200 , fixed the no charging issue... worn harmonic balancer bushing swapped to a solid one from the tb car... painted it flat black(ya that's the one as my user pic)... and it has always fired up no problems yes it always knocked. And ticked ... but ran every time... this car had been through alot...

Painted it white and drove it to montana and back 3 times at 80mph the whole way in 2011 it seen snoqalmie during blizzards both ways... and this car never skipped a beat...

Its been 7 years now.. and I've looked into making a camping trip to a place my father took me to when I was a kid... I now have 2 little guys and I want them to see it to for my pops.... except... there is a river in the way!!!

So that is what started my biuld... I cheated a bit and found a already swapped ej22 in a 93 loyal lifted... wiring was a horrific seen under the hood and the ecu was just chillin... I picked it up for 700 buck running driving and I drove it for a few monthes as a commuter befor I ripped out its heart and harness cleaned and straigned. Every thing...

Then had to say fairwell to the old faithfull(I swear I can't kill it!) Ea82t.
And I know some people may critisze for this swap but as to my knowledge... water and distributers do not mix well( I need to cross a river) don't worry a still uave everything to put it back.
The car is now up and fired up after the second day of the swap... feels like it has more power than a turbo motor...( I actually think it does btw). Runs like a champ... no guages.. gonna run aftermarket manuals and use velcro.. I. Don't want to chop into the origional wire harness much. ... ill upload some picks soon of this car as it sit...

Since I've bought this one.. I've owned 4 ea82 subis love some and canabalized others...
86 gl10turbo
90 loyal wagon 4wd
87 rx turbo 5mt
93 loyal sedan ej22 swap 2 in lift 30 in tires... it was alot of pounding and cutting

Ill update this post as go along... feel free to offer up suggestions or criticizm... I don't melt in the rain so say what ya want just don't be to vulgar... iand I apoligize for grammer.. I'm using a small phone key board to write this...lol

#2 soobie_newbie67

soobie_newbie67

    Eat, Live, Breath Subaru

  • Members
  • 471 posts
  • Kennewick

Posted 21 May 2013 - 09:29 PM

the ej22 does have more power. pics would be awesome too. your car sounds badass

#3 marcusgl10z28

marcusgl10z28

    USMB is life!

  • Members
  • 243 posts
  • tacoma wa

Posted 21 May 2013 - 10:58 PM

These are  the pics I promised, some had to be dug up. So here it is over the years.

Attached Files



#4 marcusgl10z28

marcusgl10z28

    USMB is life!

  • Members
  • 243 posts
  • tacoma wa

Posted 21 May 2013 - 11:02 PM

b

Attached Files



#5 marcusgl10z28

marcusgl10z28

    USMB is life!

  • Members
  • 243 posts
  • tacoma wa

Posted 21 May 2013 - 11:04 PM

Engine compartment of the wagon after the swap.

Attached Files



#6 soobie_newbie67

soobie_newbie67

    Eat, Live, Breath Subaru

  • Members
  • 471 posts
  • Kennewick

Posted 21 May 2013 - 11:20 PM

looks great dude. love that custom install of the bov on that ea82t. would have loved to have that on my old 88 gl-10

#7 marcusgl10z28

marcusgl10z28

    USMB is life!

  • Members
  • 243 posts
  • tacoma wa

Posted 21 May 2013 - 11:34 PM

j


Edited by marcusgl10z28, 02 June 2013 - 11:14 PM.


#8 marcusgl10z28

marcusgl10z28

    USMB is life!

  • Members
  • 243 posts
  • tacoma wa

Posted 29 May 2013 - 12:17 PM

Finally got the ej22 running properly... it seems to be driving ok so I drove it up to work and installed a 2 in lift I had laying around from my sedan and found some 205 75 14 hankook winter I pike tires... got a good deal ($80) but had to pull all the studs out and they are new... mounted the tires by hand and it was a pita to do but got ot all on the car... didn't even need an alignment and finall finished at 11pm Monday night... she should be getting fresh paint this weekend... we will see how that goes.lol

#9 marcusgl10z28

marcusgl10z28

    USMB is life!

  • Members
  • 243 posts
  • tacoma wa

Posted 29 May 2013 - 10:24 PM

:grin:  :banana:  :drunk:

Attached Files



#10 marcusgl10z28

marcusgl10z28

    USMB is life!

  • Members
  • 243 posts
  • tacoma wa

Posted 02 June 2013 - 10:58 PM

Step one... 2 inch lift

Attached Files



#11 marcusgl10z28

marcusgl10z28

    USMB is life!

  • Members
  • 243 posts
  • tacoma wa

Posted 02 June 2013 - 11:07 PM

This has been rough week of wiring and working oit bug in the ej swap lots of bad fuses and an irritating at best high idle ussue but Got the paint on... I decided to shoot it with dark forest green aircraft paint... it turned out alright and the car has a lot of dents in it buts more of a 20/20 paint job anyways and that was all I wanted... now it looks like some pavement pounder and I can't have that so trail pics and mud next weekend.

#12 marcusgl10z28

marcusgl10z28

    USMB is life!

  • Members
  • 243 posts
  • tacoma wa

Posted 02 June 2013 - 11:11 PM

m

Attached Files



#13 marcusgl10z28

marcusgl10z28

    USMB is life!

  • Members
  • 243 posts
  • tacoma wa

Posted 07 June 2013 - 08:57 PM

Bought a cheap rump roast reese roof rack from walmart... not sure if I'm gonna return it and just make my own. Its loud and creates a considerable amount of down force almost impossible to close the sun roof at freeway speed!!

#14 marcusgl10z28

marcusgl10z28

    USMB is life!

  • Members
  • 243 posts
  • tacoma wa

Posted 11 June 2013 - 11:37 PM

updates and wheeling pics... i really wand a bigger lift but this will do for now... muds sand dunes hill climbes and oh ya did i say mud... had to take it easy as i dont have skid plate yet but it was still a blast :headbang:

Attached Files



#15 marcusgl10z28

marcusgl10z28

    USMB is life!

  • Members
  • 243 posts
  • tacoma wa

Posted 17 June 2013 - 11:40 PM

So still daily driving the wagon... and I've worked out a few more bugs... high idle fixed by turning the adjustment on the top of the iac valve and fixed the hard starting issue... coolent temp sensor was unplugged...my bad...

Both front axel inner boots are already blown... and I'm thinking the weird noise in my front end is either cvs or bearing all of which need to be done now anyways... my car is almost as high maintainance as the girl but atleast it dosent talk back...lol

#16 marcusgl10z28

marcusgl10z28

    USMB is life!

  • Members
  • 243 posts
  • tacoma wa

Posted 23 June 2013 - 07:28 PM

Weird hesitation issue... like tye engine is starving for fuel... found a forgotten pcv line after an iacv swap on the rh cam cover... oops... but I think I got some water in it as was cleaning the engine and didn't seem to notice it... and I'm hoping its not much so ima drain the oil and if there is water... I'm changing it if not then its going right back in...

#17 marcusgl10z28

marcusgl10z28

    USMB is life!

  • Members
  • 243 posts
  • tacoma wa

Posted 05 August 2013 - 01:22 AM

got my parts car cut up as i seem to have lost the title... so i figured no need for a title if the pile of metal isnt really a car anymore but just mere fragments...right?... blistered hands and shards of glass in my face... i had a blast... wish i had a torch to do it!

 

anyways was driving like a madman as usual and i jumped the wagon while going into the parking lot at work... and i dont mean like "weeeeeeee"... what mean is holy $hi#!!!! son of a b#$ch... im gonna roll it!!! kind of jumped it, so this all ended in sway bar bushings shearing from the car, a dog leg rear pass wheel and a front end alignment. it hurt..  :banghead:  but back on the road and now it drives even better after my pocket magically emptied at leshwab.... 

Attached Files



#18 MR_Loyale

MR_Loyale

    20 Years of Ownership. 94-14

  • Members
  • 915 posts
  • Seattle

Posted 05 August 2013 - 01:43 AM

got my parts car cut up as i seem to have lost the title... so i figured no need for a title if the pile of metal isnt really a car anymore but just mere fragments...right?... blistered hands and shards of glass in my face... i had a blast... wish i had a torch to do it!

 

anyways was driving like a madman as usual and i jumped the wagon while going into the parking lot at work... and i dont mean like "weeeeeeee"... what mean is holy $hi#!!!! son of a b#$ch... im gonna roll it!!! kind of jumped it, so this all ended in sway bar bushings shearing from the car, a dog leg rear pass wheel and a front end alignment. it hurt..  :banghead:  but back on the road and now it drives even better after my pocket magically emptied at leshwab.... 

 

Les Schwab??? :o   Shaking my head.



#19 marcusgl10z28

marcusgl10z28

    USMB is life!

  • Members
  • 243 posts
  • tacoma wa

Posted 18 December 2013 - 06:27 PM

Junk yard weekend!!! Gonna beef up my suspension... I'm 150 lbs the girl is 100 lbs and my kids together are 70lbs and this makes the car sag!!! Enraged!!! There has to be better... I'm gonna find it if it!... ill post what I find

#20 SmashedGlass

SmashedGlass

    Eat, Live, Breath Subaru

  • Members
  • 669 posts
  • From CO, stuck in FL

Posted 18 December 2013 - 09:37 PM

Brand new stock springs would fix that.



#21 marcusgl10z28

marcusgl10z28

    USMB is life!

  • Members
  • 243 posts
  • tacoma wa

Posted 18 December 2013 - 11:14 PM

Brand new stock springs would fix that.


Oops

Edited by marcusgl10z28, 24 December 2013 - 04:33 PM.


#22 SmashedGlass

SmashedGlass

    Eat, Live, Breath Subaru

  • Members
  • 669 posts
  • From CO, stuck in FL

Posted 18 December 2013 - 11:53 PM

Wow guy, I just offered the first answer that came to mind. You butthurt with amazing ease.



#23 marcusgl10z28

marcusgl10z28

    USMB is life!

  • Members
  • 243 posts
  • tacoma wa

Posted 19 December 2013 - 11:11 AM

thanks for the well educated information you provided me with.

Edited by marcusgl10z28, 19 December 2013 - 11:20 AM.


#24 marcusgl10z28

marcusgl10z28

    USMB is life!

  • Members
  • 243 posts
  • tacoma wa

Posted 24 December 2013 - 11:26 AM

Water pump gasket failure as of this morning... I knew that's what I've been smelling the last couple weeks... bummer gonna be a long day after work.

#25 marcusgl10z28

marcusgl10z28

    USMB is life!

  • Members
  • 243 posts
  • tacoma wa

Posted 24 December 2013 - 11:48 AM

Wow guy, I just offered the first answer that came to mind. You butthurt with amazing ease.


Bad day my bad... my apologies.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users