Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

heartless & madkow's 98 Forester


  • Please log in to reply
27 replies to this topic

#26 heartless

heartless

    Do YOU Subaru?

  • Members
  • 2,691 posts
  • North Central Wisconsin

Posted 04 August 2013 - 07:46 PM

Well - "new" motor is in, everything connected, fluids filled...snag the battery out of my dd and pop that in...turn the key...and it barely turns over... :banghead:  was really hoping to hear it fire today.

 

got full power at the starter, so it isnt cable/power related, it does turn over - just very, very slowly, and the starter itself sounds like crap - a high pitched whining noise...so I will be calling the local starter/alternator shop to see if they can do a rebuild & how much it is gonna cost...

 

also found out today that apparently the twit didnt bother disconnecting either of the O2 sensors before dropping the exhaust, ripping the wires right out of the plugs, and doing other damage to the rear one :mad:



#27 heartless

heartless

    Do YOU Subaru?

  • Members
  • 2,691 posts
  • North Central Wisconsin

Posted 14 August 2013 - 08:38 AM

well, turns out that the starter is junk - the shop called yesterday - his exact words were "this starter is beyond rebuilding" <_< I guess with over 364K on the car & probably the original starter, it was bound to happen.

 

New starter has been ordered from Rockauto, just have to wait for it to get here.

 

got the new O2 sensors a few days ago - just need to get out there and install them.

 

really hoping to have this car up & running soon since we now have another project to play with... :brow:



#28 heartless

heartless

    Do YOU Subaru?

  • Members
  • 2,691 posts
  • North Central Wisconsin

Posted 01 October 2013 - 06:49 AM

Well - hate to say it, but this car just has too many issues and I give up. I think there is/was just too much damage from the fire.

 

New starter got it turning over good - replaced fuel pump assembly as well, but it still doesnt get fuel up to the engine - not sure why, and dont really have the time to mess with it anymore since I started working again.

 

Wont be a total write off tho - struts & springs will be going into the 95 Legacy wagon - as well as the complete timing kit, new plug wires, plugs, etc, etc...

Once the strut swap is complete, I will be stealing the 15" alloy wheels as well. (will have to replace one of them as it has a nasty dent in the edge - its a wonder it even holds air)

 

I hate giving up on a car - especially one that is in nice physical condition - but I dont know what else to do with it - short of replacing the complete wiring harness...and that would be one heck of a job.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users