Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

2003 Forester EJ251 Engine swap into a 2000 OBS

Engine swap EJ25 EJ22

  • Please log in to reply
39 replies to this topic

#26 mrjim

mrjim

    Advanced Member

  • Members
  • PipPipPip
  • 33 posts
  • Ogallala, NE

Posted 11 September 2013 - 08:58 AM

So, the engine's in and everything is hooked up. 

We tried to start it last night and the engine cranks but doesn't fire. Not even a sputter.

  • The spark plugs and wires are new.
  • I'm pretty sure fuel is reaching the injectors. We pulled the fuel line that leads into the engine (right after the fuel filter) and gas came spurting out, so there's definitely fuel pressure.
  • We disconnected and reconnected all the wiring harness plugs.
  • We double checked to see that no vacuum hoses had been forgotten.
  • Tried both pumping the throttle and holding it half way in while attempting to start.
  • Pretty sure the timing is right.  It came already assembled on the new engine. http://i.imgur.com/FN44v2M.jpg

Any other thoughts?  Is there a fuse or circuit breaker I need to check, replace, or reset?



#27 ivans imports

ivans imports

    1000+ Super USER!

  • Members
  • 2,947 posts
  • lumby bc canada

Posted 11 September 2013 - 09:06 AM

did you use the crank and cam gears off old engine ? is two diff types mabee crank senser not pluged in all the way or cam senser. I did a 98 impreza 22 yesterday had broken the idler bolt belt was still in time on cams and hitt all 16 valves all bent took me 4 hours to r@r valves and reinstall engine is not to bad to replace valves. Your old engine could be fixed



#28 mrjim

mrjim

    Advanced Member

  • Members
  • PipPipPip
  • 33 posts
  • Ogallala, NE

Posted 11 September 2013 - 10:23 AM

I double checked with the shop that sent me the new engine and he said that my EJ22 cam pulley and the EJ251 cam pulley are the same.  He suggested that I pull spark plug wire #1 from the coil pack and lay it close to the connection and try to start again.  Whether it arcs or not should tell us if we're getting a spark.



#29 Fairtax4me

Fairtax4me

    Su bah roo'n

  • Gold Subscribers
  • 8,774 posts
  • Charlottesburg, VA

Posted 11 September 2013 - 11:20 AM

Need to verify (by looking) that the drivers cam and crankshaft timing sprockets are the same. They changed the design of the sprocket around that time.
Old crank sprockets had 6 teeth around the outer edge, new ones have something like 25.
Old cam sprockets had 7 notches on the back, new ones I'm not sure how many but IIRC they are similar to the crank sprocket.

Tooth count on the sprockets needs to be correct or the ECU doesn't know how to time ignition and fuel.

#30 mrjim

mrjim

    Advanced Member

  • Members
  • PipPipPip
  • 33 posts
  • Ogallala, NE

Posted 11 September 2013 - 07:36 PM

I verified that both engine's crank sprokets have 24 teeth.  I'm guessing this means the cam sprokets are the same as well.  The shop also verified that they test all engines before sending them out so unless just the cam sprocket is different, the engine is definitely not the problem.

 

I pulled plug wire #1 and set it very close to the #1 connector on the ignition coil and tried to start. 

No arc.  So this means we are definitely not getting a spark.  I checked the resistance between 1&2 and 3&4 and both read 12.6 Kohms (the shop manual I've been using said they should read around 12.8K so I think I'm good there).  I did note however that #2 was darker looking than the other 3 connection points.  I don't think this would be why I didn't see an arc on #1 though.

 

I guess I'll just have to start following wire paths back from there then... <_<

 

Any other suggestions in light of this new information? :unsure:



#31 mrjim

mrjim

    Advanced Member

  • Members
  • PipPipPip
  • 33 posts
  • Ogallala, NE

Posted 11 September 2013 - 08:06 PM

Also the EJ22 engine cam sprocket has 2 notches so it must be the new type as well.



#32 mrjim

mrjim

    Advanced Member

  • Members
  • PipPipPip
  • 33 posts
  • Ogallala, NE

Posted 13 September 2013 - 05:37 PM

Another update: We connected one of the old spark plugs and wires to the ignition coil and did see a spark. We also connected an led to one of the fuel injector plugs and it flashed when trying to start. So there's gas in the fuel lines and the injectors and spark plugs are firing. I'm pretty much beside myself as to why it would not be starting.

#33 mrjim

mrjim

    Advanced Member

  • Members
  • PipPipPip
  • 33 posts
  • Ogallala, NE

Posted 13 September 2013 - 07:13 PM

Okay, I think I've found the problem.

And it's not something simple.

 

Look at this picture I snapped of the manual.
http://i.imgur.com/01YtESt.jpg


It's not just a possible difference of 2200cc vs 2500cc sprockets. It's a difference of calif. vs non calif. crank sprockets. Guess what? My old engine looks like the calif. one and the picture of the new engine looks like the other.

New: http://i.imgur.com/FN44v2M.jpg
Old: http://i.imgur.com/CA87d9N.jpg

 

This means we have to tear it down that far, swap them, realign the timing belt, and put it all back together.

 

Ouch. I guess that's what I get for assuming the right sprockets came with the engine.  ESPECIALLY after all the warnings you guys gave me about it.  You'd think I would have double checked! It would have been SO easy to check when I had both engines out too. 

 

Please let me know for sure if you agree with my conclusion. 

 

Also, I'm guessing since the #of ticks is so different, the computers are different as well.  Will I have a problem with the EJ22 california spec sprocket and computer on the EJ25 engine?  Would it be easier to try and find a non cal spec computer and leave the sprockets that are already on there?



#34 Fairtax4me

Fairtax4me

    Su bah roo'n

  • Gold Subscribers
  • 8,774 posts
  • Charlottesburg, VA

Posted 13 September 2013 - 09:46 PM

There are 24 drive teeth on the crank sprocket no matter what engine it's one. 48 drive teeth on the cam sprockets. The drive teeth are not the issue (as you've now seen in the pics above), its the teeth on the outer edge that make up the reluctor for the cam and crank sensors.

What you need, are the sprockets that match the ECU that's in the car.
The ECU doesn't care about displacement, it will work for either 2.5 or 2.2 engine, doesn't care which it is.
What it does care about is that it gets the proper signals from the cam and crank sensors, which means it needs the sprockets from its original engine.

Every 2.2 and 2.5 used the 6 tooth crank reluctors at one point. It's not an issue of 2.2vs 2.5 or Cali- vs non-Cali emmissions. Subaru decided (actually it was probably decided for them by the EPA) one year that they needed more accurate readings of the crank and camshaft angles so they could refine the ignition and fuel timing, and have more positive misfire recognition. Then all of their engines were switched to the new style sprockets, whether they were 2.5, 2.0, turbo, or n/a.

#35 mrjim

mrjim

    Advanced Member

  • Members
  • PipPipPip
  • 33 posts
  • Ogallala, NE

Posted 13 September 2013 - 10:09 PM

I guess I'm still having trouble understanding why displacement doesn't matter with the ECU.  Shouldn't you be injecting more fuel into a larger displacement engine?  If your volume is greater but the amount of fuel is the same, it seems to me like you'd have less power. :huh:

 

Also I see what you're saying about the sprockets but it seems a little odd to me that the shop manual in the screen shot I posted shows one that looks exactly like my old one (and says it's california spec) and the other looks exactly like the new one (and says it's non-california spec).  Did the change you're talking about originate in california?  And get adopted into the rest of the line later?  I've noticed this in a couple of other places too.  It shows 2 different intakes (one cal, one not), and 2 different throttle bodies (again, cal and not cal).  My intake matches the cal intake but my throttle body matches the non cal.  Also, I'm not sure this makes a difference but the car was originally sold new in South Dakota.  Would seem a little odd to me that a new California spec car be sold in SD. 

 

Edit: I realize California has stricter emission standards so this is why I was/am wondering if the change was first implemented there.

 

Edit #2: Does this also mean the crank sprocket on the new engine is the older model crank sprocket?


Edited by mrjim, 13 September 2013 - 10:13 PM.


#36 Fairtax4me

Fairtax4me

    Su bah roo'n

  • Gold Subscribers
  • 8,774 posts
  • Charlottesburg, VA

Posted 13 September 2013 - 11:05 PM

That's what it has a MAF or MAP sensor, and an oxygen sensor. To the ECU the difference in displacement between a 2.2 and 2.5 matters less than a 4000 ft change in altitude.

Your old and new sprocket pics are backwards. Perhaps this is where some of your confusion is coming from. The NEW style sprocket has more teeth.

They probably did start using the new style on CA spec vehicles, but there are plenty of other things Subaru first used on CA cars and eventually became standard for all.

Edited by Fairtax4me, 13 September 2013 - 11:14 PM.


#37 mrjim

mrjim

    Advanced Member

  • Members
  • PipPipPip
  • 33 posts
  • Ogallala, NE

Posted 15 September 2013 - 10:58 PM

Great, thanks for your help and the explanation. I've pulled a few things back out and am about to swap the sprockets. I put the car in gear to hold the crank position and then removed the belt. I realize now that I probably should have loosened the cam sprocket bolt before taking the belt off though. The shop manual assumes I've got this special fork/breaker-bar tool to hold it in place while removing the bolt. Any recommendations as to what else I can (or should) use to get it off?

#38 johnceggleston

johnceggleston

    Lite Master of the Subaru

  • Gold Subscribers
  • 6,319 posts
  • Virginia

Posted 16 September 2013 - 09:27 AM

the common knowledge here is that the 99 - 00 ej22 is interchangeable with the 00 - 03/4 ej25.

and i understand that and the reasons behind it.

 

but i have read somewhere that you cannot swap a maf engine with a different displacement into a non-maf car.

the computer has ''fixed''? fuel something or other in a non-maf car, i don't really know or remember.

(i also do not know enough to know if this is true. or if it is for some car makers if it is for subarus also)

apparently maf cars / ECUs have adjustable , not ''fixed'' programming .??????????

 

but since blocks and heads are mostly dumb, you can do the swap if you use the ORIGINAL intake manifold.

this makes the ''new'' engine the same as the old engine was.

 

so to get this engine to run in your car, swap

the cam sprocket, driver side

the crank sprocket,

and the intake manifold.

 

if you do this there is no way the ECU can know that there is a different block or heads.

 

but if the car is non-maf, will the ECU be able to adjust for the different displacement?

does the 00 OBS ej22 have a MAF?

 

i'm not trying to confuse the issues with this swap,

i'm just trying to learn something about ECUs and the MAF system.


Edited by johnceggleston, 16 September 2013 - 09:34 AM.


#39 mrjim

mrjim

    Advanced Member

  • Members
  • PipPipPip
  • 33 posts
  • Ogallala, NE

Posted 18 September 2013 - 08:46 AM

Update:

 

Got the sprockets swapped out and everything back together.  It runs!  Wow that new clutch is grabby.  Thanks again to everyone for your help, I feel SO dumb that I didn't even compare the sprockets on the engines when they were both out after all the warnings you had given me.  Guess I just thought the guy who sold me the engine knew what I was talking about and took care of it (said it would be no problem).

 

Anyways, now that it's running and everything I've found that I probably need a new battery as well.  I hooked it up to a 15A charger last night before bed and the garage smelt like rotten eggs this morning and the charge current was still around max.  I could also hear the battery sizzling.

 

Also johnceggleston, I did indeed keep the original intake.  From all the pictures I've seen in the shop manual, it looks like the intake on the EJ25 and EJ22 are the same though.  I think you're right about the ECU not knowing that a different engine is present.  Again, I'm not 100% understanding how the displacement doesn't matter (since I'd think a larger cylinder would also need more fuel and air) but from what Fairtax4me has said it sounds like the ECU uses sensors to control the amount of fuel and air.  So I'm guessing it adjusts itself automatically based on fuel, air and exhaust pressures or flow rates (whatever the cylinder size) given that the injectors and intake can supply enough.



#40 ivans imports

ivans imports

    1000+ Super USER!

  • Members
  • 2,947 posts
  • lumby bc canada

Posted 18 September 2013 - 09:44 AM

Have been there man but its ushaly comeing from a shop on a tow truck we putt the motor in now it wont start but the old one ran !







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users