Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

79 GL Wagon front end crunch-need some parts

parts needed 1979 subaru

  • Please log in to reply
23 replies to this topic

#1 def

def

    New User

  • Members
  • PipPip
  • 11 posts
  • Leavenworth, WA

Posted 21 July 2013 - 03:59 PM

Oops.  Looking for some parts and any advice too (of course).

 

This is great little EA71 sub with brown paint (color 13) and racing stripes.

 

Radiator

 

Front Bumper

Right front fender

Hood

 

Right headlight assembly

Grill

 

 

Possibly both fans.  One electric one mounted on engine.  (Or just the blade assembly?) Got squashed a little against radiator.  May work, but need to tear down first to see.

 

I'm not sure about the front end top cross member which is bent in on the Right (pass side).  Thats what pushed in the radiator.  Can that be replaced or just pulled back out?

 

 

Thanks...

 

David

 

 



#2 moosens

moosens

    Psychotic Subathusiast

  • Members
  • 1,310 posts
  • Bridgeport CT

Posted 23 July 2013 - 01:24 AM

GL as in four headlights?

 

Regular chrome bumper or you looking for the 4WD optional iron 2x4 with the loop?

 

Sounds like you have a 4WD from the two fans.

 

Danny W - "drivesubies" on here and "dannybreadman" on eBay has some new parts that would help you. My storage is hell right now but I could in the near future help you out too. My stuff is mostly good used - no junk , no rust.

 

The radiator support can usually be banged back to decent enough shape so everything lines up well enough. All depends on how bad it is. You can cut and replace those as well , and Danny should have one.

 

You'll be ok soon , I'm sure. Doesn't sound too bad.



#3 ivans imports

ivans imports

    1000+ Super USER!

  • Members
  • 2,954 posts
  • lumby bc canada

Posted 23 July 2013 - 09:24 AM

gen 1 or gen 2 ?



#4 Subruise

Subruise

    Official Party Pooper

  • Members
  • 1,502 posts
  • pierce county

Posted 23 July 2013 - 11:59 PM

gen 1 or gen 2 ?

good question Ivan, ive got parts off a gen 2 79 wagon with a ea71...fenders, bumper. somehow i feel this one is a gen 1, even though i have no reason to.



#5 ivans imports

ivans imports

    1000+ Super USER!

  • Members
  • 2,954 posts
  • lumby bc canada

Posted 24 July 2013 - 09:30 AM

have a compleate 77 wagon if is gen 1



#6 def

def

    New User

  • Members
  • PipPip
  • 11 posts
  • Leavenworth, WA

Posted 23 August 2013 - 09:16 PM

Thanks for all the replies! I'm such a noob on the forum, that somehow I missed all the replies until now.  I'll answer your questions as best I can.

 

I just got to the tear down today and hoping to be back up and running soon with your help.

 

I'm not sure how to tell Gen1 from Gen2.  Interested in knowing...

 

 

It's a 21-EA71GC engine.  4WD.  4 Spd manual. 

4 headlight, chrome bumpers. 

Has AC, which was not working.  Will need new condensor too, or take out of service.

 

 

Will need radiator, passenger side headlight (dual) assembly,  and front passenger side turn signal assembly (two lights) at minimun to make it run and legal. 

 

Love this rig.  Hate to see it sitting collecting dust.  It's my daughter's daily driver, so the sooner the better!  Thanks again.



#7 def

def

    New User

  • Members
  • PipPip
  • 11 posts
  • Leavenworth, WA

Posted 23 August 2013 - 11:17 PM


good question Ivan, ive got parts off a gen 2 79 wagon with a ea71...fenders, bumper. somehow i feel this one is a gen 1, even though i have no reason to.



#8 ivans imports

ivans imports

    1000+ Super USER!

  • Members
  • 2,954 posts
  • lumby bc canada

Posted 24 August 2013 - 10:29 AM

what parts ? have some sounds like gen 1 to me four round headlights?



#9 biffanyus

biffanyus

    79 Brat

  • Members
  • 991 posts
  • West Palm Beach, FL

Posted 24 August 2013 - 10:45 AM

Best that you post some pics up. Sounds like a little confusion here but if its a 79 wagon body style it should be like the gen1 brats style. Post pics is best though.



#10 def

def

    New User

  • Members
  • PipPip
  • 11 posts
  • Leavenworth, WA

Posted 24 August 2013 - 10:59 AM

what parts ? have some sounds like gen 1 to me four round headlights?

Yes,  Four round headlights.  Is that how to tell Gen1 or 2.  Can't find a thread that explains this.

 

Need headlight and parking/turn signal assemblies for passenger side and radiator to start.  Front bumper (chrome), Grille.  Maybe some body parts.



#11 def

def

    New User

  • Members
  • PipPip
  • 11 posts
  • Leavenworth, WA

Posted 24 August 2013 - 11:14 AM

Don't know why I can't post photos.  Any ideas?  I can't put photos or a hyperlink.  I'll try pasting plain text links below.

 

https://www.dropbox.....57 (Small).jpg

https://www.dropbox....Sub (Small).bmp

 

https://www.dropbox....q0ae/HzBhAok6-L



#12 def

def

    New User

  • Members
  • PipPip
  • 11 posts
  • Leavenworth, WA

Posted 24 August 2013 - 11:30 AM

OK.  That seems to have worked.  The third link will take you to a folder with pics of the damage and a couple pics to see the overall body style.



#13 Subruise

Subruise

    Official Party Pooper

  • Members
  • 1,502 posts
  • pierce county

Posted 24 August 2013 - 01:24 PM

gen one stage two



#14 moosens

moosens

    Psychotic Subathusiast

  • Members
  • 1,310 posts
  • Bridgeport CT

Posted 24 August 2013 - 05:33 PM

Tought to say from here but looks "bangable" for the radiator support. Pics looking down into the engine bay and/or of the front unibody "rails" would show more of the extent of the hit. It doesn't look bad to me if the fender didn't buckle up. So I'd say get stripping it and bang that radiator support back into shape. At least try. Good luck.



#15 bertmann73

bertmann73

    USMB is life!

  • Members
  • 163 posts
  • las vegas

Posted 24 August 2013 - 06:08 PM

too bad your not invegas cuz i have 3 spare radiators



#16 bertmann73

bertmann73

    USMB is life!

  • Members
  • 163 posts
  • las vegas

Posted 24 August 2013 - 06:13 PM

Also have spare set of headlight mounting brackets and turn signal lense.

that is a very nice wagon and worth fixin....dont look too bad to me.



#17 def

def

    New User

  • Members
  • PipPip
  • 11 posts
  • Leavenworth, WA

Posted 25 August 2013 - 10:47 PM

Thanks everyone. Good to have some help. Let me know what you might want for parts and shipping or I can message you if that's better.

#18 Subieguy

Subieguy

    Subaru on the brain!

  • Members
  • 903 posts
  • Paso Robles, California

Posted 26 August 2013 - 12:34 AM

If no one helps you with the turn signal assembly I can help. I have a bunch of them complete sitting around



#19 def

def

    New User

  • Members
  • PipPip
  • 11 posts
  • Leavenworth, WA

Posted 06 September 2013 - 04:31 PM

Had a good day, yesterday.  Finally pulled the radiator mount out pretty straight so, ready for some parts to see how close I got.

 

Just sent some PM's to those offering parts. 

 

I'll post more pics in the dropbox link above of the progress  Still don't know why I can't post pics direct.

 

Thanks everyone!

 

David



#20 dn69141

dn69141

    New User

  • Members
  • PipPip
  • 10 posts
  • Sidney, Nebraska

Posted 02 October 2013 - 09:59 AM

How goes the progress? My 79 Wagon hasn't had the fans working since the day I bought it. So far haven't needed them though I don't really drive it more than 10 minutes, only time I have ever seen it where I was worried was when I was parked outside in 100 degree heat and let it idle for about 20 minutes while I was inside. When I got back to the car the temp gauge was just over half way. Other than that, it does fine with them not working.. so far. 



#21 ivans imports

ivans imports

    1000+ Super USER!

  • Members
  • 2,954 posts
  • lumby bc canada

Posted 03 October 2013 - 09:27 AM

I still have a grill here but not shure how to ship it is big got any freinds up this way ? i think shiping would be pricy on sutch a bulky item



#22 def

def

    New User

  • Members
  • PipPip
  • 11 posts
  • Leavenworth, WA

Posted 11 October 2013 - 01:55 AM

How goes the progress? My 79 Wagon hasn't had the fans working since the day I bought it. So far haven't needed them though I don't really drive it more than 10 minutes, only time I have ever seen it where I was worried was when I was parked outside in 100 degree heat and let it idle for about 20 minutes while I was inside. When I got back to the car the temp gauge was just over half way. Other than that, it does fine with them not working.. so far. 

 

It is going good.  Just started putting things back together.  Been a long project mostly due to time.  I just did some rust abaitment work today and will hopefully actually start putting parts back in tomorrow.

 

I think both my fans will survive the crash and run again.  But I agree that it could run with just one.  After the crash I drove it home with the both fans disconnected because they were suck in the radiator. 



#23 def

def

    New User

  • Members
  • PipPip
  • 11 posts
  • Leavenworth, WA

Posted 11 October 2013 - 01:57 AM

I still have a grill here but not shure how to ship it is big got any freinds up this way ? i think shiping would be pricy on sutch a bulky item

 

Thanks, but I don't think I can get up there at this time.  I haven't got a grill yet, but my local wrecker says they can get one.  I guess I'll have to give them a try.



#24 ivans imports

ivans imports

    1000+ Super USER!

  • Members
  • 2,954 posts
  • lumby bc canada

Posted 12 October 2013 - 10:29 AM

is just sitting here if you cant find one







Also tagged with one or more of these keywords: parts needed, 1979 subaru

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users