Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Headlight trouble, '85 Brat


  • Please log in to reply
32 replies to this topic

#26 jonas

jonas

    Subaru Nut

  • Members
  • 984 posts
  • Oakridge

Posted 03 August 2013 - 04:15 PM

I just know when I fix this it will be something incredibly simple. Right?



#27 pressingonward

pressingonward

    USMB Regular

  • Members
  • PipPipPip
  • 90 posts
  • Battle Ground

Posted 04 August 2013 - 11:35 AM

I can almost guarantee you wired the H4s wrong. You have to change the wiring at the light because it is different than for the stock sealed beams. I had the same issues with my BRAT when I got it.

 

Here's my thread on the topic:

http://www.ultimates...rd#entry1052484

 

I can take a picture of my headlight connector if you need to see which wires go where. Otherwise you can just get an h4 bulb pinout diagram off of Google



#28 jonas

jonas

    Subaru Nut

  • Members
  • 984 posts
  • Oakridge

Posted 04 August 2013 - 01:15 PM

OOPS! posted in wrong thread! Sounds exactly like my problem except i havent replaced my bulbs. I did plasti-dip my headlight retaining rings but i did nothing to the actual buckets. Would that be messing with the grounds? Maybe i just have crappy tired pins and need to re-pin? Everything was working fine for about a week after i dipped. thatnks for the imput. Every little bit gets me closer.



#29 jonas

jonas

    Subaru Nut

  • Members
  • 984 posts
  • Oakridge

Posted 11 August 2013 - 10:00 AM

Good morning guys and gals! So I still haven't fixed my headlight problem. Been over every inch of my Brat. We have gotten very close. :wub:  Really all im left with is a faulty switch solution.

 

I have a switch from an '80 (thanks Mikaleda!) I could use, but the pins on the '80 switch harness are set up differently than the '85.

Now my question is if I re-pin the '80 harness so the wires correspond to the '85 pins, will this work or am I asking for trouble? This is really starting to suck. I love driving my Brat and my wife wants her Jeep back. B)



#30 Gloyale

Gloyale

    It's a sickness

  • Members
  • 9,048 posts
  • Corvallis, OR PNW

Posted 11 August 2013 - 09:24 PM

The relay for the Hellas is tied into the headlights? correct? so that they go out when the HI beams are on?  correct.

 

I believe the problem lies there.

 

What circuit is the coil of the relay tapped into (85,86 terminals)

 

And where is the 30 terminal supplied power from?

 

I guess I need to undertand how you've got the relay trigged. 

 

Also, how are you determining your headlight relays to be fine?


Edited by Gloyale, 11 August 2013 - 09:31 PM.


#31 jonas

jonas

    Subaru Nut

  • Members
  • 984 posts
  • Oakridge

Posted 12 August 2013 - 02:05 AM

The hellas are not wired in ATM. I just had them wired from the battery, hadn't done a permenant install yet. I swapped the headlight relays with the ones from my '84. No change. I can't borrow the switch from the '84 because a couple months back the plastic male/female connector on the '85 headlight switch harness was toast, so i took that part out. I dont want to cut up my '84 switch.



#32 jonas

jonas

    Subaru Nut

  • Members
  • 984 posts
  • Oakridge

Posted 18 August 2013 - 12:46 PM

Welp, gonna put it back together today. There is a shop close to work that I've noticed gen 2's at occasionally. Thanks everyone for all the imput. Unfortunately my problem wasn't resolved. I'll let you all know what happens.



#33 Mykeys Toy

Mykeys Toy

    Subaru Master

  • Members
  • 1,997 posts
  • South Prairie, Wa

Posted 18 August 2013 - 02:15 PM

please do then maybe we can add it to the old gen database.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users